LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Setting up SCIM (https://www.linuxquestions.org/questions/slackware-14/setting-up-scim-327114/)

Kenji Miyamoto 05-25-2005 06:31 PM

Setting up SCIM
 
I recall that you have to add something to your .xinitrc file to get SCIM to start when X does, but I forgot what it was. Does anybody else know?

Also, I can't seem to be able to read any Japanese character sets with UTF at the moment; should I be concerned?

Kenji Miyamoto 05-25-2005 08:10 PM

I got everything installed, but Ctrl+Space doesn't activate it.

Also, even with the FrontEnd Gtk font set to Code2000, it can't display the Unicode. The same font works in Firefox. What's going on?

killerbob 05-25-2005 10:04 PM

I wrote a howto recently that should explain how to do it.

http://killerbob.ca/howto/japanese.html

がんばってね。
(and I know you can't read that. it's because you don't have a Japanese font installed. That is also explained in the howto. :))

Kenji Miyamoto 05-26-2005 12:10 AM

Actually, I've recently installed Arial Unicode MS and Code2000, so I can read it. (Isn't Code2000 the coolest?)

From past experience I've found that adding "scim -d" to .xinitrc also works; it loads completely and is operable within at least KDE.

NOTE: Beaver still complains abotu the "not supported" language when I enter Ctrl+Space. Do you think that the fact I'm using FVWM2-devel at the moment has something to do with it?

killerbob 05-26-2005 07:40 AM

If you install skim, KDE will load it automatically. You don't need to load it from .xinitrc or anything else.

As for FVWM, I honestly don't know. I tried it once, a while ago, and decided I didn't like it, and haven't even considered it since. Likewise, I've never used Beaver, so I can't answer that question. :(

Kenji Miyamoto 05-26-2005 10:54 PM

I have SCIM started as a daemon and the icon in the system tray, yet it still won't come up with the trigger hotkeys. What's going on?

killerbob 05-27-2005 07:07 AM

Did you edit the exports in /etc/profile.d/lang.sh?

You need these variables to be set, as well, else the IM won't actually be used, even if it's installed.

Code:

        export LC_CTYPE=ja_JP.utf8
        export XMODIFIERS=@im=SCIM
        export GTK_IM_MODULE=scim
        export QT_IM_MODULE=scim


Kenji Miyamoto 05-27-2005 04:43 PM

I copied it into /etc/profile.d/lang.sh, and it still doesn't work.

killerbob 05-27-2005 05:18 PM

Have you tried other WM's, or just FVWM?

And do you have Anthy installed? SCIM is useless without a language system installed. For Japanese, you need Anthy.

gbonvehi 05-27-2005 05:19 PM

You've to relogin so those exports take effect.

Kenji Miyamoto 05-27-2005 05:22 PM

I do have Anthhy and SCIM-Anthy installed. I've been trying it on KDE-3.4.0 for the past 24 hours or so. It does work with Skim, though.

For some reason, it doesn't seem to allow typing within the current window. It either uses a little side window that pops up or doesn't display until "space". How do I set it up so the Romaji and typing appear in the text area I'm typing in?

killerbob 05-27-2005 06:24 PM

You need to enable On-The-Fly mode, which will require a logout/login to take effect.

Right-click on your SCIM/SKIM icon in the system tray, and go to SCIM setup. Under Front End, go to X Window. Check the box that says "On The Fly". Apply, OK, Close, etc.

Logout, and log back in, and it should work.

Kenji Miyamoto 05-27-2005 07:28 PM

I have "On the Spot" enabled, and I just did reboot the system. Still, without the window option enabled, it doesn't enter the text dirlectly into the text area.

shilo 05-28-2005 04:12 AM

Maybe somewhat OT, but:

Quote:

がんばってね。
(and I know you can't read that. it's because you don't have a Japanese font installed. That is also explained in the howto. :))
I don't recall ever installing Japanese fonts, and I can see this just fine (using Firefox, Slackware -current, dropline Gnome). Is this not normal?

killerbob 05-28-2005 06:53 AM

The font may have been installed by your Gnome installation... I know from experience that a regular installation of Slackware (at least, my regular installation that doesn't include 100% of the packages) doesn't do it. When you don't have the font installed, instead you see squares with 4 numbers in 'em, and the way to fix it is to install a font that supports the language.


All times are GMT -5. The time now is 07:41 PM.