-   Slackware (
-   -   setenv command? (

BlueSpirit 08-13-2006 02:48 PM

setenv command?
Hello all,

I would like to know something :

I just installed teTeX 3.0 and they say to do a command, and this command is setenv

Do you have the setenv command?
Is it normal that I dont have it...
B/c I have the MAN pages of setenv, but when I type setenv, it says :

setenv : command not found



gilead 08-13-2006 02:58 PM

According to, setenv is used in the C shell. If you're using the Bash shell, setting an environment variable is done with export. Can you post the info from the TeX docs and someone here should be able to tell you what needs to be done.

BlueSpirit 08-13-2006 03:17 PM


7) final configuration steps

- set up PATH
- check environment
- configure teTeX using texconfig
- generate fonts with a batch job
- set up area for automatic font generation

Set up PATH:
Set up your PATH to include the directory containing the just installed
binaries (e.g. /usr/local/teTeX/bin/i686-pc-linux-gnu); similarly, MANPATH
and INFOPATH to include the relevant newly installed subdirectories,
i.e. $prefix/man resp. $prefix/info. To avoid conflicts with a
possible different TeX installation, make sure to put the new directories
first. E.g. for setting PATH, use something like the following, but
replace i686-pc-linux-gnu by your actual platform directory:
PATH=/usr/local/teTeX/bin/i686-pc-linux-gnu:$PATH; export PATH
setenv PATH /usr/local/teTeX/bin/i686-pc-linux-gnu:$PATH

As an alternative to adjust PATH, you could as well create symbolic
links in a standard location such as /usr/local/bin:

Example using GNU-ls (which supports the "force" option):
ln -sf /usr/local/teTeX/bin/i686-pc-linux-gnu/* /usr/local/bin

Example using standard ln:
(cd /usr/local/teTeX/bin/i686-pc-linux-gnu; echo *) \
| (cd /usr/local/bin; xargs rm -f)
ln -s /usr/local/teTeX/bin/i686-pc-linux-gnu/* /usr/local/bin

This is the segment of the doc of TeTeX that I dont understand...

Well, theres a problem : when I do the PATH=, it works in the terminal ONLY IF I DONT CLOSE IT!!!, but if I open back rxvt, the PATH= is not in set...
And the MANPATH= is the same thing...
I would like rxvt to ALWAYS know where is the MAN pages of TeX...

Thanx guys...


gilead 08-13-2006 03:38 PM

I assume you're using Bash as your shell... If so, do you want the change made just for yourself? Add the following to the file .bash_profile in your home directory. You'll have to do the same for MANPATH and INFOPATH:

export PATH=/usr/local/teTeX/bin/i686-pc-linux-gnu:$PATH
If this is for all users, check that there is a section in /etc/profile that says:

for profile_script in /etc/profile.d/*.sh ; do
  if [ -x $profile_script ]; then
    . $profile_script

If there is, you can create a file called /etc/profile.d/ and add the same lines to it instead (from memory, the file needs to be executable). If the profile.d stuff is not there, add the lines to /etc/profile. Either way, the next time you login those variables should already be set for you.

BlueSpirit 08-13-2006 04:34 PM

Whoa Gilead... ThanX!
Its working...

But just another question :

I did the "ln -sf /usr/local/teTeX/bin/i686-pc-linux-gnu/* /usr/local/bin" command...
But now, I would like to REMOVE the links in /usr/local/bin/...

How can I do this?

ThanX for Ya


gilead 08-13-2006 05:16 PM

Running the following will list all of the links in /usr/local/bin. If you don't get any false positives (ie, files you don't want to delete) then you can change the ls -l to rm -f:

find /usr/local/bin -type l -exec ls -l {} \;
You can run it straight away with rm, I just prefer the more conservative approach...

BlueSpirit 08-13-2006 06:17 PM

Real ThanX Gilead, its OK...

All Problems > Resolved ...


All times are GMT -5. The time now is 09:32 AM.