LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-31-2005, 04:37 PM   #1
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Rep: Reputation: 0
Server restarts while scannink its ports


Hello.

First of all sorry for my english...

I have a problem with Slacware 10.1 on IBM xSeries 200.
While I am scanning ports from another PC, server restarts, like someone switch his power off, and than on.

There is no about this in logs.
The module for Ethernet is correct.

I have no idea why its happen.

When I installed Win 2000 amd scan ports everything was fine.

Please help me!

Thank You All
 
Old 07-31-2005, 04:47 PM   #2
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,321

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
Any iptables running ? If no maybe enable one rule
to trace the connection like :
Code:
/usr/sbin/iptables -A INPUT -j LOG --log-prefix 'LOGGED INPUT : '
Then start your scan, after the reboot there is the packet connection
logged in /var/log/syslog, take a look at that
 
Old 08-03-2005, 01:02 PM   #3
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Ok Thanks, I will try.
 
Old 08-03-2005, 01:20 PM   #4
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,321

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
I saw the same behaviour some time ago, but this was
a Macintosh machine running OSX 10.2 that did reboot
when I tried to scan its open ports, this happened once
though, so I didn't search deeper
 
Old 08-03-2005, 02:00 PM   #5
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Hello,

Well I did what you write. I have added your roule to the iptables.
When I restarted server and started scanning servers ports from another PC , nothing happens. All is working fine. The server didn't restart.
I have some logs in syslog about network packets.

I have removed this roule from iptables, and restarted server.
Then I scanned ports and server restarts!

Please help me!
 
Old 08-03-2005, 02:12 PM   #6
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,321

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
Anyway as it is a server, you need some basic firewall config, don't you ?

The rule I posted actually blocks nothing though, it just supposed to log
all incoming packets...

If enabling iptables fixes the problem, go with it, configure some basic
rules, proceed step by step
 
Old 08-03-2005, 03:26 PM   #7
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Ok. You are wright.

I'll try do the same after I build a firewall.
I will let You know if it help.

Thank You very much.
 
Old 08-06-2005, 02:24 PM   #8
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Hello again

I built some easy firewall, in which i deny any connection to my servers ethernet.
Now when i am scanning my servers ports from another PC, i still have this problem. Server restarts automaticly.

I have no idea what to do.

I have even bought new ethernet card, but it didn't help.
 
Old 08-08-2005, 02:21 PM   #9
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Hello Again

I have found some information about my server:

1. I have added - *.* /dev/tty12 - to my syslog.conf file - now I can see all logs on my screen.

2. When I scanned my servers ports from another PC about 20 times, each time it restarts whitout any information in syslog. But when I added ad.1 line in syslog.conf and watch the screen of my server, I saw for a very short time some two lines before server restarts.
I don't know why, but this lines in syslog from the screen haven't write in the file in /var/log/messages or /var/log/syslog!

3. I have tried to start scanning ports, and then to stop doing that as fast as possible to write down this lines.
Here they are:

sshd[...]: Did not receive identification string from 192.168.5.11
in.identd[...]: started

This two lines are only on my screen!!!
I cant find them in my /var/log/ files

I have still this problem with scanning my servers ports. Each time I do it, server restarts.

Please help me. I have no idea what to do.

Thanks!

Best grettings

Rafal
 
Old 08-11-2005, 08:52 PM   #10
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...i hope you solved it by now, but just incase...
i was doing some reading here ...

http://members.cox.net/laitcg/new/intro.html

...and when i read this....

--------------
Slackware 9.x update: With the advent of the hotplug feature in Slackware, spontanious reboots may occur. If this happens to you, try disabling hotplug on startup:
chmod -x /etc/rc.d/rc.hotplug
until you isolate the driver that is causing the problem and put it in /etc/hotplug/blacklist.
---------------

...your Q. came up.

before you switch off hotplug, save the output of " lsmod "
so you know what modules are loaded normally.
afterwards just load the module(s) for your network, and scan the ports to check...

egag
 
Old 08-12-2005, 05:03 AM   #11
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Hi,

I didn't solve my problem yet

Still when I'm scanning my servers ports, it restarts automaticly.
I home Your solution will helps.

I tried something with disabling ined program, but it didtn't help.

If it helps, I let you know.

Please tell me how did You find this solution. I have visist this site http://members.cox.net/laitcg/new/intro.html
But cant find any information about my problem.

Thanks a lot.

best regards

Rafal
 
Old 08-12-2005, 12:50 PM   #12
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...it's not exactly describing your problem there, more a possibility.
as it sais...
-------------
With the advent of the hotplug feature in Slackware, spontanious reboots may occur.
-------------

i would just try it and if no luck there's just one less possibility.
( though i woudn't know many more clues atm.)

egag
 
Old 08-13-2005, 10:28 AM   #13
rafal_
LQ Newbie
 
Registered: Jul 2005
Posts: 18

Original Poster
Rep: Reputation: 0
Hello

I try to do the hotplug thig with disabiling it, but it didn't help.

The server still restarts when I am scanning its ports.

Do You know maby some compaty which provides some support for Slackware? Maby they can help me?

Thank You anyway!
 
Old 08-13-2005, 10:45 AM   #14
ralvez
Member
 
Registered: Oct 2003
Location: Canada
Distribution: ArchLinux && Slackware 10.1
Posts: 298

Rep: Reputation: 30
I was following this thread and I have some info that may be useful.
Awhile ago I had a server that due to a power surge got its power supply damaged, but not enough that it would not boot. However, is I scanned the machine it would reboot just like yours. I put a UPS (to smooth the noise and electrical pics) and ... it worked!!
So I purchased another power supply and that was the end of it.

Hope this helps.

Rick
 
Old 08-13-2005, 11:19 AM   #15
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,321

Rep: Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756Reputation: 756
I first thought that was a hardware problem but it said that it could not
reproduce this behaviour from win 2000 system installed on that
machine, moreover setting an iptable log rule avoided the restart
while scanning the ports...

For me it is a netcard driver problem but I can be wrong (more likely)

rafal_, you said that setting a deny iptable rule does not fix the problem,
could you post this rule ? Also the server has only one netcard interface ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot Open Mail Server Ports 25, 110, and 220. Other Ports will open. Binxter Linux - Newbie 9 11-29-2007 03:03 AM
x server restarts when loading quake,et,glxgears morphodone Linux - Games 0 11-05-2004 02:18 PM
Which ports to allow through firewall for X Server? vmnrao Linux - Networking 1 09-04-2004 06:49 PM
ProFtpd Server Ports SwiftDeath Linux - Networking 9 05-12-2004 02:16 AM
X server restarts jayakrishnan Linux - General 1 11-13-2003 07:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration