LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-24-2011, 11:25 AM   #1
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Server blew up, so repaired but now freezing on boot, caused by either Hald or messagebus


Hi all,

So my server gave up the ghost. PSU went for a pop, so I decided I may as well upgrade the M/B at the same time as replacing the PSU.
Anyway, that led to some issues with disc drives being renamed, (were originally hdc/hdd/sda and sdb - renamed to hda/hdb, with sda and b not changing), so a quick boot from Slackware13.0 usb allowed me to rewrite both fstab and lilo.conf (thanks vi)
Rebooted and looked good, until the GTK-Update called from rc.M.
The thing just stops, no warnings, no error messages in logs anywhere. The magickeys don't work, and the only thing to do is press the reset button.
A bit of digging, and disabling the following startup services:- httpd, mysql, udev, hal, cups and fuse soon had me up and running, and then starting them manually worked with no issues.

Then tried a reboot having re-enabled all of the services and immediately a freeze again. Anyway, a work through of the services seems to point to the culprit being either Hald or messagebus as disabling either of these allows the server to boot. Anyone got any ideas why these services will stop the server when started automatically, but when started manually it seems to run OK and how to get it running again without manual intervention?

TIA

Last edited by vdemuth; 07-25-2011 at 01:29 PM. Reason: More information
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK themes missing after gtk+ update rrije Linux - Software 3 04-17-2011 11:31 AM
[SOLVED] how can a boot sector be repaired to then allow grub to install for chainload booting james2b Linux - Newbie 20 10-08-2009 09:07 PM
Reinstalled Win XP and repaired Grub, now I can't boot Linux or Windows. Please help. MegaSvensk Linux - Newbie 27 10-13-2007 05:12 PM
Red Hat Update Agent freezing, unable to update (FC4) Malakye Fedora 1 12-09-2005 08:02 PM
Redhat 8.0/update agent freezing oracle Linux - General 5 02-17-2003 03:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration