-   Slackware (
-   -   Sendmail -- What Did I Forget? (

tronayne 07-03-2013 08:57 AM

Sendmail -- What Did I Forget?
I've done a clean install of Slackware 64-bit 14.0 (fully patched) on a laptop. On all my systems, sendmail "just works;" i.e., I can

mailx -s "This is a Test Message" trona
This is a test message.

and the message gets sent, but not on this one. The sendmail is running and looks the same on the new installation as it does on all the other boxes. I don't do any configuration for sendmail (and have a couple of applications that use it to send mail to the outside world with no problems).

What the heck have I forgotten to turn on? /etc/rc.d looks like

./        rc.autofs      rc.inet1*          rc.modules-3.2.45*  rc.sendmail*      rc.yp
../        rc.bind        rc.inet1.conf      rc.mysqld          rc.serial        rc0.d/
init.d/    rc.bluetooth    rc.inet2*          rc.networkmanager  rc.snmpd          rc1.d/
rc.0@      rc.cgconfig    rc.inetd*          rc.nfsd            rc.sshd*          rc2.d/
rc.4*      rc.cgred        rc.ip_forward      rc.ntpd*            rc.syslog*        rc3.d/
rc.6*      rc.consolekit*  rc.local*          rc.pcmcia          rc.sysstat        rc4.d/
rc.K*      rc.cups*        rc.local_shutdown*  rc.php-fpm          rc.sysvinit*      rc5.d/
rc.M*      rc.dnsmasq      rc.loop*        rc.tomcat*        rc6.d/
rc.S*      rc.font        rc.mcelog*          rc.postgresql*      rc.udev*
rc.acpid*  rc.fuse*        rc.messagebus*      rc.rpc              rc.wicd*
rc.alsa*  rc.gpm*        rc.modules@        rc.samba            rc.wireless*
rc.atalk  rc.httpd        rc.modules-3.2.29*  rc.saslauthd        rc.wireless.conf

zhjim 07-03-2013 09:27 AM

Check the log files of mail. Should be /var/log/mail.log. ls /var/log/mail.*. There should be four files.

tronayne 07-03-2013 09:43 AM

A check of /var/log/maillog shows

Jul  3 10:29:56 pita sm-mta[16481]: r61KCwbf006996: to=<>, delay=1+18:16:39, xdelay=00:00:00, mailer=esmtp, pri=9300454,, dsn=4.0.0, stat=Deferred: Connection refused by
Uh-oh, where the heck is coming from?

pita's entry in /etc/hosts is
Code:       pita
and that is the content of /etc/HOSTNAME, looks like somebody, somewhere is adding the extra .com -- just who might that be?


zhjim 07-03-2013 10:00 AM

I dunno much about sendmail but maybe it needs a FQDN? With a dot at the end. Okay lets check the hostnames and alike
PHP Code:


tronayne 07-03-2013 10:18 AM

It looks normal to me:

    -s, --short          short host name
    -a, --alias          alias names
    -i, --ip-address      addresses for the hostname
    -f, --fqdn, --long    long host name (FQDN)
    -d, --domain          DNS domain name
    -y, --yp, --nis      NIS/YP domainname
    -F, --file            read hostname or NIS domainname from given file


for opt in s a i f d y
        print -n "hostname -${opt}: "
        hostname -${opt}
hostname -s: pita
hostname -a: pita
hostname -i:
hostname -f:
hostname -d: com
hostname -y: (none)

(that's KornShell, not BASH).

So, I dunno.

Spatior 07-03-2013 11:04 AM

Hi tronayne,

I have a similar problem to yours so I think what I have found so far may help you is probably coming from $w macros, it is assigned at sendmail start from the gethostname() function to get the (local)host name

You can try to run sendmail -bt -d8.8 to see how it is resolving the DNS:

sendmail -bt -d8.8
3,0 user[at][]

It will expand and resolv the recipe string as it will normally do but showing the steps from each macro involved
I found the following book very helpful to understand how sendmail works:
adn the DNS stuff in:

Now, the problem I found is that when I send a mail to user [at] it tries to deliver to instead of the MX record which points to I think it's the DNS setup which unfortunately is in another host so I cannot mess with that

I don't know if something similar is happening to you.


zhjim 07-03-2013 03:05 PM

After reading the maillog output again I see that the relay option is Which concludes to me that spatior has some point with the dns settings. I can't check them from outside. Dont get a MX only massive NS records.

A short search for the $w macro states that it only gets assign on version 8. Not prior to this. dunno if your other machine have another version. Doubt it if all of them are slack 14.

tronayne 07-04-2013 05:24 AM

Thanks for the input -- here's the output of

sendmail -bt -d8.8
ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
Enter <ruleset> <address>
> 3,0 user[at][]
canonify          input: user [ at ] [ domain . com ]
Canonify2          input: user [ at ] [ domain . com ]
Canonify2        returns: user [ at ] [ domain . com ]
canonify        returns: user [ at ] [ domain . com ]
parse              input: user [ at ] [ domain . com ]
Parse0            input: user [ at ] [ domain . com ]
Parse0          returns: user [ at ] [ domain . com ]
ParseLocal        input: user [ at ] [ domain . com ]
ParseLocal      returns: user [ at ] [ domain . com ]
Parse1            input: user [ at ] [ domain . com ]
Parse1          returns: $# local $: user [ at ] [ domain . com ]
parse            returns: $# local $: user [ at ] [ domain . com ]

This is identical to the output of both my servers and my work station (all of them are Slackware 14.0, the servers are 32-bit, the work station (and this laptop) are 64-bit and all four sedmails are un-fooled-around-with -- the laptop is the only one that is exhibiting this behavior (drat!).

All my machines are fixed-IP, with identical /etc/hosts files; i.e.,

# For loopbacking.                localhost
# For public and private OpenSRF comains      public.localhost        public      private.localhost      private
# Local servers       fubar                InkJet       snafu       pita
# Public servers      

So, I don't think DNS has anything to do with (and BIND is not configured nor is it running on any server); my /etc/resolv.conf (a little messy) contains:

cat /etc/resolv.conf
search com
# Google Free DNS Servers
# HughesNet DNS Servers

Those commented-out extras are there for the rare occasion that the first two aren't available for some reason or other; they're just-in-case. And, as I understand it, the first place we look is in /etc/hosts and, well, they're all there.

I'm not doing mailx (which goes out to the world), I simply use mailx trona, which should be resolved (and is on every box but this one) to the local machine. And it ain't.


Thanks for the input.

zhjim 07-08-2013 02:15 AM

Dunno if the output looks good. But I think that sendmail does not use your FQDN so it puts your domain (search in /etc/resolv.conf) at the end of the hostname. Coming from a little howto /etc/mail/genericsdomain should hold your FQDN. Do you have that one? What does it shown on (all) the machine(s)?

zhjim 07-08-2013 02:19 AM

Nother thing. How did you configure your sendmail?

jostber 07-08-2013 03:01 AM

Have you updated the or file?

tronayne 07-08-2013 01:44 PM

Actually, I never configure any of the sendmail files; the norm is that it "just works" on the individual server and with a mailto link from an internal web page. No kidding, I don't configure anything on any of these boxes.

So, maybe I'll look at the configuration files and see what's what but dang if I can figure out where this additional .com is coming from given that all four machines are identical Slackware 14.0 installations (other than 32-bit versus 64-bit) with all patches applied.

Tiz a puzzlement.

zhjim 07-08-2013 02:05 PM

Hm that truly is weired. Maybe some packages did fiddle with your hosts config file or sendmail. Maybe a diff on the packages might show.
Also 32vs64 does not make a difference. But the one giving headache is the only 64bit?

tronayne 07-08-2013 02:46 PM

Yeah, I know that 32-bit and 64-bit are pretty much identical -- the one being a pain happens to be a 64-bit lap top (which is identical to a 64-bit desk top). There's not enough on it to make a difference (so I can just scrap it and reload Slackware and see what happens).

I mean I haven't got a clue -- never seen this before and these guys are kept identical with configuration files and patches, including the recent kernel patch on all. The two 32-bit data base servers have old Radeon cards but the 64-bit boxes have Intel graphics (and how that could make any difference I most certainly do not know).

I think I'll just do a clean install and see what that does (if anything) to make a difference. It's just goofy.

zhjim 07-08-2013 03:20 PM

Hm. Does slackware has some options for labtop installs? I know in Debian theres an option for that. Also its more for energy saving and alike but maybe theres a silent com(on) give me more power. Just kidding. Long time ago I lost track of slack.

Maybe you can just copy the files of the desktop over to the labtop? At least that rules out any configurations. Also you would need to just host.conf and alike. Grub if installed also if you dont use the same uuid for the partitions.
Could you backup the /etc directory and diff it after the installation? Maybe this will shed some light.

All times are GMT -5. The time now is 01:31 PM.