-   Slackware (
-   -   Seamonkey not starting (

linuxbird 04-25-2010 10:37 AM

Seamonkey not starting
I ran installpkg on seamonkey 2.0.4, on Slackware 13.0, and it appeared to install OK.

I can run /usr/bin/seamonkey -version and I get the 2.0.4 version number. However, when I run it without arguments, no windows get opened, and there are no errors that I have located (eg messages, syslog).

This is probably something real obvious, but I'm drawing a blank. Any suggestions?

BTW, firefox runs OK.

slackass 04-25-2010 11:51 AM

Did you install seamonkey-solibs-2.0.4 also?
If you already had a previous version of seamonkey maybe "upgradepkg" would have been a better option if you didn't want to use slackpkg..

Asido 04-25-2010 11:57 AM

Also check if libidl (IDL library) is installed. Seamonkey uses it.

linuxbird 04-25-2010 12:08 PM

libIDL 2.0 is there. The docs are there for libIDL-0.8.10, which is the version on the 13.0 distribution.

linuxbird 04-25-2010 02:52 PM

I reinstalled seamonkey, using the slack 13.0 version of seamonkey, and the corresponding solibs. Behavior is the same. It will respond to a seamonkey -h but not any other commands.

Searching around I found a guide for dealing with Firefox startup issues, and checked out most of the stuff in that write-up.

I guess the next thing is to remove any configuration files, such as profiles, and see if that helps.

Anyone else have any ideas?

halborr 04-25-2010 04:24 PM

Are you sure there is only 1 version of seamonkey installed? (check /var/log/packages) Did slack 13.0 come with seamonkey 2.0 by default? (I'm running 12.2)

I know at least on this machine /usr/bin/seamonkey is a symlink to /usr/lib/seamonkey-2.0.4/seamonkey. Might want to look into that.

linuxbird 04-25-2010 08:04 PM

13.0 comes with 1.1.17. I wanted 2.0.4 for security and plugin reasons, so I installpkg the newer version. The seamonkey link gets updated to point to the most recently installed executable, so I thought that would be ok. I did not completely remove 1.1.17.

I did install the solibs for 2.0.4.

My symlink is identical to yours.

rob.rice 04-26-2010 12:10 PM

do an "ldd /usr/bin/seamonkey" and post the output
lets see if there is a missing library

linuxbird 04-26-2010 04:53 PM

Not a dynamic executable.

rob.rice 04-26-2010 05:35 PM

sorry that should have been "ldd /usr/lib64/seamonkey-1.1.17/seamonkey-bin"

linuxbird 04-26-2010 08:06 PM

1 Attachment(s)
ldd /usr/lib/seamonkey-2.0.4/seamonkey-bin output is attached.

linuxbird 05-09-2010 07:19 AM

Possibly related, I now find that chrome won't start as well. At least there is a possible thread.

So now I have seamonkey and chrome both not starting up.

XGizzmo 05-09-2010 07:42 AM

You should remove all versions of seamonkey and seamonkey-solibs and reinstall the version from /patches. Using installpkg to "Upgrade" a package is always a bad idea.

All times are GMT -5. The time now is 09:50 PM.