-   Slackware (
-   -   Seamonkey and Seamonkey libs update for Slackware 13.1? (

Lufbery 06-22-2011 08:55 PM

Seamonkey and Seamonkey libs update for Slackware 13.1?
Hi all,

Has anyone seen an update for Seamonkey for earlier versions of Slackware? The changelog for 13.37 has it, but not for older versions -- at least on the mirrors that I checked.


Peacedog 06-22-2011 09:34 PM

Hi Lufbery, Which version are you looking for? The mirrors have 2.0.14 in the /patches directory. If you need something newer you can grab the build scripts and create your own packages.

Good luck. ;-)

Lufbery 06-23-2011 07:28 PM

Seamonkey 2.1 is available. I'm pretty sure it's available for Slackware 13.37, but usually Pat and the team update the same software in older Slackware versions.

I haven't gotten around to updating Slackware from 13.1 and probably won't for a little while yet.


Lufbery 06-23-2011 08:32 PM

Here's more information.

The latest version of Seamonkey requires a newer version of Cairo than what's installed.


checking for cairo >= 1.10 pixman-1 freetype2 fontconfig... Requested 'cairo >= 1.10' but version of cairo is 1.8.8
configure: error: Library requirements (cairo >= 1.10 pixman-1 freetype2 fontconfig) not met;

At this point, I'll probably upgrade cairo and pixman and then try the upgrade to Seamonkey. If all of that monkey's up my system (pun!) then I'll install Slackware 13.37 (actually do the upgrade) and be done with it.


Lufbery 07-17-2011 08:18 AM

Quick update: Seamonkey is now up to version 2.2 and there's still no official Slackware update for version 13.1 and earlier.

I didn't get a chance to upgrade Cairo and Pixman and see if that helps.

I wonder if this is a circumstance where the newer dependencies will preclude continued support for earlier Slackware versions. I hope not, though.

Lufbery 08-04-2011 10:39 PM


I'm coming back to this now.

Upgrading Cairo is actually something of a big deal. Seamonkey 2.2 didn't build; it stopped part way through with an error about a missing directory (I think in the build tree).

I didn't have time to track down the error in more details tonight, but it doesn't matter. The new version of Cairo seemed to be responsible for severe instability in my installed versions of Firefox and Thunderbird. I think I would have to rebuild them with the new Cairo too -- and that's just not worth the trouble.

I haven't tried just installing the version from 13.37 to see if it works, but if Cairo is a build-dependency, it may also be a runtime dependency.

So, we seem to be in the unfortunate circumstance that major software updates to Seamonkey are only supported for the latest version of Slackware.

Bummer. :(

ReaperX7 08-04-2011 11:11 PM

Why does Slackware still have SeaMonkey anyway? I know it's the core/foundation project for all the Mozilla stuff, but do we actually really need it? Can't you just use XULRunner and SeaMonkey-SoLibs in place of the full SeaMonkey package, or is SeaMonkey really that required?

janhe 08-05-2011 03:00 AM

Slackware started including the Seamonkey suite when de Mozilla suite was discontinued (back in the day when Firefox and Thunderbird were launched).

Except maybe for Konqueror in KDE, no browser is really required. I think it is nice that we have Firefox and links and lynx and Seamonkey in addition to konqueror. I use all of them (except links).

The advantage of Seamonkey is that it is a suite, not just a browser. It also includes a mail client and maybe even more.
The advantage of Firefox is that it has a large market share, so many websites are built to work with FF.
The advantage of lynx is that it doesn't require X.
The advantage of konqueror is that it starts up faster if you're already using KDE.

They all have their uses. They may not be required, but each one is different enough from the next. IMO, Seamonkey isn't just another browser.

BTW, the solibs are a separate package on slackware, so you can have just the solibs if you want.

All times are GMT -5. The time now is 12:34 PM.