-   Slackware (
-   -   Seamonkey 2 not working on Slack 12.2 (

Eternal_Newbie 12-24-2009 11:50 AM

Seamonkey 2 not working on Slack 12.2
I am having problems getting Seamonkey 2 and to run on Slackware 12.2. I have tried the packages for 12.2 in patches/packages/ and the package from the seamonkey website, both with identical results

Seamonkey appears to start, and does appear in the process list, however no windows appear and it uses little memory and no CPU cycles. No messages appear in the console if I start it from there. I have to kill the processes (seamonkey , run-mozilla and seamonkey-bin).

I have tried removing my Seamonkey profile, with the same results.

If I try to build the slackbuild I get this error:


checking for cairo >= 1.8.8 freetype2 fontconfig... Requested 'cairo >= 1.8.8' but version of cairo is 1.6.4
configure: error: Library requirements (cairo >= 1.8.8 freetype2 fontconfig) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
configure: error: ./configure failed for mozilla
/usr/bin/gmake -C mozilla default
gmake[1]: Entering directory `/tmp/comm-1.9.1/mozilla'
gmake[1]: *** No rule to make target `default'.  Stop.
gmake[1]: Leaving directory `/tmp/comm-1.9.1/mozilla'
make: *** [default] Error 2

The version of Cairo I am running is the standard Slackware 12.2 version cairo-1.6.4-i486-1.tgz , which to my knowledge, has never been updated (there is nothing in /patches/packages for it, anyway).

Has anyone else had similar issues with Seamonkey and Slackware 12.2 and how did you resolve them?

~sHyLoCk~ 12-24-2009 12:00 PM

Why don't you upgrade cairo from Slackware 13?

Eternal_Newbie 12-24-2009 12:08 PM

I assumed that the cairo error from the slackbuild was a distraction, as no-one else appears to have reported problems running Seamonkey 2 on 12.2. I just included it for completeness sake. Anyway, its asking for Cairo 1.8.8 and Slackware 13 ships with 1.8.6

EDIT: Hmm, I see 1.8.8 is in the patches/packages for Slackware 13

~sHyLoCk~ 12-24-2009 12:52 PM


EDIT: Hmm, I see 1.8.8 is in the patches/packages for Slackware 13
Yep, thanks to the firefox 3.5.6 upgrade.

Eternal_Newbie 12-24-2009 01:36 PM

Compiled and installed cairo 1.8.8 It doesn't help, Seamonkey still doesn't open properly.

As to the slackbuild, still waiting to see if it will actually finish compiling

Eternal_Newbie 12-25-2009 08:07 AM

The Seamonkey 2.0.1 slackbuild builds without any fatal errors on slackware 12.2 with cairo 1.8.8 installed , and installs, but fails to run apparently in the same manner as the official 12.2 Slackware package and the package from Mozilla.

Anyone have problems with Seamonkey 2 on Slackware 12.2?

All times are GMT -5. The time now is 01:26 AM.