-   Slackware (
-   -   scsi emulation (

one 09-05-2003 11:45 PM

scsi emulation
does anyone know how to exactly enable scsi emulaiton on slackware 9, i have read, read and read, tried, tried and tried and can't enable it
thanks for any help

kleptophobiac 09-06-2003 12:06 AM

SCSI -> SCSI emulation support

just recompile the kernel. The option is there.

Looking_Lost 09-06-2003 03:24 AM

As far as I know as well enabling scsi emulation in the ATA/IDE section in the SCSCI support bit you need SCSI Generic Support and SCSI-CDROM at least that's what I do, if its working with just SCSI emulation if someone could post a quick Yes or no and I'll get rid of the extra options.

one 09-06-2003 09:23 AM

i just compiled 2.4.22 kernel and i already enable scsi support, i also edit my /etc/rc.d/rc.modules and append the lines to /etc/lilo.conf , when running lsmod ide-scsi shows in the list. but still i get the following when running
cdrecord -scanbus

bash-2.05b# cdrecord -scanbus
Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

please any1 who can run scsi emulation and use cdrecord on slack 9 any help would be aprecitated

Mathieu 09-06-2003 11:36 AM

To get SCSI emulation for your CD-ROM, you will have to enable the following in the kernel:
In the ATA/IDE support section, enable SCSI emulation support
In the SCSI Support section, enable SCSI Support, SCSI CD-ROM support and SCSI generic support.

one 09-06-2003 03:30 PM

all that is enable, maybe some slack 9 user who has scsci emulation knows the trick

Cerbere 09-06-2003 06:12 PM

Do you really need SCSI emulation? Read /usr/doc/cdrtools-2.0/README.ATAPI then try:

cdrecord dev=ATAPI -scanbus

If you can see your cdrw, then just use the -dev=ATAPI:X,X flag (corresponding to the output of scanbus) when you burn.

--- Cerbere

All times are GMT -5. The time now is 04:40 AM.