-   Slackware (
-   -   Scrolling Question ? (

Viper 08-02-2002 01:10 AM

Scrolling Question ?
Is it possible to get the scroll wheel on my mouse to work again?
It works on windows, but Not sure how to get it to work on Slackware 8.1

"Any Help is Greatly Appreciated"

Gameon 08-02-2002 01:34 AM

Ditto. I can't get my mouse wheel working either (using Red Hat 7.3). The mouse is a logitech two button mouse with the wheel as a third button. Unfortunately I don't know more about the mouse. It worked fine on Windows though.

Viper 08-02-2002 01:54 AM

That's Funny I have the same mouse, maybe this is a Logitech Conspiracy?

XPmandrake 08-02-2002 03:17 AM

there is something u need to add to a file, im a n00b so just google it :)

kroniq 08-02-2002 04:32 AM

Try putting

Option "ZAxisMapping" "4 5"

in your /etc/X11/XF86Config file, under your mouse InputDevice section. I'm not sure if that will solve the problems with a logitech mouse, but it does make a ms intellimouse work perfect.

Aussie 08-02-2002 05:58 AM


Originally posted by kroniq
Try putting

Option "ZAxisMapping" "4 5"

in your /etc/X11/XF86Config file, under your mouse InputDevice section.

And change the protocol to "IMPS/2"
Both in the pointer section of /etc/X11/XF86Config

Viper 08-02-2002 07:13 PM

can you guys give me an example of where and how "EXACTLY" to do this?

Aussie 08-02-2002 07:25 PM

Open the file /etc/X11/XF86Config in a text editor (as root) and edit the pointer section, make the changes, save and restart X.

Excalibur 08-02-2002 10:13 PM

I do not know how to reference another thread inside of a post. But it is thread ID 24161 that has alot of syntax on the files for the wheel mouse. And feedback on the users that used it. Use the search on "Wheel Mouse" and it is listed as "Scrolling with Logitech Mouse in X"

Maybe the following link will post in here.


rootman147 08-04-2002 12:22 AM

To all in You guys rule! I have gotten more help here than anywhere else on the net. I have to recommend for the people here, it is a security website that I also joined...great people there who help out linux people too especially about security. As a matter of fact they first referred me here.

rootman147 08-04-2002 12:22 AM

oh BTW...that last post was because my mouse wheel works now...sorry got caught up in the moment...One more step towards dumping windows.

Gameon 08-04-2002 03:28 AM

Well shoot. It is still not functioning. I added the ZAxisMapping (uncommented it) and changed the protocol yo IMPS/2 as suggested, but it is STILL not working. And I did restart the X-system.

The problem must then be somewhere else I guess... *sigh*

Aussie 08-04-2002 03:54 AM

Post the pointer section of your XF86Config Gameon.

Gameon 08-04-2002 11:35 PM

As requested, here is my pointer section.

# Pointer section
# **********************************************************************

Section "Pointer"
Protocol "IMPS/2"
Device "/dev/psaux"

# For wheel support - can not be used with Emulate3Buttons
ZAxisMapping 4 5

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.
# Protocol "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice
# BaudRate 9600
# SampleRate 150

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)
# Emulate3Buttons
# Emulate3Timeout 50

# ChordMiddle is an option for some 3-button Logitech mice
# ChordMiddle


Excalibur 08-05-2002 12:22 AM

Gameon: This is Excalibur. Your earlier post stated you were running RH 7.3. Are you running XFree version 3 or 4? The file you posted appears to look more like a version 3 file. I do not know RH very well at all. But if it shipped with both versions of X, and you are running version 4, then you might look for a XF86Config-4 file instead or something similar. You might also look to see if you have a /var/log/XFree86.0.log file. If RH has that file, then it should state the version of X and exactly what config file it is using.

If version 3, I do not have any files available anymore on that platform and my memory is not what it used to be. So I am not much help.

Good Luck.

All times are GMT -5. The time now is 08:55 AM.