-   Slackware (
-   -   Screen keeps turning off after 10 minutes (

Josh000 04-27-2010 04:09 AM

Screen keeps turning off after 10 minutes
HI, I have actually done a bit of searching on this, but the suggested solutions either don't work or are not applicable to my setup.

First, I changed the setterm link in /etc/rc.d/rc.M to be setterm -blank 0 -powersave off -powerdown 0

and have xset s off in my fluxbox startup file.

Nevertheless, the screen goes blank after 10 minutes. I can't figure out what is causing it and how to stop it.

stuart_cherrington 04-27-2010 04:13 AM

Question: Is it the screen which goes blank or does the 'physical' terminal actually power down?

dive 04-27-2010 04:41 AM

The setterm line is only for consoles. You could try commenting out completely though. As for xset try 'xset -dpms'. Run xset alone to see options.

Oh yeah and make sure xscreensaver daemon isn't running.

H_TeXMeX_H 04-27-2010 06:02 AM

Add this to the monitor section of '/etc/X11/xorg.conf'


Option "DPMS" "0"
or instead of "0" use "false".

Josh000 04-27-2010 06:22 AM

It isnt dpms related. My screen does not actually turn off, it turns blank.

H_TeXMeX_H 04-27-2010 06:49 AM

Actually, DPMS first blanks the screen, then turns it off.

If it happens when X is running, turn off DPMS in xorg.conf (restart X of course).

If it happens on the console, see 'rc.M' and do what you did above.

There are no other ways to control the screen blanking, the solution is one of the above.

propofol 04-28-2010 01:31 AM

Not sure if this will help, but I had a similar problem with my debian lenny system. This code which I found on the internet seems to fixed the problem:


xset -dpms    // This *should* turn off the dpms power management stuff
xset s noblank // This should turn off screen blanking
xset s off    // This turns off the screen saver

xscreensaver &
exec startkde


Josh000 04-29-2010 12:29 AM

OK, I have tried xset s off and xset -dpms and it still goes blank after 10 minutes.

If it is dpsm, why isn't xset -dpms working?

H_TeXMeX_H 04-29-2010 07:31 AM

Just tell me if it doesn't work if doesn't work if you add that option to xorg.conf like I said, have you tried it ?

Josh000 04-29-2010 06:47 PM

No, it didn't work. I didn't have an xorg.conf file and created it, just with the line you gave.

I would prefer anyway to be able to disable it per user and not just system wide if that is possible

H_TeXMeX_H 04-30-2010 05:39 AM

Any screensaver set to run ?

Josh000 04-30-2010 06:14 PM

No, no screensavers are even installed.

Josh000 05-02-2010 02:38 PM

OK, the culprit was the screensaver, when i do xset s off and xset s noblank the problem disappears

I put these commands in my .fluxbox/startup file, however they don't seem to be loaded as xset q shows them still to be at default settings.

I run tint2 fine from the startup file, so why would the xset commands not load from there?

It seems to be the correct approach going by here

All times are GMT -5. The time now is 03:50 PM.