-   Slackware (
-   -   Screen is black after installing Slackware 14.0 (

skania 03-03-2013 11:46 AM

Screen is black after installing Slackware 14.0
First, hardware:
Intel I5 3750k
ASRock Z77 Pro 4 motherboard
NVidia GeForce GTX 570

Windows 7 on an 120GB SSD
NTFS on partition 1 on 500GB HDD

Partition 2 is where I installed slackware.
I did a root, swap, and extended partitions for Slackware
Extended partitions was set up for usr(15GB), opt(3GB), and home(53GB)
Installed LILO, everything is the "safe" option.
---I did NOT include the NTSF files for Slackware partitions.---

After install completed, I ejected the disk, hit ctrl+alt+del to reboot, and it reboots. I select my HDD as the boot option, and LILO loads up. I select linux and hit enter. The wall of text appears, and loads a bunch of stuff, and then the speakers do a slight sound (like they turn on) and my screen goes black. I left it for 30 minutes, still nothing. I unplugged the second monitor, tried it again - same result.

Does anyone know a fix for this? Feel free to ask more about my system/install. I really want slackware on my desktop - other distributions just dont feel *right* ( Posting from Mint :/).

T3slider 03-03-2013 01:32 PM

Try passing 'nomodeset' to the kernel at the LILO boot prompt (I think hit Tab, then enter the kernel name followed by nomodeset, eg. "Linux nomodeset" without quotes). Your best bet is to install the proprietary nVidia drivers and blacklist nouveau (install xf86-video-nouveau-blacklist-noarch-1 from extra/ using upgradepkg -- it will replace the real xf86-video-nouveau package). If you search for KMS in these forums you will find more detailed information.

skania 03-03-2013 01:59 PM

I saw that as a solution, but it didn't help. I removed my graphics card and am hooked directly to the I/O panel. I'm trying to get back on windows to finish a couple assignments due tomorrow, but seems as though there is no master boot table..

maciuszek 03-03-2013 05:25 PM

well if you see lilo there is an bootsector written.
anyway if you need to gain acess to windows but are not able to reinstall the windows bootloader, then boot up your slackware via installation medium. configure a lilo.conf, a windows entry can just be root= path to windows || path to sys reserve (depending on which windows you are using).. n seting a label (label=)
reinstall lilo n you're good to go

(maybe have a look at liloconfig offered by slackware)

skania 03-04-2013 08:12 AM

Thanks for your reply. I was under the impression that the bootmgr was in thw 100MB partition Windows makes at installation. Turns out lilo needs to point to the actual partion of Windows. Thanks for your replies.

All times are GMT -5. The time now is 12:48 AM.