-   Slackware (
-   -   Screen brightness control function keys not working. (

Gargle 07-21-2007 02:49 PM

Screen brightness control function keys not working.
Hi all,
I bought me a new sony viao vgn-n320e laptop.
I have almost everything working beautifully and have just a few issues.
One issue is that under vista,function+alt+f4 or f5 would control the screen brightness
and under slackware 12.0, the keys simply don't work.I wondered is there some module
or driver I need to install to get this working? Or is there some script that could control
the voltage of the screen and let me control the brightness? Also the function keys for
the volume don't work.I can control the volume through alsamixer, but would like to control
it through the function keys.Or I could just add shortcuts from alsamixer onto the keys?


erklaerbaer 07-21-2007 02:57 PM

i don't think, that right know there is an easy solution. see for some backgrounds.

however if you want to get your multimedia keys working could be helpful.

Gargle 07-21-2007 04:57 PM

So I am screwed with getting brightness control?
I think there has to be a fix because I believe that there are other laptops that have this issue.
One thing I know that under windows, there is a utility you need to install to use the function
keys to control the brightness,volume, and whatever other function options it has. Maybe I should
download the windows utility and try to install it through wine? I wish I could fix this, because
at night you really need to lower the brightness down!

erklaerbaer 07-21-2007 05:34 PM

found it:

there is a program on this site

Gargle 07-21-2007 10:02 PM

Maybe it's possible to get it working.
I found this
Then it said,


Module use:

In order to automatically load the sonypi module on use, you can put those
lines in your /etc/modprobe.conf file:

        alias char-major-10-250 sonypi
        options sonypi minor=250

This supposes the use of minor 250 for the sonypi device:

        # mknod /dev/sonypi c 10 250

Then it said to install spicctrl, the command line utility that
could adjust the brightness level, etc.

After that, I ran spicctrl which gave me these options.

# spicctrl
Sony Vaio SPIC control program version 1.9, Jun 28, 2005

Usage: spicctrl [COMMAND] [OPTION]...

        -a, --getacstatus              get AC adaptor status
        -b, --setbrightness=NUM        set lcd screen brightness (0-255)
        -B, --getbrightness            get lcd screen brightness
        -c, --getbat1capacity          get first battery capacity
        -C, --getbat2capacity          get second battery capacity
        -l, --setbluetoothpower=NUM    set bluetooth device power state (0-1)
        -L, --getbluetoothpower        get bluetooth device power state
        -p, --powerstatus              print out battery summary
        -r, --getbat1remaining          get first battery remaining capacity
        -R, --getbat2remaining          get second battery remaining capacity
        -s, --getbat1status            get first battery status
        -S, --getbat2status            get second battery status
        -f, --setfanspeed=NUM          set fan speed (0-255)
        -F, --getfanspeed              get fan speed
        -T, --gettemperature            get temperature

I ran then

spicctrl -B
and it gives me this.

# spicctrl -B
/dev/sonypi: No such file or directory

How can I fix that? I thought sonypi was installed because it came as default
with the kernel since the 2.4.7 kernel. If you guys or gals! could help me
on how to get the /dev/sonypi it would be great because this looks like
my only chance at being about to control the brightness.

Thanks again

erklaerbaer 07-22-2007 06:59 AM

did you insert the module?
modprobe sonypi

All times are GMT -5. The time now is 09:22 AM.