-   Slackware (
-   -   scim problems w/kde 4.8.5 & xfce 4.10, vi mode (

offplanet 09-09-2012 08:59 PM

scim problems w/kde 4.8.5 & xfce 4.10, vi mode
I am using the latest RC as of September 9. I am going to relate the problems I am having using konsole. I have set -o vi turned on. escape k doesn't work to recall the last command. I am using kde 4.8.5. I was using xfce 4.10 until the problem. Pressing the letter L echos the number 3 in 4.10. I tried control-alt-3 and the letter L also echo the number 3. so I moved to kde. I could not find scim tool in xfce. When the problem started with vi mode the scim icon changed from a keyboard icon to an "EN" icon. When I type each word gets highlighted until I move to the next word. I just checked terminal 4.8 and vi mode works. As a rule I don't use terminal because line-wrap is wonky. (and I can't figure out how to make it behave.) the scim stuff started happening between rc2 and rc4. Before rc2 I installed the bash-completion package. I only have one machine so I am uncomfortable with risking my internet connection with a reinstall. all other suggestions are welcome. Thanks in advance. edit: xfce 4.10 is the L translating to the number 3. what is the tool to reset scim input in xfce? why does this happen in ctrl-alt-3 vt console as well? kde 4.8.5 why is my input highlighted until I move to the next word? Before the latest updates input highlighting did not happen. why does escape k not call up command history? It worked normally before the latest updates. Thx Update: Reboot cured kde vi mode escape-k problem. scim input icon has changed back to keyboard from "EN" icon. ctrl-alt-3 vt console works when I log in with kde under X but not when I login in under xfce. scim input menu displayed when clicking on the keyboard icon has changed. when escape-k failed to work English was at the top of the list with a separator bar between it and the rest of the list. Now that escape-k is working English is at the bottom of the list with no separator bar. (topographically yuck)

All times are GMT -5. The time now is 03:55 AM.