LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-09-2017, 07:42 AM   #1
nodir
Member
 
Registered: May 2016
Posts: 134

Rep: Reputation: Disabled
sboupgrade: can't read /usr/lib/libidn2.la (claws-mail)


After running:
Code:
sboupgrade --all
i get the error mentioned in the thread title:
Code:
/bin/grep: /usr/lib/libidn2.la: No such file or directory
/bin/sed: can't read /usr/lib/libidn2.la: No such file or directory
libtool:   error: '/usr/lib/libidn2.la' is not a valid libtool archive
make[4]: *** [Makefile:626: libclawscommon.la] Error 1
make[4]: Leaving directory '/tmp/SBo/claws-mail-3.15.1/src/common'
make[3]: *** [Makefile:1547: all-recursive] Error 1
make[2]: *** [Makefile:1237: all] Error 2
make[3]: Leaving directory '/tmp/SBo/claws-mail-3.15.1/src'
make[2]: Leaving directory '/tmp/SBo/claws-mail-3.15.1/src'
make[1]: *** [Makefile:777: all-recursive] Error 1
make[1]: Leaving directory '/tmp/SBo/claws-mail-3.15.1'
make: *** [Makefile:552: all] Error 2
Failure encountered while building claws-m
Checking for libidn:
Code:
ROOT# ls -l /usr/lib/libidn*
-rwxr-xr-x 1 root root    920 Jul 28  2016 /usr/lib/libidn.la
lrwxrwxrwx 1 root root     17 Nov 17  2016 /usr/lib/libidn.so -> libidn.so.11.6.16
lrwxrwxrwx 1 root root     17 Aug 16 15:44 /usr/lib/libidn.so.11 -> libidn.so.11.6.16
-rwxr-xr-x 1 root root 206372 Jul 28  2016 /usr/lib/libidn.so.11.6.16
lrwxrwxrwx 1 root root     16 Aug 16 15:44 /usr/lib/libidn2.so.0 -> libidn2.so.0.3.2
-rwxr-xr-x 1 root root 116132 Jul 24 21:37 /usr/lib/libidn2.so.0.3.2
-rwxr-xr-x 1 root root    637 Mar 25  2011 /usr/lib/libidnkit.la
lrwxrwxrwx 1 root root     18 Nov 14  2016 /usr/lib/libidnkit.so -> libidnkit.so.1.0.2
lrwxrwxrwx 1 root root     18 Nov 14  2016 /usr/lib/libidnkit.so.1 -> libidnkit.so.1.0.2
-rwxr-xr-x 1 root root 216888 Mar 25  2011 /usr/lib/libidnkit.so.1.0.2
-rwxr-xr-x 1 root root    657 Mar 25  2011 /usr/lib/libidnkitlite.la
lrwxrwxrwx 1 root root     22 Nov 14  2016 /usr/lib/libidnkitlite.so -> libidnkitlite.so.1.0.2
lrwxrwxrwx 1 root root     22 Nov 14  2016 /usr/lib/libidnkitlite.so.1 -> libidnkitlite.so.1.0.2
-rwxr-xr-x 1 root root 211544 Mar 25  2011 /usr/lib/libidnkitlite.so.1.0.2
ROOT#
thanks in advance

Last edited by nodir; 10-09-2017 at 02:14 PM.
 
Old 10-09-2017, 08:19 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,663

Rep: Reputation: 964Reputation: 964Reputation: 964Reputation: 964Reputation: 964Reputation: 964Reputation: 964Reputation: 964
have you installed the new library?
Quote:
l/libidn2-2.0.2-i586-1.txz: Added.
 
1 members found this post helpful.
Old 10-09-2017, 08:40 AM   #3
nodir
Member
 
Registered: May 2016
Posts: 134

Original Poster
Rep: Reputation: Disabled
Thanks. That helped, but now i ran in the next problem:
Code:
/bin/grep: /usr/lib/libwebp.la: No such file or directory
/bin/sed: can't read /usr/lib/libwebp.la: No such file or directory
libtool:   error: '/usr/lib/libwebp.la' is not a valid libtool archive
but it is already installed:
Code:
ROOT# sboinstall libwebp
libwebp (libwebp-0.6.0-i586-2) is already installed.
ROOT#
Code:
ROOT# ls /usr/lib/libwebp*
/usr/lib/libwebp.so	   /usr/lib/libwebpdecoder.so	     /usr/lib/libwebpdemux.so	     /usr/lib/libwebpmux.so
/usr/lib/libwebp.so.7	   /usr/lib/libwebpdecoder.so.3      /usr/lib/libwebpdemux.so.2      /usr/lib/libwebpmux.so.3
/usr/lib/libwebp.so.7.0.0  /usr/lib/libwebpdecoder.so.3.0.0  /usr/lib/libwebpdemux.so.2.0.2  /usr/lib/libwebpmux.so.3.0.0
ROOT#
 
Old 10-09-2017, 02:19 PM   #4
nodir
Member
 
Registered: May 2016
Posts: 134

Original Poster
Rep: Reputation: Disabled
I removed libwebp and reinstalled it from slackbuilds.org
Code:
slackpkg remove libwebp
sboinstall libwebp
The result is a existing libwebp.la file at /usr/lib/libwebp.la
Code:
user$ ls /usr/lib/libwebp.la 
/usr/lib/libwebp.la
user $
 
Old 10-09-2017, 02:39 PM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,837

Rep: Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892
but you really shouldn't do that, because this way you have broken whatever in your system links to the new libwebp in current.
you should rebuild all the claws-mail dependencies instead, the mandatory one (libetpan) and the optional ones, if you have any of them installed, and also their dependencies, if needed.
 
Old 10-09-2017, 02:52 PM   #6
nodir
Member
 
Registered: May 2016
Posts: 134

Original Poster
Rep: Reputation: Disabled
Sorry, how would i do that?
 
Old 10-09-2017, 02:54 PM   #7
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,837

Rep: Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892Reputation: 1892
Quote:
Originally Posted by nodir View Post
Sorry, how would i do that?
https://slackbuilds.org/howto/
but if you're using current it's assumed that you already know how to do these things...
if you don't you should stick to stable.

Last edited by ponce; 10-09-2017 at 02:58 PM.
 
Old 10-09-2017, 03:07 PM   #8
nodir
Member
 
Registered: May 2016
Posts: 134

Original Poster
Rep: Reputation: Disabled
I would assume that sbotools do that, only in an automated way.
 
Old 10-09-2017, 03:29 PM   #9
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 362

Rep: Reputation: 67
apparently this depends on the flags used, with -r you could get yourself in trouble
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] /usr/lib/libXfixes.so: could not read symbols: File in wrong format enine Slackware 2 12-16-2015 07:27 PM
OPENNMS INSTALLATION ERROR -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 4 07-11-2011 12:06 PM
opennms installation error -install –disU –l /usr/lib/jni:/usr/lib ramecare Linux - Server 2 07-08-2011 10:51 AM
Compromised? Files "/usr/lib.hwm", "/usr/lib.pwd", "/usr/lib.pwi" Klaus Pforte Linux - Security 4 09-28-2004 11:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration