-   Slackware (
-   -   sbopkg Unknown token error (

jjthomas 11-21-2012 02:32 PM

sbopkg Unknown token error
I'm trying to build ffmpeg using sbopkg passing on the configuration DC1394=yes. I have libdc1394 installed. I've tried varations of

sbopkg -i ffmpeg DC1394=yes
with and without quotes and I cannot seem to get it to build.

I've google'd and read the man page but I cannot come up with the correct solution.

This is for Slackware 14.


ponce 11-21-2012 03:21 PM


sbopkg -i ffmpeg:DC1394=yes
from "man sbopkg"

      -b PACKAGE(s)/QUEUE(s)
            Build packages of the argument(s) from  the  active  repository.  If
            more  than one package is specified, they may either be quoted or the
            switch can be given multiple times.  Using this second form, a colon-
            separated list of options may be given.  If whitespace occurs between
            the colons, it must be quoted.

            For example:

                  # sbopkg -b "foo bar"

            will build foo and then bar.


                  # sbopkg -b app1:opt1="foo bar":opt2=baz -b app2:opt=mu

            will build app1 with the options ``foo bar'' and  ``baz'',  and  app2
            with the option ``mu''.


      -i PACKAGE(s)/QUEUE(s)
            Download,  build,  and  install  packages of the argument(s) from the
            active repository.

            See the -b option for details since,  other  than  the  installation,
            these two options operate similarly.

jjthomas 11-21-2012 06:17 PM

Fooey! I tried everything but that one. Thank you. Flagging Solved.



491 DC1394=yes; sbopkg -i ffmpeg
492 sbopkg -i ffmpeg DC1394=yes
493 sbopkg -i ffmpeg | DC1394=yes
494 sbopkg -i ffmpeg DC1394=yes
495 sbopkg -i ffmpeg : DC1394=yes
496 sbopkg -i ffmpeg : DC1394="yes"
497 sbopkg -i ffmpeg | DC1394="yes"
498 sbopkg -i ffmpeg
501 sbopkg -i ffmpeg DC1394=yes
502 sbopkg -i ffmpeg DC1394=YES
503 sbopkg -i ffmpeg "DC1394=YES"
504 sbopkg -i ffmpeg CELT=YES
505 sbopkg -i ffmpeg DC1394|yes
506 sbopkg -i ffmpeg DC1394:yes
507 sbopkg -i ffmpeg "DC1394:yes"
508 sbopkg -i ffmpeg CELT=YES
509 history | grep ffmpeg
510 sbopkg -i ffmpeg | DC1394=yes
511 sbopkg -i ffmpeg DC1394=yes
519 vim ffmpeg.SlackBuild
520 DC1394=yes ./ffmpeg.SlackBuild
521 install /tmp/ffmpeg-0.11.2-x86_64_custom-2_SBo.tgz
522 installpkg /tmp/ffmpeg-0.11.2-x86_64_custom-2_SBo.tgz
524 sbopkg -i ffmpeg:DC1394=yes
526 history | grep ffmpeg
Yours works:

root@ambient:/home/jjthomas/Downloads/ffmpeg# sbopkg -i ffmpeg:DC1394=yes

One or more build option files for the ffmpeg
SlackBuild script were found:

Command line options: DC1394="yes"

Use (N)one, (C)ommand line options, or (A)bort?:

All times are GMT -5. The time now is 11:01 AM.