-   Slackware (
-   -   Sbopkg error (

adriv 04-09-2009 03:19 PM

Sbopkg error
1 Attachment(s)
Since I installed SW 12.2 sbopkg gives an error when I try to start it. It's on both machines and I've been puzzled by it:

sbopkg: Can't find a value for variable(s):

If you have recently upgraded sbopkg there may be
new variables in the sbopkg.conf file.  Please
merge the file with your existing
sbopkg.conf file.  Please see the sbopkg.conf(5)
man page for more details.

Please correct this error and run sbopkg again.

So it's complaining about the KEEPLOG value, which is strange in my opinion, because the KEEPLOG value is set to YES (which is the default value).
It's probably something simple that I'm overlooking, but canot seem to figure it out. The old sbopkg directory in my /home/ is deleted.
/etc/sbopkg/sbopkg.conf is attached.
Attachment 435

larryhaja 04-09-2009 03:52 PM

Did you recently upgrade sbopkg? If so, then from the error message you are getting is saying there is a new configuration file at /etc/sbopkg/ I believe a similar error message happened to me when I upgraded sbopkg in the past. If you have slackpkg installed you can merge the new conf file with the old.

# slackpkg new-config
Choose option "O" to overwrite the old file with the new.

adriv 04-09-2009 04:48 PM

That's indeed what you would expect from the error, but that's not the case.
It's a new installation on a brand new SW12.2.
There is no /etc/sbopkg/


ls /etc/sbopkg
sbopkg-renames  sbopkg.conf

chess 04-09-2009 04:50 PM

adriv, if you can, join #sbopkg on freenode or post to the sbopkg mailing list.

In the meantime, is there anything unusual about your install? Are you running a full, stock Slackware 12.2 install? Are you running stock bash3 or did you upgrade to bash4 in /testing? Have you upgraded to the latest sbopkg (we just released a bugfix 0.27.1 the other day)?

Have you tried backing up your own sbopkg.conf and using the sample that comes with it?

adriv 04-09-2009 05:05 PM


No, it's not an upgrade and as said: I deleted my old sbopkg directory in my /home/ (on both comnputers!). And both pc's had a full install (apart from Emacs..)

I'm upgrading sbopkg right now and....
Yes! It works.
Thank you!

Problem solved. :cool:

chess 04-09-2009 05:11 PM

Excellent, glad to hear it!

All times are GMT -5. The time now is 06:20 PM.