LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-28-2018, 10:07 PM   #1351
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 323

Rep: Reputation: 121Reputation: 121

@rworkman,

Yes, I wouldn't have suggested bumping the version for 14.2 - but good to hear it's being updated for -current. I just wasn't sure if it was such a drastic A{B,P}I change that even under current, it would break too much to update it.
 
Old 07-29-2018, 02:48 AM   #1352
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,310

Rep: Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828Reputation: 828
polkit-0.115 has been installed here since July 10th and everything seems fine so far.
 
3 members found this post helpful.
Old 07-31-2018, 08:58 PM   #1353
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 911

Rep: Reputation: 201Reputation: 201Reputation: 201
Quote:
Originally Posted by sombragris View Post
dxx-rebirth still cannot play mp3 music but at least I can have music now!
Good news is that the developer has done some work incorporating sdl2 (which Slackware ships with) and now any form of music (I have tested mp3) can be used with the development version of d2x-rebirth. Updated SlackBuild here...

Now back down the mines.....
 
1 members found this post helpful.
Old 08-03-2018, 08:06 PM   #1354
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 526

Rep: Reputation: 142Reputation: 142
Hi, the recent removal (Changelog Fri Jul 27 21:01:22 UTC 2018) of l/libart_lgpl-2.3.21 prevents compilation of libgnomecanvas (needed for Xournal).

Compiling libart_lgpl (on the source from 14.2) and reinstalling this library makes libgnomecanvas/Xournal work again.
 
Old 08-03-2018, 08:54 PM   #1355
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 323

Rep: Reputation: 121Reputation: 121
Guess libart_lgpl could always be added to SBO... Any takers?
 
Old 08-04-2018, 01:04 AM   #1356
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,425

Original Poster
Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
I actually did it some days ago and merged it today

http://cgit.ponce.cc/slackbuilds/commit/?h=libart-lgpl
http://cgit.ponce.cc/slackbuilds/com...libgnomecanvas

note that is added as libart-lgpl in the unofficial repository for current only, as SBo tracks the stable release and libart_lgpl is already present there.

Last edited by ponce; 08-04-2018 at 01:05 AM.
 
4 members found this post helpful.
Old 08-04-2018, 11:11 AM   #1357
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 104

Rep: Reputation: 37
There seems to be another problem building networkmanager-openvpn.

A bugreport was already made. it seems to be an error in NetworkManager. A patch (for networkmanager) can be found here:
https://cgit.freedesktop.org/Network...c7c568a64c8456

I tested it and it works.

Kr
Mel
 
Old 08-08-2018, 02:11 AM   #1358
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint, Niresh (MacOS)...
Posts: 452

Rep: Reputation: 291Reputation: 291Reputation: 291
This morning I tried to update the packages from FlightGear with slackware64-current and (sbopkg -V SBo-git/current -r), but SimGear failed to build on that message:
----------------------
/usr/bin/ld: ../libSimGearScene.so.2018.2.2: undefined reference to `osgDB::readRefObjectFile(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, osgDB::Options const*)'
/usr/bin/ld: ../libSimGearScene.so.2018.2.2: undefined reference to `osgUtil::RenderBin::find_or_insert(int, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)'
/usr/bin/ld: ../libSimGearScene.so.2018.2.2: undefined reference to `osgDB::ReaderWriter::fileExists(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, osgDB::Options const*) const'
/usr/bin/ld: ../libSimGearScene.so.2018.2.2: undefined reference to `osgDB::ReaderWriter::acceptsExtension(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) const'
collect2: error: ld a retourn� le statut de sortie 1
make[2]: *** [simgear/package/CMakeFiles/sg_pkgutil.dir/build.make:103: simgear/package/sg_pkgutil] Error 1
make[1]: *** [CMakeFiles/Makefile2:667: simgear/package/CMakeFiles/sg_pkgutil.dir/all] Error 2
make: *** [Makefile:152: all] Error 2
------------------------
 
Old 08-08-2018, 04:03 AM   #1359
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,425

Original Poster
Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
I've just tried to build FlightGear and all of its dependencies from scratch and it went fine.

have you tried removing FlightGear and all of its dependencies and then rebuild them all? Maybe removing SimGear before rebuilding it against a different version of OpenSceneGraph would be enough, but just in case...

in any case this doesn't look like a current-specific issue but a case in which some libraries links to some other libraries of different versions from the one they were linked to.
 
Old 08-08-2018, 12:47 PM   #1360
qunying
Member
 
Registered: Jun 2002
Distribution: Slackware
Posts: 143

Rep: Reputation: 78
patchelf could be removed, since it is included in current.
 
Old 08-08-2018, 01:01 PM   #1361
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,425

Original Poster
Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
Quote:
Originally Posted by qunying View Post
patchelf could be removed, since it is included in current.
thanks, pushed!
 
Old 08-11-2018, 06:53 AM   #1362
lord_
Member
 
Registered: Apr 2018
Distribution: Slackware -current
Posts: 39

Rep: Reputation: Disabled
ladspa_sdk won't compile

Ladspa_sdk returns a Segmentation fault while building.

Code:
ladspa_sdk/
ladspa_sdk/snd/
ladspa_sdk/snd/noise.wav
ladspa_sdk/README
ladspa_sdk/plugins/
ladspa_sdk/bin/
ladspa_sdk/doc/
ladspa_sdk/doc/shared_plugins.html
ladspa_sdk/doc/changes.html
ladspa_sdk/doc/license.html
ladspa_sdk/doc/download.html
ladspa_sdk/doc/unique_ids.html
ladspa_sdk/doc/background.html
ladspa_sdk/doc/COPYING
ladspa_sdk/doc/index.html
ladspa_sdk/doc/ladspa.h.txt
ladspa_sdk/doc/overview.html
ladspa_sdk/doc/example_plugins.html
ladspa_sdk/doc/installation.html
ladspa_sdk/src/
ladspa_sdk/src/utils.h
ladspa_sdk/src/default.c
ladspa_sdk/src/listplugins.c
ladspa_sdk/src/search.c
ladspa_sdk/src/plugins/
ladspa_sdk/src/plugins/amp.c
ladspa_sdk/src/plugins/sine.cpp
ladspa_sdk/src/plugins/noise.c
ladspa_sdk/src/plugins/delay.c
ladspa_sdk/src/plugins/filter.c
ladspa_sdk/src/load.c
ladspa_sdk/src/ladspa.h
ladspa_sdk/src/makefile
ladspa_sdk/src/applyplugin.c
ladspa_sdk/src/analyseplugin.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC -o plugins/amp.o -c plugins/amp.c
ld -o ../plugins/amp.so plugins/amp.o -shared
cc -O2 -fPIC -I. -Wall -Werror -fPIC -o plugins/delay.o -c plugins/delay.c
ld -o ../plugins/delay.so plugins/delay.o -shared
cc -O2 -fPIC -I. -Wall -Werror -fPIC -o plugins/filter.o -c plugins/filter.c
ld -o ../plugins/filter.so plugins/filter.o -shared
cc -O2 -fPIC -I. -Wall -Werror -fPIC -o plugins/noise.o -c plugins/noise.c
ld -o ../plugins/noise.so plugins/noise.o -shared
c++ -O2 -fPIC -I. -Wall -Werror -fPIC -o plugins/sine.o -c plugins/sine.cpp
c++ -o ../plugins/sine.so plugins/sine.o -shared
cc -O2 -fPIC -I. -Wall -Werror -fPIC   -c -o analyseplugin.o analyseplugin.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC   -c -o load.o load.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC   -c -o default.o default.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC -ldl -lm					\
	-o ../bin/analyseplugin 				\
	analyseplugin.o load.o default.o
cc -O2 -fPIC -I. -Wall -Werror -fPIC   -c -o applyplugin.o applyplugin.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC -ldl -lm					\
	-o ../bin/applyplugin					\
	applyplugin.o load.o default.o
cc -O2 -fPIC -I. -Wall -Werror -fPIC   -c -o listplugins.o listplugins.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC   -c -o search.o search.c
cc -O2 -fPIC -I. -Wall -Werror -fPIC -ldl -lm					\
	-o ../bin/listplugins	 				\
	listplugins.o search.o
../bin/listplugins
make: *** [makefile:70: /tmp/test.wav] Segmentation fault
Messing around with gdb listplugins (which is the binary that fails), I get this

Code:
$ gdb listplugins 
GNU gdb (GDB) 8.1.1
Copyright (C) 2018 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-slackware-linux".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from listplugins...done.
(gdb) run
Starting program: /tmp/SBo/ladspa_sdk/bin/listplugins 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
/usr/lib64/ladspa/matrix_st_ms_1420.so:
	Matrix: Stereo to MS (1420/matrixStMS)
/usr/lib64/ladspa/bode_shifter_1431.so:
	Bode frequency shifter (1431/bodeShifter)
/usr/lib64/ladspa/valve_1209.so:
	Valve saturation (1209/valve)
/usr/lib64/ladspa/zm1_1428.so:
	z-1 (1428/zm1)
/usr/lib64/ladspa/ringmod_1188.so:
	Ringmod with two inputs (1188/ringmod_2i1o)
	Ringmod with LFO (1189/ringmod_1i1o1l)
/usr/lib64/ladspa/revdelay_1605.so:
	Reverse Delay (5s max) (1605/revdelay)
/usr/lib64/ladspa/bode_shifter_cv_1432.so:
	Bode frequency shifter (CV) (1432/bodeShifterCV)
/usr/lib64/ladspa/inv_1429.so:
	Inverter (1429/inv)
/usr/lib64/ladspa/sc2_1426.so:
	SC2 (1426/sc2)
/usr/lib64/ladspa/karaoke_1409.so:
	Karaoke (1409/karaoke)
/usr/lib64/ladspa/tap_limiter.so:
/usr/lib64/ladspa/giant_flange_1437.so:
	Giant flange (1437/giantFlange)
/usr/lib64/ladspa/vynil_1905.so:
	VyNil (Vinyl Effect) (1905/vynil)
/usr/lib64/ladspa/fast_lookahead_limiter_1913.so:
	Fast Lookahead limiter (1913/fastLookaheadLimiter)
/usr/lib64/ladspa/decay_1886.so:
	Exponential signal decay (1886/decay)
/usr/lib64/ladspa/matrix_ms_st_1421.so:
	Matrix: MS to Stereo (1421/matrixMSSt)
/usr/lib64/ladspa/valve_rect_1405.so:
	Valve rectifier (1405/valveRect)
/usr/lib64/ladspa/impulse_1885.so:
	Nonbandlimited single-sample impulses (Frequency: Control) (1885/impulse_fc)
/usr/lib64/ladspa/pointer_cast_1910.so:
	Pointer cast distortion (1910/pointerCastDistortion)
/usr/lib64/ladspa/freq_tracker_1418.so:
	Frequency tracker (1418/freqTracker)
/usr/lib64/ladspa/sc1_1425.so:
	SC1 (1425/sc1)

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff7df4df6 in strlen () from /lib64/ld-linux-x86-64.so.2
(gdb) l
1	circular_buffer.c: No such file or directory.
 
Old 08-11-2018, 07:55 AM   #1363
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,425

Original Poster
Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
looks like it segfaults there when it tries to play a test sound: it doesn't happen here, I tried both on a physical machine and a virtual one without a soundcard.
 
Old 08-11-2018, 08:36 AM   #1364
lord_
Member
 
Registered: Apr 2018
Distribution: Slackware -current
Posts: 39

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
looks like it segfaults there when it tries to play a test sound: it doesn't happen here, I tried both on a physical machine and a virtual one without a soundcard.
A reboot made things work again

Personal memorandum: reboot asap when you upgrade the kernel.

I rebuild ladspa_sdk because it's an optional dependency of mlt (on which I'm stuck), but it seems it wasn't the problem.

https://pastebin.com/raw/sryKEpfg
 
Old 08-11-2018, 08:39 AM   #1365
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,425

Original Poster
Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
Quote:
Originally Posted by lord_ View Post
mlt (on which I'm stuck), but it seems it wasn't the problem.

https://pastebin.com/raw/sryKEpfg
disable the php and java bindings

http://cgit.ponce.cc/slackbuilds/commit/?h=mlt
 
1 members found this post helpful.
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration