LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-27-2018, 09:08 AM   #1276
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,314

Original Poster
Rep: Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524

that's strange, because here inkscape and its dependencies built fine on a clean slackware current installation: maybe you missed something.
 
Old 06-27-2018, 09:17 AM   #1277
lord_
Member
 
Registered: Apr 2018
Distribution: Slackware -current
Posts: 44

Rep: Reputation: Disabled
I rebuild:
  • potrace-1.15-x86_64-1_ponce
  • numpy3-1.14.3-x86_64-1_ponce
  • python-webencodings-0.5.1-x86_64-1_ponce
  • six-1.11.0-x86_64-1_SBo
  • html5lib-0.999999999-x86_64-1_ponce
  • BeautifulSoup4-4.6.0-x86_64-1_ponce
  • lxml-4.2.1-x86_64-1_ponce

What am I missing?
 
Old 06-27-2018, 09:38 AM   #1278
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,314

Original Poster
Rep: Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524
numpy3 is not an inkscape dependency, numpy is.

consider that what breaks the build could also be an optional dependency of a dependency (like cssselect or Sphinx and its dependencies, for example).

Last edited by ponce; 06-27-2018 at 09:41 AM.
 
Old 06-27-2018, 04:39 PM   #1279
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 1,998

Rep: Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564Reputation: 6564
Quote:
Originally Posted by lord_ View Post
I rebuild:
  • potrace-1.15-x86_64-1_ponce
  • numpy3-1.14.3-x86_64-1_ponce
  • python-webencodings-0.5.1-x86_64-1_ponce
  • six-1.11.0-x86_64-1_SBo
  • html5lib-0.999999999-x86_64-1_ponce
  • BeautifulSoup4-4.6.0-x86_64-1_ponce
  • lxml-4.2.1-x86_64-1_ponce

What am I missing?
Got any stray .la files that are pulling in -lssp?
 
Old 06-28-2018, 04:25 AM   #1280
lord_
Member
 
Registered: Apr 2018
Distribution: Slackware -current
Posts: 44

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
that's strange, because here inkscape and its dependencies built fine on a clean slackware current installation: maybe you missed something.
I managed to solve my situation: looking at
Code:
$ ldd -u /usr/bin/inkscape 
Unused direct dependencies:
	/usr/lib64/libgtkspell.so.0
	/usr/lib64/libgsl.so.23
	/usr/lib64/libgslcblas.so.0
	/usr/lib64/libpng16.so.16
	/usr/lib64/libxslt.so.1
	/lib64/libz.so.1
	/usr/lib64/libgomp.so.1
	/usr/lib64/libaspell.so.15
	/usr/lib64/libpangomm-1.4.so.1
	/usr/lib64/libgdk-x11-2.0.so.0
	/usr/lib64/libpangocairo-1.0.so.0
	/usr/lib64/libatk-1.0.so.0
	/usr/lib64/libgdk_pixbuf-2.0.so.0
	/usr/lib64/libpangoft2-1.0.so.0
	/usr/lib64/libpango-1.0.so.0
	/usr/lib64/libfribidi.so.0
	/usr/lib64/libfontconfig.so.1
	/usr/lib64/libgiomm-2.4.so.1
	/usr/lib64/libgio-2.0.so.0
	/usr/lib64/libexif.so.12
	/usr/lib64/libgnomevfs-2.so.0
	/usr/lib64/libdbus-glib-1.so.2
	/lib64/libssl.so.1
	/lib64/libcrypto.so.1
	/usr/lib64/libavahi-glib.so.1
	/usr/lib64/libavahi-client.so.3
	/usr/lib64/libdbus-1.so.3
	/usr/lib64/libavahi-common.so.3
	/lib64/libdl.so.2
	/lib64/libresolv.so.2
	/lib64/libutil.so.1
	/usr/lib64/libgconf-2.so.4
	/usr/lib64/libgthread-2.0.so.0
	/usr/lib64/libgmodule-2.0.so.0
	/usr/lib64/libfreetype.so.6
	/usr/lib64/libwpg-0.3.so.3
	/usr/lib64/libvisio-0.1.so.1
	/usr/lib64/librevenge-0.0.so.0
	/usr/lib64/librevenge-stream-0.0.so.0
	/usr/lib64/libMagickWand-6.Q16HDRI.so.6
	/usr/lib64/libMagickCore-6.Q16HDRI.so.6
	/usr/lib64/libX11.so.6
	/usr/lib64/libjpeg.so.62
	/usr/lib64/libpotrace.so.0
	/usr/lib64/liblcms2.so.2
	/usr/lib64/libpoppler-glib.so.8
	/usr/lib64/libcairo.so.2
	/lib64/libm.so.6
	/usr/lib64/libgcc_s.so.1
	/lib64/libpthread.so.0
I found that I had to update all these packages:

Code:
gtkspell-2.0.16-x86_64-4:usr/lib64/libgtkspell.so.0.0.0
gsl-2.5-x86_64-1:usr/lib64/libgsl.so.23.1.0
gsl-2.5-x86_64-1:usr/lib64/libgslcblas.so.0.0.0
aaa_elflibs-15.0-x86_64-2:usr/lib64/libpng16.so.16.34.0
libpng-1.6.34-x86_64-2:usr/lib64/libpng16.so.16.34.0
libxslt-1.1.32-x86_64-2:usr/lib64/libxslt.so.1.1.32
aaa_elflibs-15.0-x86_64-2:lib64/libz.so.1.2.11
zlib-1.2.11-x86_64-2:lib64/libz.so.1.2.11
gcc-8.1.1-x86_64-1:usr/lib64/libgomp.so.1.0.0
aspell-0.60.6.1-x86_64-3:usr/lib64/libaspell.so.15.1.5
pangomm-2.40.1-x86_64-2:usr/lib64/libpangomm-1.4.so.1.0.30
gtk+2-2.24.32-x86_64-2:usr/lib64/libgdk-x11-2.0.so.0.2400.32
pango-1.42.1-x86_64-2:usr/lib64/libpangocairo-1.0.so.0.4200.1
atk-2.28.1-x86_64-2:usr/lib64/libatk-1.0.so.0.22810.1
gdk-pixbuf2-2.36.12-x86_64-2:usr/lib64/libgdk_pixbuf-2.0.so.0.3612.0
pango-1.42.1-x86_64-2:usr/lib64/libpangoft2-1.0.so.0.4200.1
pango-1.42.1-x86_64-2:usr/lib64/libpango-1.0.so.0.4200.1
fribidi-1.0.4-x86_64-1:usr/lib64/libfribidi.so.0.4.0
fontconfig-2.12.6-x86_64-2:usr/lib64/libfontconfig.so.1.10.1
glibmm-2.56.0-x86_64-1:usr/lib64/libgiomm-2.4.so.1.3.0
glib2-2.56.1-x86_64-2:usr/lib64/libgio-2.0.so.0.5600.1
libexif-0.6.21-x86_64-2:usr/lib64/libexif.so.12.3.3
gnome-vfs-2.24.4-x86_64-3_ponce:usr/lib64/libgnomevfs-2.so.0.2400.4
dbus-glib-0.110-x86_64-2:usr/lib64/libdbus-glib-1.so.2.3.4
openssl-1.1.0h-x86_64-2:lib64/libssl.so.1.1
openssl-solibs-1.1.0h-x86_64-2:lib64/libssl.so.1.1
openssl-1.1.0h-x86_64-2:lib64/libcrypto.so.1.1
openssl-solibs-1.1.0h-x86_64-2:lib64/libcrypto.so.1.1
avahi-0.6.32-x86_64-1_ponce:usr/lib64/libavahi-glib.so.1.0.2
avahi-0.6.32-x86_64-1_ponce:usr/lib64/libavahi-client.so.3.2.9
dbus-1.12.8-x86_64-1:usr/lib64/libdbus-1.so.3.19.7
avahi-0.6.32-x86_64-1_ponce:usr/lib64/libavahi-common.so.3.5.3
GConf-3.2.6-x86_64-4:usr/lib64/libgconf-2.so.4.1.5
aaa_elflibs-15.0-x86_64-2:usr/lib64/libgthread-2.0.so.0.5600.1
glib2-2.56.1-x86_64-2:usr/lib64/libgthread-2.0.so.0.5600.1
aaa_elflibs-15.0-x86_64-2:usr/lib64/libgmodule-2.0.so.0.5600.1
glib2-2.56.1-x86_64-2:usr/lib64/libgmodule-2.0.so.0.5600.1
freetype-2.9-x86_64-2:usr/lib64/libfreetype.so.6.16.0
libwpg-0.3.1-x86_64-2:usr/lib64/libwpg-0.3.so.3.0.1
libvisio-0.1.6-x86_64-4:usr/lib64/libvisio-0.1.so.1.0.6
librevenge-0.0.4-x86_64-2:usr/lib64/librevenge-0.0.so.0.0.4
librevenge-0.0.4-x86_64-2:usr/lib64/librevenge-stream-0.0.so.0.0.4
imagemagick-6.9.10_3-x86_64-1:usr/lib64/libMagickWand-6.Q16HDRI.so.6.0.0
imagemagick-6.9.10_3-x86_64-1:usr/lib64/libMagickCore-6.Q16HDRI.so.6.0.0
libX11-1.6.5-x86_64-2:usr/lib64/libX11.so.6.3.0
aaa_elflibs-15.0-x86_64-2:usr/lib64/libjpeg.so.62.2.0
libjpeg-turbo-1.5.3-x86_64-2:usr/lib64/libjpeg.so.62.2.0
potrace-1.15-x86_64-1_ponce:usr/lib64/libpotrace.so.0.0.5
lcms2-2.9-x86_64-2:usr/lib64/liblcms2.so.2.0.8
poppler-0.66.0-x86_64-1:usr/lib64/libpoppler-glib.so.8.9.0
cairo-1.15.12-x86_64-2:usr/lib64/libcairo.so.2.11512.0
aaa_elflibs-15.0-x86_64-2:usr/lib64/libgcc_s.so.1
gcc-8.1.1-x86_64-1:usr/lib64/libgcc_s.so.1
Since there are mostly Slackware packages (and they're surely up to date); I focused at 3rd party ones

Code:
gnome-vfs-2.24.4-x86_64-3_ponce:usr/lib64/libgnomevfs-2.so.0.2400.4
avahi-0.6.32-x86_64-1_ponce:usr/lib64/libavahi-glib.so.1.0.2
avahi-0.6.32-x86_64-1_ponce:usr/lib64/libavahi-client.so.3.2.9
avahi-0.6.32-x86_64-1_ponce:usr/lib64/libavahi-common.so.3.5.3
potrace-1.15-x86_64-1_ponce:usr/lib64/libpotrace.so.0.0.5
So I updated avahi and gnome-vfs (and their dependencies) and I finally rebuild inkscape without any errors
 
1 members found this post helpful.
Old 06-28-2018, 07:31 AM   #1281
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,947

Rep: Reputation: Disabled
Can you please report the undocumented dependencies to the SBo maintainer?
 
Old 06-30-2018, 03:26 AM   #1282
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 106

Rep: Reputation: 45
NetworkManager-OpenVPN doesn't build anymore since the upgrade to NetworkManager. The configure gives following error:

Code:
checking for LIBSECRET... yes
checking for LIBNM_GTK... no
configure: error: Package requirements (libnm-gtk >= 1.2.0) were not met:

Package 'NetworkManager', required by 'libnm-gtk', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBNM_GTK_CFLAGS
and LIBNM_GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
 
1 members found this post helpful.
Old 06-30-2018, 03:41 AM   #1283
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,314

Original Poster
Rep: Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524Reputation: 3524
I think it hasn't catched up yet with NetworkManager's 1.12.0 release, it seems to me there's nothing in their git yet...
https://github.com/GNOME/network-man...commits/master
 
Old 06-30-2018, 04:04 AM   #1284
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 106

Rep: Reputation: 45
Quote:
Originally Posted by ponce View Post
I think it hasn't catched up yet with NetworkManager's 1.12.0 release, it seems to me there's nothing in their git yet...
https://github.com/GNOME/network-man...commits/master
I tried the latest version... 1.8 something, didnt work either...

afterwards I thought it might be the nm-applet (because it has the libnm-gtk library), but I was unable to rebuild it:
Code:
checking for ISO_CODES... yes
checking for LIBNM_GLIB... no
configure: error: Package requirements (gio-2.0 >= 2.32
		 NetworkManager >= 1.2
		 libnm-glib >= 1.2
		 libnm-util >= 1.2
		 libnm-glib-vpn >= 1.2
		 gmodule-export-2.0) were not met:

No package 'NetworkManager' found
No package 'libnm-glib' found
No package 'libnm-util' found
No package 'libnm-glib-vpn' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBNM_GLIB_CFLAGS
and LIBNM_GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
 
Old 06-30-2018, 12:02 PM   #1285
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,802
Blog Entries: 1

Rep: Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182
Quote:
Originally Posted by mmawhin View Post
NetworkManager-OpenVPN doesn't build anymore since the upgrade to NetworkManager. The configure gives following error:

Code:
checking for LIBSECRET... yes
checking for LIBNM_GTK... no
configure: error: Package requirements (libnm-gtk >= 1.2.0) were not met:

Package 'NetworkManager', required by 'libnm-gtk', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBNM_GTK_CFLAGS
and LIBNM_GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Same here and it doesn't work either with yesterday's upgrade to NetworkManager-1.12.0-x86_64-1.txz.
I tried to rebuild NetworkManager-OpenVPN and when it failed, I reinstalled NetworkManager-1.10.10-x86_64-1.txz and that solved the problem (for now).
 
Old 06-30-2018, 09:27 PM   #1286
RadicalDreamer
Senior Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 1,451

Rep: Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731Reputation: 731
Quote:
Originally Posted by lord_ View Post
I rebuild:
  • six-1.11.0-x86_64-1_SBo
That library is apart of Current.
 
Old 07-01-2018, 05:52 AM   #1287
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 106

Rep: Reputation: 45
Quote:
Originally Posted by cwizardone View Post
Same here and it doesn't work either with yesterday's upgrade to NetworkManager-1.12.0-x86_64-1.txz.
I tried to rebuild NetworkManager-OpenVPN and when it failed, I reinstalled NetworkManager-1.10.10-x86_64-1.txz and that solved the problem (for now).
I was able to build NetworkManager-OpenVPN (a newer version 1.8.4) with the --without-libnm-glib flag. However, starting a VPN client is then no longer possible with nm-applet (it does work with nmcli). I tried rebuilding the applet, but no luck sofar.

Kr
Mel
 
2 members found this post helpful.
Old 07-01-2018, 07:28 PM   #1288
cwizardone
LQ Veteran
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib."
Posts: 6,802
Blog Entries: 1

Rep: Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182Reputation: 4182
Quote:
Originally Posted by mmawhin View Post
I was able to build NetworkManager-OpenVPN (a newer version 1.8.4) with the --without-libnm-glib flag. However, starting a VPN client is then no longer possible with nm-applet (it does work with nmcli). I tried rebuilding the applet, but no luck sofar.

Kr
Mel
Today's changes to -current allow NetworkManager-OpenVPN to be re-built, but it still does Not work with NetworkManager. Once again I've had to re-install NetworkManager-1.10.10-x86_64-1.txz and my previous build of NetworkManager-OpenVPN to be able to start a vpn connection.
 
Old 07-02-2018, 01:04 AM   #1289
Melke
Member
 
Registered: Sep 2009
Location: Graz, Austria
Distribution: Slackware Current
Posts: 106

Rep: Reputation: 45
Quote:
Originally Posted by cwizardone View Post
Today's changes to -current allow NetworkManager-OpenVPN to be re-built, but it still does Not work with NetworkManager. Once again I've had to re-install NetworkManager-1.10.10-x86_64-1.txz and my previous build of NetworkManager-OpenVPN to be able to start a vpn connection.
Strangely enough the vpn can be started with nmcli on the command line.
 
1 members found this post helpful.
Old 07-02-2018, 01:21 PM   #1290
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 496

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Quote:
Originally Posted by lord_ View Post
I removed /usr/local/lib64/perl5 (actually I renamed perl5 in perl5.old) because I got this error:

Code:
$ cpan
ListUtil.c: loadable library and perl binaries are mismatched (got handshake key 0xde00080, needed 0xce00080)
After that, I managed to upgrade all my modules with
Code:
cpan -u
At last, I rebuild all the perl modules that I had as slackbuilds.

I have only a few packages left to rebuild: perl-pango and perl-gtk2. So I'm stuck at perl-pango.
Got exactly the same problem - have rebuilt a number of perl packages but got stuck at perl-pango, getting this error message in the build process:
Code:
Gtk2-1.24992/maps_pango-1.6
xs/Pango.c: loadable library and perl binaries are mismatched (got handshake key 0xde00080, needed 0xce00080)
Rebuilt pango-1.42.1 (without issues) but that didn't solve the problem.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration