LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-26-2017, 12:00 PM   #856
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled

Please report this to the maintainer and on the SBo mailing list.
 
Old 12-27-2017, 06:04 PM   #857
seb_62
LQ Newbie
 
Registered: Feb 2015
Location: North of France
Distribution: slackware 14.2 & current
Posts: 8

Rep: Reputation: Disabled
Guile problem with Gnucash

Hi,

I'm not sure that my problem belong to this subject ; tell me if I should better question the Gnucash SB maintainer.

When I try building on current the Gnucash SB (from SBo or Ponce repository) after all dependencies are installed, it claims that there is not Guile installed, whereas it is in version 2.2.3. The problem is corrected by installation of Guile1.8.

Thank you for your opinion on this problem, and the eventual patch you could apply.

Best regards,

Sébastien

Last edited by seb_62; 12-27-2017 at 06:05 PM.
 
Old 12-27-2017, 06:29 PM   #858
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled
thanks for reporting!

looks like gnucash is not compatible with guile-2.2.x in current (not even version 2.6.19, released a few days ago) so, yes, using guile1.8 available on SBo seems a reasonable choice (as the build system look also for that alternate version).
another alternative should be to submit to SBo, when submissions for the next Slackware release will open, another SlackBuild for guile2.0 (it can't be done now as it's the same version of the present stable) and let gnucash use that, but IMHO should work fine with 1.8 without the hassle of maintaining another SlackBuild.

you can report this to the gnucash maintainer on SBo, if you feel like, but he might not be interested as he should guaranteed a clean build on stable, not current.
 
Old 12-27-2017, 07:53 PM   #859
seb_62
LQ Newbie
 
Registered: Feb 2015
Location: North of France
Distribution: slackware 14.2 & current
Posts: 8

Rep: Reputation: Disabled
Thank you very much for your reply ; I'll use guile1.8.

Best regards,
Sébastien
 
Old 01-05-2018, 09:58 AM   #860
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32
Posts: 315

Rep: Reputation: 24
Musescore yields problem again.

I used scripts directly from you, Ponce:
https://github.com/Ponce/slackbuilds...edia/MuseScore


Code:
 [  7%] Building CXX object thirdparty/freetype/CMakeFiles/mscore_freetype.dir/mscore_freetype_autogen/mocs_compilation.cpp.o
[  7%] Linking CXX static library libmscore_freetype.a
make[3]: Leaving directory '/tmp/SBo/MuseScore-2.1.0/build.release'
[  7%] Built target mscore_freetype
make[2]: Leaving directory '/tmp/SBo/MuseScore-2.1.0/build.release'
make[1]: *** [Makefile:152: all] Error 2
make[1]: Leaving directory '/tmp/SBo/MuseScore-2.1.0/build.release'
make: *** [Makefile:48: release] Error 2
bash-4.4#
 
Old 01-05-2018, 10:33 AM   #861
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled
hi brodo, MuseScore builds fine here... have you rebuilt also all of its dependencies?
can you please post the full log somewhere (pastebin or whatever)?
 
Old 01-06-2018, 05:41 AM   #862
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32
Posts: 315

Rep: Reputation: 24
Musescore went well, because I recompiled all deps (QT - long time used !) using your github scripts.

Thanks again !
 
Old 01-06-2018, 03:41 PM   #863
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 990

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
@ponce

need to remove this --> python3-sip

Because slackware-current provide sip with python 2 +3 binds , and this overlap original python3 binding provided by slackware.


Some gstreamer components are too old , no problem building , but same as plugins i think is good idea go with same versions...thats only suggestion.

Quote:
gstreamer-editing-services
gst-python
gst-python3
Thanks for your work man.
 
Old 01-06-2018, 05:33 PM   #864
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled
all done, will go in at the next update.
thanks to you for reporting!
 
Old 01-06-2018, 07:10 PM   #865
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 990

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
Quote:
Originally Posted by ponce View Post
all done, will go in at the next update.
thanks to you for reporting!
Sorry , i encounter python3-PyQt5 , have some configs for python3-sip from sbo , probably need tweaks.
 
Old 01-07-2018, 01:49 AM   #866
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
Sorry , i encounter python3-PyQt5 , have some configs for python3-sip from sbo , probably need tweaks.
sorry, I can't understand...
 
Old 01-07-2018, 02:47 PM   #867
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 990

Rep: Reputation: 306Reputation: 306Reputation: 306Reputation: 306
Quote:
Originally Posted by ponce View Post
sorry, I can't understand...
python3-pyqt5 , want some especific files from "sbo package python3-sip"

if remove python3-sip slackbuild (overlaping oficial sip packaged from current) , then if try to build from SBo

python3-pyqt5 , get a error message , cause in config time have some points to /usr/bin/python3-sip , and that executable is not provided for sip package from current.

--------------------------------------------------------

easy test , on clean current machine , go to build python3-pyqt5 , but no install python3-sip from sbo to no overwrite original sip binding from slackware , ... then you see error messages...cuase suposed executable no exist on oficial package "sip"
 
Old 01-08-2018, 04:09 AM   #868
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
python3-pyqt5 , want some especific files from "sbo package python3-sip"

if remove python3-sip slackbuild (overlaping oficial sip packaged from current) , then if try to build from SBo

python3-pyqt5 , get a error message , cause in config time have some points to /usr/bin/python3-sip , and that executable is not provided for sip package from current.

--------------------------------------------------------

easy test , on clean current machine , go to build python3-pyqt5 , but no install python3-sip from sbo to no overwrite original sip binding from slackware , ... then you see error messages...cuase suposed executable no exist on oficial package "sip"
thanks for reporting: these two lines must be changed to use the sip package from current
Code:
--- python3-PyQt5.SlackBuild.orig       2018-01-08 10:04:03.934891880 +0100
+++ python3-PyQt5.SlackBuild    2018-01-08 10:05:25.764891568 +0100
@@ -93,8 +93,8 @@
   --confirm-license \
   --verbose \
   -q /usr/bin/qmake-qt5 \
-  --sip=/usr/bin/python3-sip \
-  --sip-incdir=/usr/include/python$PYTHONVER
+  --sip=/usr/bin/sip3 \
+  --sip-incdir=/usr/include/python${PYTHONVER}m
 
 make
 make install DESTDIR=$PKG INSTALL_ROOT=$PKG

Last edited by ponce; 01-08-2018 at 04:10 AM.
 
Old 01-09-2018, 06:14 PM   #869
qunying
Member
 
Registered: Jun 2002
Distribution: Slackware
Posts: 143

Rep: Reputation: 78
dpkg could not compile properly under current. This is due to ncurses package now has libtinfo as a separate lib.

I added the following line just before the make call in the build script. Seems working fine.

Code:
sed -i 's/lncursesw/lncursesw -ltinfo/g' dselect/Makefile
 
Old 01-10-2018, 09:46 AM   #870
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,484

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by qunying View Post
dpkg could not compile properly under current. This is due to ncurses package now has libtinfo as a separate lib.

I added the following line just before the make call in the build script. Seems working fine.

Code:
sed -i 's/lncursesw/lncursesw -ltinfo/g' dselect/Makefile
that's strange, I just tried building it on a fresh installation and everything went fine.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration