LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-31-2017, 03:18 AM   #691
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Original Poster
Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901

Quote:
Originally Posted by phenixia2003 View Post
Hello,



I tried to build vbox on an old virtualized -current (20170704) and it works well. Therefore, I checked existing changes between my old current and -current, and the issue is due to a change done in latest glibc (2.25 vs 2.26), and more precisely the following change in /usr/include/sys/ucontext.h :
Code:
 /* Number of general registers.  */
-#define NGREG	23
+#define __NGREG	23
+#ifdef __USE_MISC
+# define NGREG	__NGREG
+#endif
This change leads to the conflicting types in VBoxDTraceTypes.h.

The attached patch Attachment 25801 (see below) fixes this issue.
Code:
--- src/VBox/ExtPacks/VBoxDTrace/include/VBoxDTraceTypes.h.orig	2017-08-30 14:43:09.000632019 +0200
+++ src/VBox/ExtPacks/VBoxDTrace/include/VBoxDTraceTypes.h	2017-08-30 14:46:09.577874319 +0200
@@ -55,7 +55,7 @@
 typedef uint32_t                    id_t;
 typedef uint32_t                    zoneid_t;
 #endif
-#if !defined(NGREG) || !defined(RT_OS_LINUX)
+#if !defined(__NGREG) || !defined(RT_OS_LINUX)
 typedef RTCCINTREG                  greg_t;
 #else
 AssertCompileSize(greg_t, sizeof(RTCCINTREG));
To apply this patch, make the changes below (in bold) to virtualbox.SlackBuild :
Code:
# Fix wrong path to rdesktop-vrdp-keymaps
patch -p1 -i $CWD/006-rdesktop-vrdp-keymap-path.patch

patch -p0<$CWD/VBoxDTraceTypes-glibc-2.26.patch

--
SeB
thanks SeB, I got it wrong blaming gcc!
I'm pushing the patch in the unofficial repository.
 
Old 08-31-2017, 05:18 AM   #692
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 368

Rep: Reputation: 67
Hi ponce I have mailed the maintainer; but on my previous computer I did not run into problems compiling openBlas (also on current though); Possibly the processor on my new computer is released after version 0.2.11 of openBlas on Slackbuilds.org.
 
Old 09-01-2017, 10:17 PM   #693
zakame
Member
 
Registered: Apr 2012
Distribution: Debian, Ubuntu, Slackware
Posts: 216

Rep: Reputation: 118Reputation: 118
sbcl needs a ucontext patch: https://bugs.launchpad.net/sbcl/+bug/1714549
 
Old 09-02-2017, 05:16 AM   #694
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Original Poster
Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
thanks Zak, pushed!
 
1 members found this post helpful.
Old 09-14-2017, 05:42 PM   #695
brodo
Member
 
Registered: Jan 2004
Location: Poland, Poznan
Distribution: Slackware current 32
Posts: 283

Rep: Reputation: 19
Hello,

I found that a a new version of Kicad 4.0.7 just emerged about a month ago.
I tried to compile it, but I went into wxwidgets/wxpython dependency mess ...
How can we do it properly ?
 
Old 09-15-2017, 11:14 PM   #696
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 431

Rep: Reputation: 186Reputation: 186
Thanks ponce, your live555 works great
 
Old 09-17-2017, 04:04 AM   #697
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint, Niresh (MacOS)...
Posts: 168

Rep: Reputation: 139Reputation: 139
Can't get FreeCAD built on slackware-current, it's ok on slackware-14.2. Here is the error:
---------------------
[ 31%] Building CXX object src/Gui/CMakeFiles/FreeCADGui.dir/WorkbenchPyImp.cpp.o
[ 31%] Building CXX object src/Gui/CMakeFiles/FreeCADGui.dir/SelectionObjectPyImp.cpp.o
[ 31%] Building CXX object src/Gui/CMakeFiles/FreeCADGui.dir/SelectionObject.cpp.o
[ 31%] Building CXX object src/Gui/CMakeFiles/FreeCADGui.dir/Selection.cpp.o
[ 31%] Building CXX object src/Gui/CMakeFiles/FreeCADGui.dir/SelectionFilter.cpp.o
[ 31%] Building CXX object src/Gui/CMakeFiles/FreeCADGui.dir/PreCompiled.cpp.o
make[2]: *** Aucune r�gle pour fabriquer la cible ��/usr/lib/libspnav.so��, n�cessaire pour ��lib/libFreeCADGui.so��. Arr�t.
make[1]: *** [CMakeFiles/Makefile2:4493: src/Gui/CMakeFiles/FreeCADGui.dir/all] Error 2
make: *** [Makefile:130: all] Error
-----------------------------
libspnav is installed but doesn't it.
 
Old 09-17-2017, 04:04 AM   #698
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint, Niresh (MacOS)...
Posts: 168

Rep: Reputation: 139Reputation: 139
dont' know why it appears twice?

Last edited by nobodino; 09-17-2017 at 04:05 AM.
 
Old 09-17-2017, 05:19 AM   #699
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,670

Rep: Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971
have you tried to rebuilt all dependencies?
 
Old 09-17-2017, 08:55 AM   #700
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint, Niresh (MacOS)...
Posts: 168

Rep: Reputation: 139Reputation: 139
Yes, I did: "sbopkg -i FreeCAD".
 
Old 09-17-2017, 10:57 AM   #701
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,670

Rep: Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971Reputation: 971
Quote:
Originally Posted by nobodino View Post
Yes, I did: "sbopkg -i FreeCAD".
Did you generate the queue file before running above command?
if you are running -current, some dependencies might not build, ast least numpy.
You need to have a look at this commit
 
Old 09-17-2017, 12:08 PM   #702
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint, Niresh (MacOS)...
Posts: 168

Rep: Reputation: 139Reputation: 139
yes , I did: sqg -a

Last edited by nobodino; 09-17-2017 at 12:11 PM.
 
Old 09-17-2017, 12:14 PM   #703
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Original Poster
Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
FYI, I've just tested building FreeCAD and all of its dependencies using the unofficial repository linked in the first post on two clean full installs, one of slackware-current and the other of slackware64-current, and it went fine in both cases: are you using a different setup from the one I just tested building the stuff onto?
 
Old 09-17-2017, 01:20 PM   #704
nobodino
Member
 
Registered: Jul 2010
Location: in France
Distribution: slackware, slackware from scratch, LFS, linux Mint, Niresh (MacOS)...
Posts: 168

Rep: Reputation: 139Reputation: 139
how do I change from '14.2' to 'something current' repo for SBo?
 
Old 09-17-2017, 01:25 PM   #705
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,850

Original Poster
Rep: Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901Reputation: 1901
Quote:
Originally Posted by nobodino View Post
how do I change from '14.2' to 'something current' repo for SBo?
if you are using sbopkg see here.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration