LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-17-2017, 11:30 AM   #601
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 275

Rep: Reputation: 59

Thank you! Now it works fine after updating SBo-git!
 
Old 06-18-2017, 04:30 PM   #602
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 588

Rep: Reputation: 177Reputation: 177
Hi , i cant build "graphviz" under current , he builds fine in to 14.2 box.

I try , remove all extra SBo packages --> build fails
I try , comment php patch --> build fails

There are some of errors getting , list are very large y copy/paste only some , all point to php ...strange cause in 14,2 builds.

Quote:
gv_php.cpp:1001:27: error: 'gv_globals' was not declared in this scope
#define SWIG_ErrorCode() (gv_globals.error_code)

/usr/include/php/Zend/zend_API.h:250:69: error: cannot convert 'zval* {aka _zval_struct*}' to 'zval*** {aka _zval_struct***}' for argument '2' to 'int _zend_get_parameters_array_ex(int, zval***, void***)'
_zend_get_parameters_array_ex(param_count, argument_array TSRMLS_CC)

gv_php.cpp:5368:9: error: 'res' was not declared in this scope
efree(res->ptr);

gv_php.cpp:1001:27: error: 'gv_globals' was not declared in this scope
#define SWIG_ErrorCode() (gv_globals.error_code)

/usr/include/php/Zend/zend_API.h:250:69: error: cannot convert 'zval* {aka _zval_struct*}' to 'zval*** {aka _zval_struct***}' for argument '2' to 'int _zend_get_parameters_array_ex(int, zval***, void***)'

make[4]: *** [Makefile:2544: libgv_php_la-gv_php.lo] Error 1
 
Old 06-18-2017, 11:37 PM   #603
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,786

Original Poster
Rep: Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852
http://cgit.ponce.cc/slackbuilds/commit/?h=graphviz
 
Old 06-19-2017, 03:44 PM   #604
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 588

Rep: Reputation: 177Reputation: 177
Thanks ponce.

I try first if rebuild php solve this ... probably not, but out of curiosity.
 
Old 06-23-2017, 03:09 PM   #605
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 348

Rep: Reputation: 163Reputation: 163
mypaint-1.2.0 fails to build saying it cannot find json?
Code:
installed               multilib                     json-c-compat32-0.12-x86_64-1compat32     
   installed               slackware64                  qjson-0.8.1-x86_64-1
Code:
mypaint-1.2.0/brushlib/gegl/mypaint-gegl-surface.c
scons: Reading SConscript files ...
building for 'python2.7' (use scons python_binary=xxx to change)
using 'python2.7-config' (use scons python_config=xxx to change)
Delete(["libmypaint-tests.so", "libmypaint-tests.so", "libmypaint.so", "libmypaintlib.so", "libmypaint.a", "libmypaint-tests.a", "lib/_mypaintlib.so"])
Enabling i18n for brushlib in full application build
Could not find 'json-c' pkg-config, trying legacy 'json' instead
Package json was not found in the pkg-config search path.
Perhaps you should add the directory containing `json.pc'
to the PKG_CONFIG_PATH environment variable
No package 'json' found
OSError: 'pkg-config --cflags --libs json ' exited 1:
  File "/tmp/SBo/mypaint-1.2.0/SConstruct", line 235:
    brushlib = SConscript('./brushlib/SConscript')
  File "/usr/lib64/python2.7/site-packages/SCons/Script/SConscript.py", line 604:
    return method(*args, **kw)
  File "/usr/lib64/python2.7/site-packages/SCons/Script/SConscript.py", line 541:
    return _SConscript(self.fs, *files, **subst_kw)
  File "/usr/lib64/python2.7/site-packages/SCons/Script/SConscript.py", line 250:
    exec _file_ in call_stack[-1].globals
  File "/tmp/SBo/mypaint-1.2.0/brushlib/SConscript", line 146:
    parse_pkg_config(env, pkg)
  File "/tmp/SBo/mypaint-1.2.0/brushlib/SConscript", line 73:
    env.ParseConfig(cmd)
  File "/usr/lib64/python2.7/site-packages/SCons/Environment.py", line 1557:
    return function(self, self.backtick(command))
  File "/usr/lib64/python2.7/site-packages/SCons/Environment.py", line 594:
    raise OSError("'%s' exited %d" % (command, status))
 
Old 06-23-2017, 03:42 PM   #606
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,786

Original Poster
Rep: Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852
json-c has been removed in slackware current on february, but I added it again to the unofficial repository, so you can build it from there

https://github.com/Ponce/slackbuilds/commit/json-c

I also have already added it again as a mypaint dependency, will go in the main repository most probably tomorrow

https://github.com/Ponce/slackbuilds/commit/mypaint
 
2 members found this post helpful.
Old 06-23-2017, 04:09 PM   #607
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 348

Rep: Reputation: 163Reputation: 163
Thank you ponce!
 
Old 06-23-2017, 11:25 PM   #608
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 348

Rep: Reputation: 163Reputation: 163
I had to use mypaint 1.2.1 because of this issue while running: "Crash on startup to Exception on startup: TypeError: GLib.filename_to_utf8() takes exactly 2 arguments (4 given)"
https://github.com/mypaint/mypaint/releases
 
Old 06-24-2017, 12:49 AM   #609
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,786

Original Poster
Rep: Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852
thanks for reporting, I version bumped it too in the repository for current.
 
1 members found this post helpful.
Old 06-24-2017, 03:23 AM   #610
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 336

Rep: Reputation: 64
Hi,

current upgrade of libgsl broke my inkscape build and re-compiling that stopped with

Quote:
ui/tools/flood-tool.cpp:1124:5: note: here
case GDK_MOTION_NOTIFY:
^~~~
make[3]: *** [Makefile:8413: ui/tools/flood-tool.o] Error 1
Would the patch mentioned at the bottom of the this bug-report help to repair this?
//bugs.debian.org/cgi-bin/bugreport.cgi?bug=853453

Last edited by brobr; 06-24-2017 at 03:26 AM.
 
Old 06-24-2017, 03:40 AM   #611
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 3,786

Original Poster
Rep: Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852Reputation: 1852
hi brobr, I just tried to build inkscape and all of its dependencies on a clean install of slackware64-current and everyhting went fine (no patches for gcc7 seem needed): I suppose yours is a local issue...

the one you linked seems not to be the actual error: please try rebuilding also all of the dependencies and see if the error persists.

if it does please paste the full log somewhere like pastebin.com (split it in more parts if there's a size limit).

Last edited by ponce; 06-24-2017 at 05:44 AM.
 
Old 06-24-2017, 09:38 AM   #612
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 336

Rep: Reputation: 64
Hi ponce,

I did as you advised (reinstalled reportlab, unicovertor; six,BeautifulSoup4, html5lib, lxml; numpy), but no joy. My system follows current and until now no problems. Last compile of inkscape 0.92.1 was 29 April; For now I added a symbolic link for the old libgsl to get my current inkscape-build to work. Not ideal of course; I attached the last section where the error starts; hopefully that is informative.

Cheers,

rob
Attached Files
File Type: txt error-section.txt (13.9 KB, 6 views)
 
Old 06-24-2017, 11:07 AM   #613
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,647

Rep: Reputation: 958Reputation: 958Reputation: 958Reputation: 958Reputation: 958Reputation: 958Reputation: 958Reputation: 958
Hi Rob,

i just got the same result as Ponce.
inkscape built fine on latest -current update

Code:
numpy:
  MD5SUM check for numpy-1.11.1.tar.gz ... OK
  Building package numpy-1.11.1-x86_64-1_SBo.tgz ... OK
  Installing package numpy-1.11.1-x86_64-1_SBo.tgz ... OK

html5lib:
  MD5SUM check for html5lib-python-0.9999999.tar.gz ... OK
  Building package html5lib-0.9999999-x86_64-1_SBo.tgz ... OK
  Installing package html5lib-0.9999999-x86_64-1_SBo.tgz ... OK

BeautifulSoup4:
  MD5SUM check for beautifulsoup4-4.5.3.tar.gz ... OK
  Building package BeautifulSoup4-4.5.3-x86_64-1_SBo.tgz ... OK
  Installing package BeautifulSoup4-4.5.3-x86_64-1_SBo.tgz ... OK

lxml:
  MD5SUM check for lxml-lxml-3.8.0.tar.gz ... OK
  Building package lxml-3.8.0-x86_64-1_SBo.tgz ... OK
  Installing package lxml-3.8.0-x86_64-1_SBo.tgz ... OK

inkscape:
  MD5SUM check for inkscape-0.92.1.tar.bz2 ... OK
  Building package inkscape-0.92.1-x86_64-1_SBo.tgz ... OK
  Installing package inkscape-0.92.1-x86_64-1_SBo.tgz ... OK

Last edited by willysr; 06-24-2017 at 11:09 AM.
 
Old 06-24-2017, 12:20 PM   #614
USUARIONUEVO
Member
 
Registered: Apr 2015
Posts: 588

Rep: Reputation: 177Reputation: 177
@brobr

Quote:
six
this is included in current as

python-six
 
Old 06-26-2017, 05:07 PM   #615
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 336

Rep: Reputation: 64
@usuarionuevo: thanks for reminding me
@ponce and willysr: thanks for the feedback. That hinted at the possibility that something was missing from my system or I was using a different source.

Still, after syncing with the latest current, reinstalling all packages in d, l and x, recompiling lxml, numpy and inkscape from scratch (i.e. letting the SlackBuild script download the source) compilation of inkscape-0.92.1 ran into the same errors:

Quote:
ui/tools/flood-tool.cpp:235:49: error: call of overloaded ‘abs(guint32)’ is ambiguous
ui/tools/flood-tool.cpp:237:109: error: call of overloaded ‘abs(unsigned int)’ is ambiguous
ui/tools/flood-tool.cpp:239:109: error: call of overloaded ‘abs(unsigned int)’ is ambiguous
ui/tools/flood-tool.cpp:241:109: error: call of overloaded ‘abs(unsigned int)’ is ambiguous
ui/tools/flood-tool.cpp:251:119: error: call of overloaded ‘abs(unsigned int)’ is ambiguous
ui/tools/flood-tool.cpp:252:119: error: call of overloaded ‘abs(unsigned int)’ is ambiguous
ui/tools/flood-tool.cpp:253:119: error: call of overloaded ‘abs(unsigned int)’ is ambiguous
Something that keeps these gcc7 complaints down seems to be missing at my end:

1) Today's downloaded inkscape-master (which is gcc 7 compliant) compiled fine (with cmake instead of autotools.sh and ./configure in the inkscape.SlackBuild).
2) Changing the ui/tools/flood-tool.cpp in inkscape-0.92.1 to that of the master - as described in that debian bug-report - is sufficient to get 0.92.1 built on my current-box.

HTH for anyone running into similar problems.

rob

Last edited by brobr; 06-26-2017 at 05:17 PM.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration