LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-16-2021, 08:32 PM   #3841
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,937

Rep: Reputation: 808Reputation: 808Reputation: 808Reputation: 808Reputation: 808Reputation: 808Reputation: 808

Quote:
Originally Posted by kevmccor View Post
I was able to build and install /system/yelp with sbopkg:

I previously tried upgrading yelp-tools again, with the same error ("python module lxml not found").

This quote from the yelp-tools build log may give a clue:

Maybe there is some confusion between python2 and python3, or maybe something is not right in my system.

It is not causing me any apparent problems, so basically this is FYI.

Thanks
I don't use SBo to build my packages I have my own SlackBuilds.

I build yelp-tools with yelp-xsl and python-lxml as dependencies. Yelp tools is a meson build. I build python-lxml with python3. I am currently on 40.0 yelp and 4.6.1 python-lxml.
 
Old 05-17-2021, 07:17 AM   #3842
pm_a_cup_of_tea
LQ Newbie
 
Registered: May 2021
Posts: 7

Rep: Reputation: Disabled
error installing Gtk-Sharp from slackbuilds

Ultimately I'm attempting to install Bless, the hex editor. Bless relies on Gkt-Sharp which in return relies on mono. I had no issues following the build instructions and mono 'seemingly' built successfully but while attempting to build Gtk-Sharp I ran into the following error. I'm using the SBo-git repository and trying to build on current.

Code:
/tmp/SBo/gtk-sharp-2.12.45/sample/test/../../gtk/gtk-sharp.dll (Location of the symbol related to previous error)
./TestRange.cs(35,13): error CS0030: Cannot convert type `Gtk.HScale' to `System.Range'
./TestRange.cs(42,6): error CS0104: `Range' is an ambiguous reference between `System.Range' and `Gtk.Range'
/usr/lib/mono/4.5/mscorlib.dll (Location of the symbol related to previous error)
/tmp/SBo/gtk-sharp-2.12.45/sample/test/../../gtk/gtk-sharp.dll (Location of the symbol related to previous error)
./TestRange.cs(42,13): error CS0030: Cannot convert type `Gtk.HScrollbar' to `System.Range'
./TestRange.cs(62,6): error CS0104: `Range' is an ambiguous reference between `System.Range' and `Gtk.Range'
/usr/lib/mono/4.5/mscorlib.dll (Location of the symbol related to previous error)
/tmp/SBo/gtk-sharp-2.12.45/sample/test/../../gtk/gtk-sharp.dll (Location of the symbol related to previous error)
./TestRange.cs(62,13): error CS0030: Cannot convert type `Gtk.VScale' to `System.Range'
./TestCombo.cs(31,20): warning CS0612: `Gtk.Combo' is obsolete
Compilation failed: 6 error(s), 2 warnings
make[3]: *** [Makefile:502: WidgetViewer.exe] Error 1
make[3]: Leaving directory '/tmp/SBo/gtk-sharp-2.12.45/sample/test'
make[2]: *** [Makefile:440: all-recursive] Error 1
make[2]: Leaving directory '/tmp/SBo/gtk-sharp-2.12.45/sample'
make[1]: *** [Makefile:454: all-recursive] Error 1
make[1]: Leaving directory '/tmp/SBo/gtk-sharp-2.12.45'
make: *** [Makefile:382: all] Error 2
I consider myself a 'learner' any help/explanation would be benefical.

Last edited by pm_a_cup_of_tea; 05-17-2021 at 07:19 AM.
 
Old 05-17-2021, 07:37 AM   #3843
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,168

Original Poster
Rep: Reputation: Disabled
hi pm_a_cup_of_tea,

mono is unmaintained on SBo and it has been recently upgraded to version 6.12.0.122 following requests in other topics here on LQ.
I don't know if whatever depends on mono has been tested with the newer version too (that should have been something that a maintainer would have to do) but you can try asking also to the interested script maintainer, in this specific case the gtk-sharp one.

EDIT: it seems this patch actually helps the script build

https://raw.githubusercontent.com/ar...gtkrange.patch

https://git.slackbuilds.org/slackbui...it/?id=6262b17

Last edited by ponce; 05-17-2021 at 08:44 AM.
 
Old 05-17-2021, 09:40 AM   #3844
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,937

Rep: Reputation: 808Reputation: 808Reputation: 808Reputation: 808Reputation: 808Reputation: 808Reputation: 808
Quote:
Originally Posted by ponce View Post
hi pm_a_cup_of_tea,

mono is unmaintained on SBo and it has been recently upgraded to version 6.12.0.122 following requests in other topics here on LQ.
I don't know if whatever depends on mono has been tested with the newer version too (that should have been something that a maintainer would have to do) but you can try asking also to the interested script maintainer, in this specific case the gtk-sharp one.

EDIT: it seems this patch actually helps the script build

https://raw.githubusercontent.com/ar...gtkrange.patch

https://git.slackbuilds.org/slackbui...it/?id=6262b17
For what it is worth, I am using gtk-sharp 2.12.45. I checked the files in the patch, those changes in the patch are included in this version.
 
Old 05-17-2021, 10:03 AM   #3845
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,168

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by chrisretusn View Post
For what it is worth, I am using gtk-sharp 2.12.45. I checked the files in the patch, those changes in the patch are included in this version.
are you sure? because they don't seem to be in the upstream tarball...

Last edited by ponce; 05-17-2021 at 12:10 PM. Reason: fixed link
 
Old 05-17-2021, 12:51 PM   #3846
pm_a_cup_of_tea
LQ Newbie
 
Registered: May 2021
Posts: 7

Rep: Reputation: Disabled
Error while building Bless

Quote:
Originally Posted by ponce View Post
Ok, thank you Ponce the patch worked... except now I've encountered an error building Bless


Code:
make[1]: Leaving directory '/tmp/SBo/bless-0.6.0/tests'
/usr/bin/mono builder/bless-builder.exe Bless -nowarn:0169  -d:ENABLE_UNIX_SPECIFIC
>> Building module Bless.Util...
Ok
>> Building module Bless.Tools...
Ok
>> Building module Bless.Buffers...
/tmp/SBo/bless-0.6.0/src/buffers/ByteBuffer.cs(673,52): error CS0104: `Range' is an ambiguous reference between `System.Range' and `Bless.Util.Range'
/usr/lib/mono/4.5/mscorlib.dll (Location of the symbol related to previous error)
/tmp/SBo/bless-0.6.0/bin/Bless.Util.dll (Location of the symbol related to previous error)
/tmp/SBo/bless-0.6.0/src/buffers/SaveOperation.cs(64,23): warning CS0109: The member `Bless.Buffers.SaveOperation.StageReached' does not hide an inherited member. The new keyword is not required
Compilation failed: 1 error(s), 1 warnings
Failed
make: *** [Makefile:627: all] Error 1
On a personal note, I installed Bless from source from a github repo. The latest release of Bless was in 2017 the edition of the book I'm reading is from 2009... maybe I should update my resources... nevertheless thank you for directing to the gtk-sharp patch.

Last edited by pm_a_cup_of_tea; 05-17-2021 at 12:53 PM.
 
Old 05-17-2021, 01:00 PM   #3847
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,168

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by pm_a_cup_of_tea View Post
Ok, thank you Ponce the patch worked... except now I've encountered an error building Bless

Code:
make[1]: Leaving directory '/tmp/SBo/bless-0.6.0/tests'
/usr/bin/mono builder/bless-builder.exe Bless -nowarn:0169  -d:ENABLE_UNIX_SPECIFIC
>> Building module Bless.Util...
Ok
>> Building module Bless.Tools...
Ok
>> Building module Bless.Buffers...
/tmp/SBo/bless-0.6.0/src/buffers/ByteBuffer.cs(673,52): error CS0104: `Range' is an ambiguous reference between `System.Range' and `Bless.Util.Range'
/usr/lib/mono/4.5/mscorlib.dll (Location of the symbol related to previous error)
/tmp/SBo/bless-0.6.0/bin/Bless.Util.dll (Location of the symbol related to previous error)
/tmp/SBo/bless-0.6.0/src/buffers/SaveOperation.cs(64,23): warning CS0109: The member `Bless.Buffers.SaveOperation.StageReached' does not hide an inherited member. The new keyword is not required
Compilation failed: 1 error(s), 1 warnings
Failed
make: *** [Makefile:627: all] Error 1
I think you need to apply also this patch in the SlackBuild.
 
Old 05-17-2021, 01:24 PM   #3848
pm_a_cup_of_tea
LQ Newbie
 
Registered: May 2021
Posts: 7

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
I think you need to apply also this patch in the SlackBuild.
!
Again, that worked. Thank you, again. Lawdy that Slackbuild was an entertaining read!

To B. Watson if you are reading. I was glad it was there Although perhaps later I'll look for another hex editor
 
Old 05-17-2021, 01:38 PM   #3849
however
Member
 
Registered: Jan 2019
Distribution: slackware current
Posts: 224

Rep: Reputation: Disabled
Hi Ponce,

has there been any development regarding aegisub deps an/or the fact that it won't build on slackware current?

I cannot build the sbopkg and if I install the binary from pckgs.org i get the following error msg:
Quote:
bash-5.1$ aegisub
aegisub: error while loading shared libraries: libass.so.5: cannot open shared object file: No such file or directory
bash-5.1$
I have found a cpl of aegisub related posts on this thread but thy all seem 'hangin' and some rumors that aegisub support was deprecated in some ubuntu and debian cases (although i did not pay too much attention to the details as not my distros)

Grazie
 
Old 05-17-2021, 01:48 PM   #3850
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,168

Original Poster
Rep: Reputation: Disabled
hi however, I just tried to build aegisub and it built fine here on current with the scripts of this repository so it should be something related to your installation.
like explained in the first post of this topic if you need help with build errors with your custom installation please open another topic: I also suggest you to post in it the build errors you got so people can try to help.
I'm sorry but I have no idea on what is on pkgs.org: forgive me if, in this specific case (I'm referring to pkgs.org), I don't even care.

Last edited by ponce; 05-17-2021 at 01:50 PM.
 
Old 05-17-2021, 03:53 PM   #3851
however
Member
 
Registered: Jan 2019
Distribution: slackware current
Posts: 224

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
hi however, I just tried to build aegisub and it built fine here on current with the scripts of this repository so it should be something related to your installation.
like explained in the first post of this topic if you need help with build errors with your custom installation please open another topic: I also suggest you to post in it the build errors you got so people can try to help.
I'm sorry but I have no idea on what is on pkgs.org: forgive me if, in this specific case (I'm referring to pkgs.org), I don't even care.
thank you Ponce,

I tried to build aegisub again and the same happened.

I will do that (open a thread) although, I am not sure what you mean by 'custom installation' since I have a pretty standard slackware current installation, upgraded regularly with slackpkg

p.s.: my bad, it is pkgs.org (not pckgs.org)
 
Old 05-17-2021, 04:08 PM   #3852
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,168

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by however View Post
I am not sure what you mean by 'custom installation'
if you do a full install of slackware current from scratch then you have a "clean and full installation of Slackware current" as referred in the first post of this topic (please re-read it carefully).
if you install something else in your OS (a package is enough) then you have a custom installation and you shouldn't post in this topic if something from the unofficial repository for current doesn't build in your OS.
also, if you, nevertheless, decide to post about your build failure and I test it here and I am not able to reproduce it you should take it as an hint that the problem you got is specific of your installation so this topic is not the one to discuss about it.

Last edited by ponce; 05-17-2021 at 04:12 PM.
 
1 members found this post helpful.
Old 05-17-2021, 04:29 PM   #3853
however
Member
 
Registered: Jan 2019
Distribution: slackware current
Posts: 224

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
if you do a full install of slackware current from scratch then you have a "clean and full installation of Slackware current" as referred in the first post of this topic (please re-read it carefully).
if you install something else in your OS (a package is enough) then you have a custom installation and you shouldn't post in this topic if something from the unofficial repository for current doesn't build in your OS.
also, if you, nevertheless, decide to post about your build failure and I test it here and I am not able to reproduce it you should take it as an hint that the problem you got is specific of your installation so this topic is not the one to discuss about it.
gotcha! )
 
Old 05-17-2021, 04:41 PM   #3854
Ilgar
Senior Member
 
Registered: Jan 2005
Location: Istanbul, Turkey
Distribution: Slackware64 14.2, Slackwarearm-current
Posts: 1,056

Rep: Reputation: 163Reputation: 163
Hello,

In the last two days I compiled quite a few packages for -current using ponce's repository. Here are two issues I ran into:

1) gdl, a requirement for inkscape is not in the repo. Using the slackbuild for 14.2 works. Inkscape is at version 1.0 in the repo and versions 1.1 and later do not use gdl. So we either need a version bump in inkscape or the addition of gdl. Since I'm not the decision maker on this I decided to drop it here.

2) qucs is in the repo but apparently it has no Qt5 support yet, and does not compile. It should probably be removed.

There were also build issues with xfce4-xkb-plugin, ktikz, coq, udftools, unetbootin, qcad, aqemu, shaderc. I contacted the maintainers about these. I managed to compile all but the last two by upgrading to the latest versions and/or modifying the slackbuild a little.
 
Old 05-17-2021, 05:27 PM   #3855
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 8,268

Rep: Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859Reputation: 5859
Quote:
Originally Posted by Ilgar View Post
2) qucs is in the repo but apparently it has no Qt5 support yet, and does not compile. It should probably be removed.
I think a qt4 SlackBuild is in the works to be added to SBo for 15.0 to allow all that software that was never updated to qt5 to still be able to be used. If a piece of software can be updated to qt5, it probably should, but if it only supports qt4, removal because of that should only happen if it's found a qt4 SlackBuild isn't going to be added to SBo.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration