LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-12-2021, 09:56 PM   #3826
frtorres
Member
 
Registered: Jul 2012
Posts: 42

Rep: Reputation: Disabled

Quote:
Originally Posted by willysr View Post
Hi, i'm sorry for this mistake
i have fixed it on my branch which will be merged to master soon
but in the meantime, you can see the changes here https://git.slackbuilds.org/slackbui...03fb8c1244ea18
Thank you Willy. No problem As I have installed netdata without that patch. Could you please explain in general terms this patch's purpose? I saw the changes but I could not inferred its purpose.

Thanks in advance.

Francisco.

Update: I just built netdata-v1.30.1-x86_64-1_SBo.tgz from the provided URL with changes. I updated over previous netdata-1.29.3-x86_64-1_SBo version.

Thanks again Willy.

Last edited by frtorres; 05-12-2021 at 11:22 PM. Reason: Updating my progress
 
Old 05-13-2021, 12:29 AM   #3827
frtorres
Member
 
Registered: Jul 2012
Posts: 42

Rep: Reputation: Disabled
dehydrated not present in Ponce Repo but present in SlackBuilds.org

Hello Ponce.

I want to follow this Alien Bob Guide to setup https on my server.

‘dehydrated‘, a 3rd-party and free Let’s Encrypt client is required but not present in ponce repo.

In fact it is present in SlackBuilds.org. Alien Bob installed it from that repo.

Should it be present in Ponce's repo?

May I install in slackware-current ‘dehydrated‘ from Slackbuilds.org manually?

Thanks in advance for your comments and advice.

Francisco.
 
Old 05-13-2021, 12:31 AM   #3828
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,152

Original Poster
Rep: Reputation: Disabled
dehydrated has been added to Slackware current after 14.2 was released and has been removed from the repository to avoid duplicate packages: you should have it already available if you are using Slackware current.
 
1 members found this post helpful.
Old 05-13-2021, 12:32 AM   #3829
Ook
Member
 
Registered: Apr 2004
Location: Hell, Arizona (July - 118 degrees)
Distribution: Slackware 14.2 soon to be Slackware 15
Posts: 663

Rep: Reputation: 127Reputation: 127
Quote:
pm me and I can share it off my server for you (Ooc) if you want to try it; but I'd suggest a full -current install if not already.
Tyvm. I fired up a VM and installed slackware-current. Built gcab there just fine. I wish I knew what I did to my system that it won't build, it was a clean install of slackware-current just a few weeks ago <shrug>.

Once I got that in, the rest of the deps for flatpak installed, and flatpak installed and ran just fine.
 
Old 05-13-2021, 06:53 AM   #3830
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 651

Rep: Reputation: 317Reputation: 317Reputation: 317Reputation: 317
diakonos: url not working, new dependency

Quote:
Originally Posted by ponce View Post
keep using the mailing list for issues that are affecting 14.2 only.
report here only issues affecting current/15.0 with SBo's git master branch or the unofficial repository (but *NOT* if using current with the 14.2 repository), it doesn't matter if they are present also on 14.2.
also, as the weekly updates of the 14.2 repository has now stopped, you can also report issues affecting current/15.0 with SBo's git master branch on the mailing list too.
Did not understand this well. Hope I don't mess this up.

For diakonos:
  1. Download URL is not working anymore.
  2. A newer version (0.9.7) can be downloaded from here: https://github.com/Pistos/diakonos/releases/tag/v0.9.7
  3. This version requires also the curses gem, which is different to the ncurses-ruby SBo package. It's not available in SBo, so for now it must be installed manually via gem.

Once the curses gem is present on the system, the newest diakonos will run correctly.
 
Old 05-13-2021, 07:44 AM   #3831
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,152

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by sombragris View Post
Did not understand this well. Hope I don't mess this up.

For diakonos:
  1. Download URL is not working anymore.
  2. A newer version (0.9.7) can be downloaded from here: https://github.com/Pistos/diakonos/releases/tag/v0.9.7
  3. This version requires also the curses gem, which is different to the ncurses-ruby SBo package. It's not available in SBo, so for now it must be installed manually via gem.

Once the curses gem is present on the system, the newest diakonos will run correctly.
also the old diakonos (available here) doesn't work without the curses gem with the ruby on current: as it is missing dependencies either someone submits here a SlackBuild for the curses ruby gem so that I can put in the repository (I'm sorry but I don't wish to become the maintainer of such ruby gem) or I will be forced to remove diakonos.

Last edited by ponce; 05-13-2021 at 07:46 AM.
 
1 members found this post helpful.
Old 05-15-2021, 01:31 PM   #3832
linuxtinker
Member
 
Registered: Dec 2013
Location: NJ / USA
Distribution: Slackware 64 -Current
Posts: 231

Rep: Reputation: 99
inkscape-1.0.2_2021-01-15_e86c870879

Trying to build inkscape 1.02 on current but it seems to looking for gdl anyone else having issues ?

Code:
-- Checking for modules 'gtkmm-3.0>=3.22;gdkmm-3.0>=3.22;gtk+-3.0>=3.22;gdk-3.0>=3.22;gdl-3.0>=3.4'
--   No package 'gdl-3.0' found
CMake Error at /usr/share/cmake-3.20/Modules/FindPkgConfig.cmake:556 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.20/Modules/FindPkgConfig.cmake:778 (_pkg_check_modules_internal)
  CMakeScripts/DefineDependsandFlags.cmake:259 (pkg_check_modules)
  CMakeLists.txt:139 (include)


-- Configuring incomplete, errors occurred!
Thanks
 
Old 05-15-2021, 01:44 PM   #3833
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,152

Original Poster
Rep: Reputation: Disabled
yes, gdl is one of inkscape dependencies and I think it has been removed from SBo by mistake.
while it gets fixed you can take the SlackBuilds files from this link (just click on the "plain" links at the end of each line)

https://git.slackbuilds.org/slackbui...ec02bc52e180fc
 
Old 05-15-2021, 04:51 PM   #3834
frtorres
Member
 
Registered: Jul 2012
Posts: 42

Rep: Reputation: Disabled
recoll 1.22.3 not building

Hi Ponce.

No I am trying to build recoll from recoll-1.22.3.tar.gz using sbopkg on ponce repo.

I got this compilation error

Code:
ssearch_w.cpp:76:22: error: invalid use of incomplete type ‘class QAbstractItemView’
   76 |     queryText->view()->installEventFilter(this);
      |                      ^~
In file included from /usr/include/qt5/QtWidgets/qcombobox.h:45,
                 from ssearch_w.cpp:27:
/usr/include/qt5/QtWidgets/qabstractitemdelegate.h:54:7: note: forward declaration of ‘class QAbstractItemView’
   54 | class QAbstractItemView;
      |       ^~~~~~~~~~~~~~~~~
ssearch_w.cpp: In member function ‘virtual bool SSearch::eventFilter(QObject*, QEvent*)’:
ssearch_w.cpp:715:16: error: comparison between distinct pointer types ‘QObject*’ and ‘QAbstractItemView*’ lacks a cast
  715 |     if (target == queryText->view()) {
      |         ~~~~~~~^~~~~~~~~~~~~~~~~~~~
make[2]: *** [Makefile:2945: .obj/ssearch_w.o] Error 1
make[2]: Leaving directory '/tmp/SBo/recoll-1.22.3/qtgui'
make[1]: *** [Makefile:2188: recollqt] Error 2
make[1]: Leaving directory '/tmp/SBo/recoll-1.22.3'
make: *** [Makefile:1022: all] Error 2
Thanks in advance for your help and advice.

Francisco.
 
Old 05-15-2021, 07:15 PM   #3835
linuxtinker
Member
 
Registered: Dec 2013
Location: NJ / USA
Distribution: Slackware 64 -Current
Posts: 231

Rep: Reputation: 99
Quote:
Originally Posted by ponce View Post
yes, gdl is one of inkscape dependencies and I think it has been removed from SBo by mistake.
while it gets fixed you can take the SlackBuilds files from this link (just click on the "plain" links at the end of each line)

https://git.slackbuilds.org/slackbui...ec02bc52e180fc

OK thank you! That was my next move, thought I might of missed why gdl was removed .
 
Old 05-16-2021, 03:33 AM   #3836
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,152

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by frtorres View Post
Hi Ponce.

No I am trying to build recoll from recoll-1.22.3.tar.gz using sbopkg on ponce repo.

I got this compilation error

Code:
ssearch_w.cpp:76:22: error: invalid use of incomplete type ‘class QAbstractItemView’
   76 |     queryText->view()->installEventFilter(this);
      |                      ^~
In file included from /usr/include/qt5/QtWidgets/qcombobox.h:45,
                 from ssearch_w.cpp:27:
/usr/include/qt5/QtWidgets/qabstractitemdelegate.h:54:7: note: forward declaration of ‘class QAbstractItemView’
   54 | class QAbstractItemView;
      |       ^~~~~~~~~~~~~~~~~
ssearch_w.cpp: In member function ‘virtual bool SSearch::eventFilter(QObject*, QEvent*)’:
ssearch_w.cpp:715:16: error: comparison between distinct pointer types ‘QObject*’ and ‘QAbstractItemView*’ lacks a cast
  715 |     if (target == queryText->view()) {
      |         ~~~~~~~^~~~~~~~~~~~~~~~~~~~
make[2]: *** [Makefile:2945: .obj/ssearch_w.o] Error 1
make[2]: Leaving directory '/tmp/SBo/recoll-1.22.3/qtgui'
make[1]: *** [Makefile:2188: recollqt] Error 2
make[1]: Leaving directory '/tmp/SBo/recoll-1.22.3'
make: *** [Makefile:1022: all] Error 2
Thanks in advance for your help and advice.

Francisco.
Hi Francisco,

the version of recoll in the repository didn't work with qt5 so I updated it in our git and it will go in at the next update

https://git.slackbuilds.org/slackbui...it/?id=3c1b97d
 
1 members found this post helpful.
Old 05-16-2021, 09:15 AM   #3837
kevmccor
Member
 
Registered: Aug 2004
Location: Texas
Distribution: slackware
Posts: 141

Rep: Reputation: 38
yelp-tools issue

Quote:
Originally Posted by willysr View Post
i added lxml as dep for yelp-xsl
I was able to build and install /system/yelp with sbopkg:
Quote:
$ ls /var/log/packages/ | grep yelp
yelp-40.0-x86_64-1ponce
yelp-tools-3.18.0-x86_64-1ponce
yelp-xsl-40.0-x86_64-1ponce
I previously tried upgrading yelp-tools again, with the same error ("python module lxml not found").

This quote from the yelp-tools build log may give a clue:
Quote:
Build started at 2021-05-16T08:47:49.065600
Main binary: /usr/bin/python3
Build Options: -Dprefix=/usr -Dinfodir=/usr/info -Dlibdir=/usr/lib64 -Dlocalstatedir=/var -Dmandir=/usr/man -Dsysconfdir=/etc -Dbuildtype=release
Python system: Linux
The Meson build system
Version: 0.58.0
Source dir: /tmp/SBo/yelp-tools-40.0
Build dir: /tmp/SBo/yelp-tools-40.0/build
Build type: native build
Project name: yelp-tools
Project version: 40.rc
Build machine cpu family: x86_64
Build machine cpu: x86_64
Host machine cpu family: x86_64
Host machine cpu: x86_64
Target machine cpu family: x86_64
Target machine cpu: x86_64
Program python3 found: YES (/usr/bin/python3)
Running command: /usr/bin/python3 -c import lxml
--- stdout ---

--- stderr ---
Traceback (most recent call last):
File "<string>", line 1, in <module>
ModuleNotFoundError: No module named 'lxml'


../meson.build:12:0: ERROR: Assert failed: Python module `lxml` required
Maybe there is some confusion between python2 and python3, or maybe something is not right in my system.

It is not causing me any apparent problems, so basically this is FYI.

Thanks
 
Old 05-16-2021, 02:27 PM   #3838
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,306

Rep: Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512
Have you make sure that lxml is built with python 2 and 3?
 
Old 05-16-2021, 02:31 PM   #3839
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,306

Rep: Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512Reputation: 1512
Quote:
Originally Posted by ponce View Post
yes, gdl is one of inkscape dependencies and I think it has been removed from SBo by mistake.
while it gets fixed you can take the SlackBuilds files from this link (just click on the "plain" links at the end of each line)

https://git.slackbuilds.org/slackbui...ec02bc52e180fc
OK, gdl is now re-added on my branch
it wasn't showing up in the reverse lookup and i thought only anjuta that needs it.
 
Old 05-16-2021, 08:05 PM   #3840
richarson
Member
 
Registered: Dec 2020
Location: Argentina
Distribution: Slackware64-current
Posts: 46

Rep: Reputation: Disabled
Hello,

youtube-dl 2021.05.16 is released, version 2021.04.26 is not available anymore in the usual download location.

Haven't tested the build yet as I have other packages to upgrade.
 
1 members found this post helpful.
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration