LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-10-2021, 06:49 PM   #3691
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 707

Rep: Reputation: 180Reputation: 180

Quote:
Originally Posted by brobr View Post
Hi, after the poppler upgrade Scribus does not build:

It has been reported already upstream: https://bugs.scribus.net/view.php?id=16536
Scribus is compiling with this weeks poppler rebuilt; issue solved.
 
1 members found this post helpful.
Old 04-11-2021, 10:52 AM   #3692
redneonglow
Member
 
Registered: Feb 2020
Location: PA
Distribution: Gentoo, Slackware
Posts: 64

Rep: Reputation: 24
nodejs 12.22.1 won't install because it looks for /usr/sbo/repo/development/nodejs/node-v12.22.1.tar.gz when the .tar.xz file is there instead.
 
Old 04-11-2021, 11:33 AM   #3693
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,079

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by The_First_Post
so, what is this thread for?
risking to be repetitive, report issues here only if you have already tried the scripts from our repository and they won't build on a clean and full installation of Slackware current.

also, if you want to report a problem that applies also to Slackware stable this is not the right place, this topic is current-specific.
if you think a script on SBo shows issues (broken download, not building, etc.) on such platform write to the maintainer and wait some days for an answer (a week should be fine): if the maintainer isn't responsive after this time please post the same thing by mail to the slackbuilds-users mailing list putting the maintainer in cc

http://lists.slackbuilds.org/mailman...ckbuilds-users
https://lists.slackbuilds.org/piperm...il/025597.html
 
Old 04-11-2021, 06:03 PM   #3694
BenCollver
Rogue Class
 
Registered: Sep 2006
Location: OR, USA
Distribution: Slackware64-current
Posts: 251
Blog Entries: 2

Rep: Reputation: 92
The games/desmume build failed with the same error documented below.
https://github.com/TASVideos/desmume/issues/304

I built it on current with the following changes:

desmume.info
============
VERSION="bca921ddae6c8736e938b0010a2ad15da6af51f8"
DOWNLOAD="https://github.com/TASVideos/desmume/archive/bca921ddae6c8736e938b0010a2ad15da6af51f8.zip"
MD5SUM="b144f4074d4cbc2e4b8799c49ef39af4"

desmume.SlackBuild
==================
VERSION=${VERSION:-bca921ddae6c8736e938b0010a2ad15da6af51f8}
# tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
unzip $CWD/$PRGNAM-$VERSION.zip
 
Old 04-12-2021, 12:54 AM   #3695
BenCollver
Rogue Class
 
Registered: Sep 2006
Location: OR, USA
Distribution: Slackware64-current
Posts: 251
Blog Entries: 2

Rep: Reputation: 92
slackbuilds.org/repository/14.2/libraries/pipewire/ fails to build on current with the same error documented in the following patch.

https://gitweb.gentoo.org/repo/gento...73d8fe5f6ac749

It builds after i download the patch and add the following line to pipewire.SlackBuild between the find and meson commands.

patch -p1 <$CWD/pipewire-0.2.7-fno-common.patch
 
Old 04-12-2021, 01:11 AM   #3696
BenCollver
Rogue Class
 
Registered: Sep 2006
Location: OR, USA
Distribution: Slackware64-current
Posts: 251
Blog Entries: 2

Rep: Reputation: 92
The slackbuilds/games/dolphin-emu build fails with an error about `string' in namespace `std' does not name a type.

It builds with the following patch.

$ cat DiscExtractor.h.diff
--- dolphin-20181020_9c9d598/Source/Core/DiscIO/DiscExtractor.h.orig 2018-10-20 08:00:02.000000000 -0700
+++ dolphin-20181020_9c9d598/Source/Core/DiscIO/DiscExtractor.h 2021-04-11 23:10:05.209864021 -0700
@@ -8,6 +8,7 @@
#include <optional>

#include "Common/CommonTypes.h"
+#include <string>

namespace DiscIO
{
 
Old 04-12-2021, 02:12 AM   #3697
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 8,119

Rep: Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648
Quote:
Originally Posted by BenCollver View Post
slackbuilds.org/repository/14.2/libraries/pipewire/ fails to build on current with the same error documented in the following patch.

https://gitweb.gentoo.org/repo/gento...73d8fe5f6ac749

It builds after i download the patch and add the following line to pipewire.SlackBuild between the find and meson commands.

patch -p1 <$CWD/pipewire-0.2.7-fno-common.patch
There's no reason to build pipewire from SBo on -current since it is included in the distro. The pipewire script has already been removed from ponce's repo. If you need to rebuild pipewire, I'd suggest doing it using the script from -current's source/.
 
Old 04-12-2021, 11:18 AM   #3698
BenCollver
Rogue Class
 
Registered: Sep 2006
Location: OR, USA
Distribution: Slackware64-current
Posts: 251
Blog Entries: 2

Rep: Reputation: 92
Quote:
Originally Posted by bassmadrigal View Post
There's no reason to build pipewire from SBo on -current since it is included in the distro.
Thanks for pointing that out! I will use the one included in -current.
 
Old 04-12-2021, 11:40 AM   #3699
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,079

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BenCollver View Post
The slackbuilds/games/dolphin-emu build fails with an error about `string' in namespace `std' does not name a type.

It builds with the following patch.

$ cat DiscExtractor.h.diff
--- dolphin-20181020_9c9d598/Source/Core/DiscIO/DiscExtractor.h.orig 2018-10-20 08:00:02.000000000 -0700
+++ dolphin-20181020_9c9d598/Source/Core/DiscIO/DiscExtractor.h 2021-04-11 23:10:05.209864021 -0700
@@ -8,6 +8,7 @@
#include <optional>

#include "Common/CommonTypes.h"
+#include <string>

namespace DiscIO
{
Quote:
Originally Posted by BenCollver View Post
The games/desmume build failed with the same error documented below.
https://github.com/TASVideos/desmume/issues/304

I built it on current with the following changes:

desmume.info
============
VERSION="bca921ddae6c8736e938b0010a2ad15da6af51f8"
DOWNLOAD="https://github.com/TASVideos/desmume/archive/bca921ddae6c8736e938b0010a2ad15da6af51f8.zip"
MD5SUM="b144f4074d4cbc2e4b8799c49ef39af4"

desmume.SlackBuild
==================
VERSION=${VERSION:-bca921ddae6c8736e938b0010a2ad15da6af51f8}
# tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
unzip $CWD/$PRGNAM-$VERSION.zip
thanks for the reports!

I also found the related dolphin-emu upstream commit that added a couple of other fixes

https://github.com/dolphin-emu/dolph...c3a1e909.patch

...but in the end, as I had already updated dolphin-emu and desmume to git snapshots respectively three and two years ago, I just updated them again to their latest git snapshots! :-)

http://cgit.ponce.cc/slackbuilds/commit/?h=dolphin-emu
http://cgit.ponce.cc/slackbuilds/commit/?h=desmume

Last edited by ponce; 04-12-2021 at 11:59 AM.
 
1 members found this post helpful.
Old 04-12-2021, 03:30 PM   #3700
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.2 64-bit
Posts: 510

Rep: Reputation: 166Reputation: 166
Installing android-tools in current errors out due to missing ninja package:

Code:
 se -b android-tools
Both a queuefile and a package were found with the name "android-tools".

Use (Q)ueuefile, (P)ackage, or (A)bort?: Q

The following packages cannot be found
in the currently active repository
(SBo-git/current) and have been skipped:

pcre2
ninja
ninja is a part of current:

[inst] slackware64 : ninja-1.10.2-x86_64-3

Should this be corrected?
 
Old 04-12-2021, 04:09 PM   #3701
drumz
Member
 
Registered: Apr 2005
Location: Scottsdale, AZ, USA
Distribution: Slackware
Posts: 351

Rep: Reputation: 165Reputation: 165
Quote:
Originally Posted by jostber View Post
Installing android-tools in current errors out due to missing ninja package:

Code:
 se -b android-tools
Both a queuefile and a package were found with the name "android-tools".

Use (Q)ueuefile, (P)ackage, or (A)bort?: Q

The following packages cannot be found
in the currently active repository
(SBo-git/current) and have been skipped:

pcre2
ninja
ninja is a part of current:

[inst] slackware64 : ninja-1.10.2-x86_64-3

Should this be corrected?
The answer is on the previous page of this same thread, and multiple other places:

https://www.linuxquestions.org/quest...ml#post6238991
 
Old 04-12-2021, 06:05 PM   #3702
redneonglow
Member
 
Registered: Feb 2020
Location: PA
Distribution: Gentoo, Slackware
Posts: 64

Rep: Reputation: 24
Quote:
Originally Posted by redneonglow View Post
nodejs 12.22.1 won't install because it looks for /usr/sbo/repo/development/nodejs/node-v12.22.1.tar.gz when the .tar.xz file is there instead.
This is not a -current/ponce issue, this is a problem with the original Slackbuild.
The Slackbuild depends on the .tar.gz while making available the .tar.xz for download on the page.
sbotools pulls in the .tar.xz file.

Should I report this issue to sbotools or the maintainer of the nodejs Slackbuild? Or both?

Last edited by redneonglow; 04-12-2021 at 06:06 PM.
 
Old 04-12-2021, 06:22 PM   #3703
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 8,119

Rep: Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648Reputation: 5648
Quote:
Originally Posted by redneonglow View Post
Should I report this issue to sbotools or the maintainer of the nodejs Slackbuild? Or both?
It's not an issue with sbotools. The maintainer, willysr, either accidentally switched to a tar.xz for the download or intended to switch, but forgot to change the SlackBuild. You should email him (assuming he doesn't see the message on here).
 
Old 04-13-2021, 01:29 AM   #3704
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,079

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by redneonglow View Post
This is not a -current/ponce issue, this is a problem with the original Slackbuild.
The Slackbuild depends on the .tar.gz while making available the .tar.xz for download on the page.
sbotools pulls in the .tar.xz file.

Should I report this issue to sbotools or the maintainer of the nodejs Slackbuild? Or both?
hi redneonglow, I answered with a link just after your post, you probaly missed it

Quote:
Originally Posted by ponce View Post
 
Old 04-13-2021, 03:12 PM   #3705
J_W
Member
 
Registered: Apr 2004
Location: Yamagata, JAPAN
Distribution: Slackware64-current
Posts: 86

Rep: Reputation: 28
recoll-1.30.1

Hello,

This is NOT a bug report but just an information about the latest version of recoll (1.30.1).
I created Japanese translation file for recoll-1.30.0 a couple days ago, then sent it to recoll upstream.
"jf" who is a maintainer of Recoll kindly committed my translation to the recent source repository and released the update version 1.30.1 which includes new Japanese i18n support.
(Thank you jf for your quick action and updating the latest version.)

I created recoll-1.30.1 slackware package for slackware54-current, and also related helper packages.
All SlackBuilds which I used were based on SlackBuilds.org;s script. So, I thought I should announce this information here.

Please refer Recoll upstream site about details.
Recoll upstrean site
slackware packages for slackware64-current
The packages are working fine under slackware64-current now.


J_W
Attached Thumbnails
Click image for larger version

Name:	recoll-1.30.1_en.png
Views:	10
Size:	94.4 KB
ID:	36101   Click image for larger version

Name:	recoll-1.30.1_ja.png
Views:	11
Size:	107.2 KB
ID:	36102  
 
1 members found this post helpful.
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration