LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-07-2021, 01:45 PM   #3661
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,027

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by BrunoLafleur View Post
I have put my last versions of qt4 and qtwebkit4 here :
https://github.com/BrunoLafleur/pbsl.../kde4/other/qt
https://github.com/BrunoLafleur/pbsl...other/qtwebkit

I have compiled them on the latest Slackware current. My KDE4 port is compiling with them.
I have split the original qt package which included qtwebkit (which depends on qt).
qtwebkit can now compile without being removed. qtwebkit is also necessary for a lot of kde4 packages.

I have keep the original name of qt because new packages for qt5 have the 5 in their name and I don't like renaming packages. But if there is some preferences for a renaming I will do it.
I'll have a look at them ASAP!
 
Old 04-07-2021, 02:21 PM   #3662
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 211

Rep: Reputation: 44
Quote:
Originally Posted by enine View Post
It looks like SoQt is looking for Qt4 and not 5.

Code:
checking for QT4... 
Could not gather the configure flags for Qt through pkg-config. Please
ensure that the qt pkg-config metadata .pc files, such as QtCore.pc,
exist on your system. In case the metadata .pc files are installed
into a non-default location verify that the PKG_CONFIG_PATH environment
variable points to the correct directory.
I tried to build SoQt 1.6.0 instead of 1.5.0, end up with QT4 still needed.
But there's a note:
"Before using SoQt, consider whether Quarter is a better match for your
application."

Guessing SoQt is no more... That info is 4 years old...

https://github.com/coin3d/soqt

Side note: info file contain wrong URL for homepage (https://bitbucket.org/Coin3D/soqt)
correct URL is https://github.com/coin3d/soqt

And for Coin:
https://github.com/coin3d/coin

Last edited by MDKDIO; 04-07-2021 at 02:23 PM.
 
Old 04-07-2021, 02:29 PM   #3663
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 211

Rep: Reputation: 44
While at it...
I've tried to build DeadBeef for a couple of hours, but not been able to find a way to sort this dependency, libblockruntime
which is required in latest version of DeadBeef.

Any suggestions?

Thanks in advance!

From README
Quote:
* Clang: GCC is not supported, you need clang
* libdispatch
* libblockruntime
* Yasm: required to build assembly portions of ffap plugin on supported platforms (x86, x86_64)
* intltool: required for localization. If you don't need translations -- run ./configure --disable-nls (in this case you won't need to install intltool, as long as the configure script is already generated)
 
Old 04-07-2021, 04:00 PM   #3664
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,027

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by enine View Post
It looks like SoQt is looking for Qt4 and not 5.

Code:
checking for QT4... 
Could not gather the configure flags for Qt through pkg-config. Please
ensure that the qt pkg-config metadata .pc files, such as QtCore.pc,
exist on your system. In case the metadata .pc files are installed
into a non-default location verify that the PKG_CONFIG_PATH environment
variable points to the correct directory.
I see some FreeCAD forum discussions about weather SoQT is needed in newer versions, maybe an updated FreeCAD slackbuild would eliminate the need for this?

Looks like freecad has the same issue
Code:
-- Found unsuitable Qt version "5.15.2" from /usr/lib/qt5/bin/qmake
Qt QTOPENGL library not found.
Qt QTSVG library not found.
Qt QTUITOOLS library not found.
Qt QTWEBKIT library not found.
Qt QTGUI library not found.
Qt QTXML library not found.
Qt QTNETWORK library not found.
Qt QTCORE library not found.
CMake Error at CMakeLists.txt:827 (MESSAGE):
  ========================

  Qt4 libraries not found.

  ========================
FreeCAD, together with its dependencies, is WIP

https://github.com/Ponce/slackbuilds/pull/94
 
Old 04-07-2021, 05:53 PM   #3665
enine
Senior Member
 
Registered: Nov 2003
Distribution: Slackʍɐɹǝ
Posts: 1,303
Blog Entries: 4

Rep: Reputation: 193Reputation: 193
Quote:
Originally Posted by ponce View Post
FreeCAD, together with its dependencies, is WIP

https://github.com/Ponce/slackbuilds/pull/94
Interesting, I thought maybe it could build with qt5 and found this:

Code:
-DBUILD_QT5=ON \
    -DPYTHON_EXECUTABLE=/usr/bin/python3 \
Based on the instructions here and it did accept them but I ran into this:
Code:
CMake Error at /usr/lib/cmake/Boost-1.75.0/BoostConfig.cmake:141 (find_package):
  Could not find a package configuration file provided by "boost_signals"
  (requested version 1.75.0) with any of the following names:

    boost_signalsConfig.cmake
    boost_signals-config.cmake

  Add the installation prefix of "boost_signals" to CMAKE_PREFIX_PATH or set
  "boost_signals_DIR" to a directory containing one of the above files.  If
  "boost_signals" provides a separate development package or SDK, be sure it
  has been installed.
Call Stack (most recent call first):
  /usr/lib/cmake/Boost-1.75.0/BoostConfig.cmake:258 (boost_find_component)
  /usr/share/cmake-3.20/Modules/FindBoost.cmake:594 (find_package)
  CMakeLists.txt:596 (find_package)
Searching on boost_signals appears that it was dropped around boost 1.69 so it doesn't exist anymore in boost 1.75.

I see you beat me to that and are moving up to FreeCAD 18.4. Do you have a Slackbuild for shiboken2 already?

Last edited by enine; 04-07-2021 at 06:20 PM.
 
Old 04-07-2021, 06:31 PM   #3666
enine
Senior Member
 
Registered: Nov 2003
Distribution: Slackʍɐɹǝ
Posts: 1,303
Blog Entries: 4

Rep: Reputation: 193Reputation: 193
Quote:
Originally Posted by MDKDIO View Post
I tried to build SoQt 1.6.0 instead of 1.5.0, end up with QT4 still needed.
But there's a note:
"Before using SoQt, consider whether Quarter is a better match for your
application."

Guessing SoQt is no more... That info is 4 years old...

https://github.com/coin3d/soqt

Side note: info file contain wrong URL for homepage (https://bitbucket.org/Coin3D/soqt)
correct URL is https://github.com/coin3d/soqt

And for Coin:
https://github.com/coin3d/coin
Is/was SoQt used anywhere else besides FreeCAD? it doesn't look like it

Code:
bash-5.1$ grep 'SoQt' * -r
ChangeLog.txt:development/SoQt: Update homepage.
development/Pivy/Pivy.info:REQUIRES="SoQt"
I only find Pivy and only FreeCAD using Pivy so it looks like we would drop it with a more up to date Pivy.

Last edited by enine; 04-07-2021 at 08:59 PM.
 
Old 04-08-2021, 02:11 AM   #3667
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,027

Original Poster
Rep: Reputation: Disabled
sorry, maybe I wasn't clear: I am not the one working on updating FreeCAD and its dependencies but Heiko, the author of that pull request...
 
Old 04-08-2021, 03:11 AM   #3668
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,027

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by MDKDIO View Post
While at it...
I've tried to build DeadBeef for a couple of hours, but not been able to find a way to sort this dependency, libblockruntime
which is required in latest version of DeadBeef.

Any suggestions?

Thanks in advance!

From README
Quote:
* Clang: GCC is not supported, you need clang
* libdispatch

* libblockruntime
* Yasm: required to build assembly portions of ffap plugin on supported platforms (x86, x86_64)
* intltool: required for localization. If you don't need translations -- run ./configure --disable-nls (in this case you won't need to install intltool, as long as the configure script is already generated)
as you have pasted yourself from the README, the thing is that you have to use clang to build it
Code:
diff -Naur deadbeef.orig/deadbeef.SlackBuild deadbeef/deadbeef.SlackBuild
--- deadbeef.orig/deadbeef.SlackBuild   2021-04-07 09:48:07.170404000 +0200
+++ deadbeef/deadbeef.SlackBuild        2021-04-08 10:06:14.912875000 +0200
@@ -23,7 +23,7 @@
 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 
 PRGNAM=deadbeef
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-1.8.7}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}
 
@@ -70,6 +70,9 @@
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
+export CC=${CC:-clang}
+export CXX=${CXX:-clang++}
+
 CFLAGS="$SLKCFLAGS" \
 CXXFLAGS="$SLKCFLAGS" \
 ./configure \
diff -Naur deadbeef.orig/deadbeef.info deadbeef/deadbeef.info
--- deadbeef.orig/deadbeef.info 2021-04-07 09:48:07.170404000 +0200
+++ deadbeef/deadbeef.info      2021-04-08 10:06:46.607875000 +0200
@@ -1,10 +1,10 @@
 PRGNAM="deadbeef"
-VERSION="1.8.1"
+VERSION="1.8.7"
 HOMEPAGE="http://deadbeef.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/deadbeef/deadbeef-1.8.1.tar.bz2"
-MD5SUM="9c087836aa67b7bc7a873e312b04ce24"
+DOWNLOAD="http://downloads.sourceforge.net/deadbeef/deadbeef-1.8.7.tar.bz2"
+MD5SUM="87af281b5811f2411454501381268606"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
-REQUIRES="jansson"
+REQUIRES="libdispatch"
 MAINTAINER="Ruoh-Shoei Lin"
 EMAIL="lin.ruohshoei@gmail.com"
 
1 members found this post helpful.
Old 04-08-2021, 04:31 AM   #3669
Lockywolf
Member
 
Registered: Jul 2007
Posts: 485

Rep: Reputation: 124Reputation: 124
spatialite_gui needs:

Code:
sed -i 27i'#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H 1' Main.cpp
 
Old 04-08-2021, 05:11 AM   #3670
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,027

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Lockywolf View Post
spatialite_gui needs:

Code:
sed -i 27i'#define ACCEPT_USE_OF_DEPRECATED_PROJ_API_H 1' Main.cpp
sorry Lockywolf, is this current-specific or could/should be applied also to 14.2?
 
Old 04-08-2021, 05:15 AM   #3671
Lockywolf
Member
 
Registered: Jul 2007
Posts: 485

Rep: Reputation: 124Reputation: 124
Quote:
Originally Posted by ponce View Post
sorry Lockywolf, is this current-specific or could/should be applied also to 14.2?
I am not sure. Since 14.2 also has proj 7.2.1, I think, yes, but I do not have a running install of 14.2 to test.
 
Old 04-08-2021, 05:21 AM   #3672
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 6,027

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Lockywolf View Post
I am not sure. Since 14.2 also has proj 7.2.1, I think, yes, but I do not have a running install of 14.2 to test.
well, in the end I think it's safe to push it there too: thanks for that!

https://git.slackbuilds.org/slackbui.../ponce/updates
 
Old 04-08-2021, 09:15 AM   #3673
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 211

Rep: Reputation: 44
Quote:
Originally Posted by enine View Post
Is/was SoQt used anywhere else besides FreeCAD? it doesn't look like it

Code:
bash-5.1$ grep 'SoQt' * -r
ChangeLog.txt:development/SoQt: Update homepage.
development/Pivy/Pivy.info:REQUIRES="SoQt"
I only find Pivy and only FreeCAD using Pivy so it looks like we would drop it with a more up to date Pivy.
I agree, couldn't find any info stating that SoQt is used in any other package either.

But I found this:
"SoQt is no longer used in FreeCAD, it was replaced by Quarter which is a more recent Qt binding."
Found here https://wiki.freecadweb.org/Third_Pa...8deprecated.29
 
Old 04-08-2021, 09:37 AM   #3674
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2 & Current
Posts: 211

Rep: Reputation: 44
Quote:
Originally Posted by ponce View Post
as you have pasted yourself from the README, the thing is that you have to use clang to build it
Code:
diff -Naur deadbeef.orig/deadbeef.SlackBuild deadbeef/deadbeef.SlackBuild
--- deadbeef.orig/deadbeef.SlackBuild   2021-04-07 09:48:07.170404000 +0200
+++ deadbeef/deadbeef.SlackBuild        2021-04-08 10:06:14.912875000 +0200
@@ -23,7 +23,7 @@
 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 
 PRGNAM=deadbeef
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-1.8.7}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}
 
@@ -70,6 +70,9 @@
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
+export CC=${CC:-clang}
+export CXX=${CXX:-clang++}
+
 CFLAGS="$SLKCFLAGS" \
 CXXFLAGS="$SLKCFLAGS" \
 ./configure \
diff -Naur deadbeef.orig/deadbeef.info deadbeef/deadbeef.info
--- deadbeef.orig/deadbeef.info 2021-04-07 09:48:07.170404000 +0200
+++ deadbeef/deadbeef.info      2021-04-08 10:06:46.607875000 +0200
@@ -1,10 +1,10 @@
 PRGNAM="deadbeef"
-VERSION="1.8.1"
+VERSION="1.8.7"
 HOMEPAGE="http://deadbeef.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/deadbeef/deadbeef-1.8.1.tar.bz2"
-MD5SUM="9c087836aa67b7bc7a873e312b04ce24"
+DOWNLOAD="http://downloads.sourceforge.net/deadbeef/deadbeef-1.8.7.tar.bz2"
+MD5SUM="87af281b5811f2411454501381268606"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
-REQUIRES="jansson"
+REQUIRES="libdispatch"
 MAINTAINER="Ruoh-Shoei Lin"
 EMAIL="lin.ruohshoei@gmail.com"
Thank you Ponce!!
That sorted it
Works great!!

I had tried with a dif setting for clang to be used...
 
Old 04-08-2021, 09:38 PM   #3675
enine
Senior Member
 
Registered: Nov 2003
Distribution: Slackʍɐɹǝ
Posts: 1,303
Blog Entries: 4

Rep: Reputation: 193Reputation: 193
I don't see any updated script on your git ponce for ffmpeg

Code:
patching file configure
patching file libavcodec/libopenjpegdec.c
patching file libavcodec/libopenjpegenc.c
patching file libavcodec/libfdk-aacenc.c
ERROR: libopenjpeg not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solve the problem.
looking at the patch the slackbuild applies I see version 2.0 through 2.3 but -current has 2.4 of libopenjpeg
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration