LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-11-2020, 02:35 PM   #2956
slac-in-the-box
Member
 
Registered: Mar 2010
Location: oregon
Distribution: slackware64-current
Posts: 388

Rep: Reputation: 171Reputation: 171

Trying to update 3rd party packages on current, today, 09-11-20, and bctools and belle-sip, dependencies to linphone, wouldn't build because the source links have expired. The same version of sources are still available from gitlab, but I had to find them and manually run slackbuild scripts, so it is a hitch to the sbopkg+ script doing its thing until links are updated. The versions requested are getting pretty outdated, but linphone's build process isn't very slackware friendly, requiring little python pakages that it expects to install with pip instead of installpkg... at least the old links and build script still creates a working linphone: thanks for that, I quite rely on linphone, and haven't found any other suitable sip clients, that can handle static bindings (without sip registration).
 
Old 09-13-2020, 11:22 AM   #2957
StalocX
Member
 
Registered: Aug 2020
Distribution: Slackware
Posts: 32

Rep: Reputation: Disabled
Seems like mpv should be rebuilt against new libplacebo-2.72. As of today mpv only works with old libplacebo-2.43.
 
Old 09-13-2020, 03:00 PM   #2958
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,593

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by StalocX View Post
Seems like mpv should be rebuilt against new libplacebo-2.72. As of today mpv only works with old libplacebo-2.43.
maybe there's a misunderstanding: this is a repository of SlackBuilds, not packages...
the versions of libplacebo and mpv that we have in this repository are the same as on SBo and they work fine on current.
 
1 members found this post helpful.
Old 09-13-2020, 03:08 PM   #2959
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,593

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by slac-in-the-box View Post
Trying to update 3rd party packages on current, today, 09-11-20, and bctools and belle-sip, dependencies to linphone, wouldn't build because the source links have expired.
please re-read very carefully the first post of the thread...
 
1 members found this post helpful.
Old 09-14-2020, 03:56 AM   #2960
StalocX
Member
 
Registered: Aug 2020
Distribution: Slackware
Posts: 32

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
maybe there's a misunderstanding: this is a repository of SlackBuilds, not packages...
the versions of libplacebo and mpv that we have in this repository are the same as on SBo and they work fine on current.
I didn't mean it's a problem, I just informed about version bump, so everybody who is interested in using mpv from your repository should rebuild mpv after update of libplacebo. Did I choose a wrong thread for this purpose? If so, I'm sorry.
 
Old 09-14-2020, 06:33 AM   #2961
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 81

Rep: Reputation: 28
Package desktop/xfce4-volumed-pulse requires libraries/keybinder as dependency. With keybinder installed, builds without any issue.

Code:
checking for keybinder >= 0.2.2... not found
*** The required package keybinder was not found on your system.
*** Please install keybinder (atleast version 0.2.2) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

xfce4-volumed-pulse:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.
 
Old 09-14-2020, 06:47 AM   #2962
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,593

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by StalocX View Post
I didn't mean it's a problem, I just informed about version bump, so everybody who is interested in using mpv from your repository should rebuild mpv after update of libplacebo. Did I choose a wrong thread for this purpose? If so, I'm sorry.
no prob, please have a look at the first post of this thread, it will clarify its purpose.
 
1 members found this post helpful.
Old 09-14-2020, 06:47 AM   #2963
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,593

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by kukibl View Post
Package desktop/xfce4-volumed-pulse requires libraries/keybinder as dependency. With keybinder installed, builds without any issue.

Code:
checking for keybinder >= 0.2.2... not found
*** The required package keybinder was not found on your system.
*** Please install keybinder (atleast version 0.2.2) or adjust
*** the PKG_CONFIG_PATH environment variable if you
*** installed the package in a nonstandard prefix so that
*** pkg-config is able to find it.

xfce4-volumed-pulse:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.
thanks for the report, will push it ASAP!
 
Old 09-14-2020, 08:16 AM   #2964
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 81

Rep: Reputation: 28
SlackBuild for libraries/html5lib requires six and python3-six, but these are not available (I assume because python-six-1.15.0 is already in -current). Therefore REQUIRES in html5lib.info should be fixed:

Code:
PRGNAM="html5lib"
VERSION="1.0.1"
HOMEPAGE="https://github.com/html5lib/"
DOWNLOAD="https://pypi.io/packages/source/h/html5lib/html5lib-1.0.1.tar.gz"
MD5SUM="942a0688d6bdf20d087c9805c40182ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="six python3-six python-webencodings"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
In any case it builds fine, just a remark.

Last edited by kukibl; 09-14-2020 at 08:17 AM. Reason: update
 
Old 09-14-2020, 08:24 AM   #2965
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,593

Original Poster
Rep: Reputation: Disabled
Hi kukibl, maybe you missed it as it was cited before quite a lot of times in the topic and it's also noted in the wiki page of the repository but the *.info files are not edited to remove the dependencies that gets pushed into the current tree as the branches of this fork are a lot (=~ 650) and they get rebased every week, so it doesn't make sense to fix the REQUIRES lines with removals: all of those unnecessary dependencies in the *.info files will be removed when the official SBo repository will move to the next official version of Slackware, in the meantime they should be harmless like you noted.

Last edited by ponce; 09-14-2020 at 08:43 AM.
 
Old 09-14-2020, 08:43 AM   #2966
kukibl
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 81

Rep: Reputation: 28
Yeap, missed it, sorry. Good to know, everything is clear now.
 
Old 09-14-2020, 05:55 PM   #2967
szo
LQ Newbie
 
Registered: Oct 2018
Location: Manhattan ad Maas
Distribution: Slackware Operating System
Posts: 7

Rep: Reputation: Disabled
Just a big THANK YOU ponce for everything you do for us Slackers!
Hope it's not too inappropriate for this thread ... just something I wanted to say for a very long time
 
Old 09-15-2020, 01:44 PM   #2968
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current
Posts: 199
Blog Entries: 1

Rep: Reputation: Disabled
webkitgtk compile error

Webkitgtk and webkitgtk3, which are identical, use v2.4.11 from 2016.
Source/WebCore/platform/graphics/SegmentedFontData.cpp is missing a semi-colon on line 64: U16_NEXT(characters, i, length, c)
All other instances of U16_NEXT under WebCore contain a terminating semi-colon.
 
Old 09-15-2020, 01:55 PM   #2969
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,593

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by hpfeil View Post
Webkitgtk and webkitgtk3, which are identical, use v2.4.11 from 2016.
Source/WebCore/platform/graphics/SegmentedFontData.cpp is missing a semi-colon on line 64: U16_NEXT(characters, i, length, c)
All other instances of U16_NEXT under WebCore contain a terminating semi-colon.
Are you sure that you are using the scripts from this repository?
I'm asking because I already patched both webkitgtk and webkitgtk3 for this nearly one year ago...

Last edited by ponce; 09-15-2020 at 02:44 PM.
 
Old 09-15-2020, 04:52 PM   #2970
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current
Posts: 199
Blog Entries: 1

Rep: Reputation: Disabled
Thanks for pointing out that icu4c-65.1.patch fixes this issue. I copied the patches from your repository, but probably didn't update the SlackBuild. My bad.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration