LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-01-2020, 09:55 AM   #2851
zsd
Member
 
Registered: Dec 2005
Location: Nova Scotia
Distribution: Slackware
Posts: 84

Rep: Reputation: 41

Thanks for the suggestion.
 
Old 07-02-2020, 04:21 AM   #2852
lioh
Member
 
Registered: Aug 2019
Location: Switzerland
Distribution: Slackware
Posts: 142

Rep: Reputation: Disabled
scantailor is not building with the following error:


Code:
/usr/include/eigen3/Eigen/src/Core/Assign.h: In instantiation of 'struct Eigen::internal::assign_traits<Eigen::Matrix<double, 2, 2>, Eigen::Matrix<double, 2, 2> >':
/usr/include/eigen3/Eigen/src/Core/Assign.h:506:64:   required from 'Derived& Eigen::DenseBase<Derived>::lazyAssign(const Eigen::DenseBase<OtherDerived>&) [with OtherDerived = Eigen::Matrix<double, 2, 2>; Derived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:414:30:   required from 'Derived& Eigen::PlainObjectBase<Derived>::lazyAssign(const Eigen::DenseBase<OtherDerived>&) [with OtherDerived = Eigen::Matrix<double, 2, 2>; Derived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/Assign.h:527:123:   required from 'static Derived& Eigen::internal::assign_selector<Derived, OtherDerived, false, false>::run(Derived&, const OtherDerived&) [with Derived = Eigen::Matrix<double, 2, 2>; OtherDerived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:653:72:   required from 'Derived& Eigen::PlainObjectBase<Derived>::_set_noalias(const Eigen::DenseBase<OtherDerived>&) [with OtherDerived = Eigen::Matrix<double, 2, 2>; Derived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/Matrix.h:303:25:   required from 'Eigen::Matrix<_Scalar, _Rows, _Cols, _Options, _MaxRows, _MaxCols>::Matrix(const Eigen::Matrix<_Scalar, _Rows, _Cols, _Options, _MaxRows, _MaxCols>&) [with _Scalar = double; int _Rows = 2; int _Cols = 2; int _Options = 0; int _MaxRows = 2; int _MaxCols = 2]'
/tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/math/HomographicTransform.h:34:7:   required from here
/usr/include/eigen3/Eigen/src/Core/Assign.h:53:57: warning: enum constant in boolean context [-Wint-in-bool-context]
   53 |     MayLinearVectorize = MightVectorize && MayLinearize && DstHasDirectAccess
      |                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~
/usr/include/eigen3/Eigen/src/Core/Assign.h:57:41: warning: enum constant in boolean context [-Wint-in-bool-context]
   57 |     MaySliceVectorize  = MightVectorize && DstHasDirectAccess
      |                          ~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~
make[2]: *** [zones/CMakeFiles/zones.dir/build.make:252: zones/CMakeFiles/zones.dir/ZoneContextMenuInteraction.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1328: zones/CMakeFiles/zones.dir/all] Error 2
make: *** [Makefile:183: all] Error 2

perl-Image-Magick fails with this error:


Code:
chmod 644 "Magick.bs"
"/usr/bin/perl5.32.0" -MExtUtils::Command::MM -e 'cp_nonempty' -- Magick.bs blib/arch/auto/Image/Magick/Magick.bs 644
cc -c  -I/usr/local/include/ImageMagick-6 -DMAGICKCORE_HDRI_ENABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16 -I/usr/include/libxml2 -I"/usr/include/ImageMagick-6" -D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -I/usr/include/freetype2 -g -O2 -Wall -pthread -DMAGICKCORE_HDRI_ENABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16 -O2 -fPIC   -DVERSION=\"6.89\" -DXS_VERSION=\"6.89\" -fPIC "-I/usr/lib64/perl5/CORE"  -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c
Magick.xs:60:10: fatal error: magick/MagickCore.h: No such file or directory
   60 | #include <magick/MagickCore.h>
      |          ^~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [Makefile:348: Magick.o] Error 1
 
Old 07-02-2020, 05:28 AM   #2853
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,515

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lioh View Post
scantailor is not building with the following error:
Code:
/usr/include/eigen3/Eigen/src/Core/Assign.h: In instantiation of 'struct Eigen::internal::assign_traits<Eigen::Matrix<double, 2, 2>, Eigen::Matrix<double, 2, 2> >':
/usr/include/eigen3/Eigen/src/Core/Assign.h:506:64:   required from 'Derived& Eigen::DenseBase<Derived>::lazyAssign(const Eigen::DenseBase<OtherDerived>&) [with OtherDerived = Eigen::Matrix<double, 2, 2>; Derived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:414:30:   required from 'Derived& Eigen::PlainObjectBase<Derived>::lazyAssign(const Eigen::DenseBase<OtherDerived>&) [with OtherDerived = Eigen::Matrix<double, 2, 2>; Derived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/Assign.h:527:123:   required from 'static Derived& Eigen::internal::assign_selector<Derived, OtherDerived, false, false>::run(Derived&, const OtherDerived&) [with Derived = Eigen::Matrix<double, 2, 2>; OtherDerived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/PlainObjectBase.h:653:72:   required from 'Derived& Eigen::PlainObjectBase<Derived>::_set_noalias(const Eigen::DenseBase<OtherDerived>&) [with OtherDerived = Eigen::Matrix<double, 2, 2>; Derived = Eigen::Matrix<double, 2, 2>]'
/usr/include/eigen3/Eigen/src/Core/Matrix.h:303:25:   required from 'Eigen::Matrix<_Scalar, _Rows, _Cols, _Options, _MaxRows, _MaxCols>::Matrix(const Eigen::Matrix<_Scalar, _Rows, _Cols, _Options, _MaxRows, _MaxCols>&) [with _Scalar = double; int _Rows = 2; int _Cols = 2; int _Options = 0; int _MaxRows = 2; int _MaxCols = 2]'
/tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/math/HomographicTransform.h:34:7:   required from here
/usr/include/eigen3/Eigen/src/Core/Assign.h:53:57: warning: enum constant in boolean context [-Wint-in-bool-context]
   53 |     MayLinearVectorize = MightVectorize && MayLinearize && DstHasDirectAccess
      |                          ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~
/usr/include/eigen3/Eigen/src/Core/Assign.h:57:41: warning: enum constant in boolean context [-Wint-in-bool-context]
   57 |     MaySliceVectorize  = MightVectorize && DstHasDirectAccess
      |                          ~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~
make[2]: *** [zones/CMakeFiles/zones.dir/build.make:252: zones/CMakeFiles/zones.dir/ZoneContextMenuInteraction.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:1328: zones/CMakeFiles/zones.dir/all] Error 2
make: *** [Makefile:183: all] Error 2
scantailor is unmaintained upstream since some years and unfortunately is incompatible with the qt5 in current.
Code:
/tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp: In constructor ‘page_split::OptionsWidget::OptionsWidget(const IntrusivePtr<page_split::Settings>&, const IntrusivePtr<ProjectPages>&, const PageSelectionAccessor&)’:
/tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp:49:43: error: invalid use of incomplete type ‘class QButtonGroup’
   49 |  QButtonGroup* grp = new QButtonGroup(this);
      |                                           ^
In file included from /usr/include/qt5/QtWidgets/qpushbutton.h:44,
                 from /usr/include/qt5/QtWidgets/QPushButton:1,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/build/filters/page_split/ui_PageSplitOptionsWidget.h:18,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.h:22,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp:19:
/usr/include/qt5/QtWidgets/qabstractbutton.h:53:7: note: forward declaration of ‘class QButtonGroup’
   53 | class QButtonGroup;
      |       ^~~~~~~~~~~~
/tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp:50:5: error: invalid use of incomplete type ‘class QButtonGroup’
   50 |  grp->addButton(autoBtn);
      |     ^~
In file included from /usr/include/qt5/QtWidgets/qpushbutton.h:44,
                 from /usr/include/qt5/QtWidgets/QPushButton:1,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/build/filters/page_split/ui_PageSplitOptionsWidget.h:18,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.h:22,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp:19:
/usr/include/qt5/QtWidgets/qabstractbutton.h:53:7: note: forward declaration of ‘class QButtonGroup’
   53 | class QButtonGroup;
      |       ^~~~~~~~~~~~
/tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp:51:5: error: invalid use of incomplete type ‘class QButtonGroup’
   51 |  grp->addButton(manualBtn);
      |     ^~
In file included from /usr/include/qt5/QtWidgets/qpushbutton.h:44,
                 from /usr/include/qt5/QtWidgets/QPushButton:1,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/build/filters/page_split/ui_PageSplitOptionsWidget.h:18,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.h:22,
                 from /tmp/SBo/scantailor-EXPERIMENTAL_2016_01_13/filters/page_split/OptionsWidget.cpp:19:
/usr/include/qt5/QtWidgets/qabstractbutton.h:53:7: note: forward declaration of ‘class QButtonGroup’
   53 | class QButtonGroup;
Quote:
perl-Image-Magick fails with this error:
Code:
chmod 644 "Magick.bs"
"/usr/bin/perl5.32.0" -MExtUtils::Command::MM -e 'cp_nonempty' -- Magick.bs blib/arch/auto/Image/Magick/Magick.bs 644
cc -c  -I/usr/local/include/ImageMagick-6 -DMAGICKCORE_HDRI_ENABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16 -I/usr/include/libxml2 -I"/usr/include/ImageMagick-6" -D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -I/usr/include/freetype2 -g -O2 -Wall -pthread -DMAGICKCORE_HDRI_ENABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16 -O2 -fPIC   -DVERSION=\"6.89\" -DXS_VERSION=\"6.89\" -fPIC "-I/usr/lib64/perl5/CORE"  -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c
Magick.xs:60:10: fatal error: magick/MagickCore.h: No such file or directory
   60 | #include <magick/MagickCore.h>
      |          ^~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [Makefile:348: Magick.o] Error 1
this is not compatible with imagemagick-7.x and shouldn't be needed by gscan2pdf because the newer imagemagick should ship already its own perl modules.

I'll remove them both from the repository, thanks for the reports!
 
Old 07-03-2020, 08:46 PM   #2854
qunying
Member
 
Registered: Jun 2002
Distribution: Slackware
Posts: 182

Rep: Reputation: 99
bashdb is not building but after upgrade to the latest 5.0-1.1.2 and fixed the document line "README" to "README.md", it is fined.
 
Old 07-04-2020, 02:50 AM   #2855
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,515

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by qunying View Post
bashdb is not building but after upgrade to the latest 5.0-1.1.2 and fixed the document line "README" to "README.md", it is fined.
thanks, pushed!
 
Old 07-05-2020, 03:35 PM   #2856
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,442

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Hi , cmake-extra-modules not build here , i try update to version 5.71 , but no lucky

any idea?

thanks!
 
Old 07-05-2020, 03:41 PM   #2857
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,515

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
Hi , cmake-extra-modules not build here , i try update to version 5.71 , but no lucky

any idea?

thanks!
I'm not able to reproduce, as it seems to build fine here... which error you got?
 
Old 07-05-2020, 03:57 PM   #2858
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,442

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
mm ... i can build with this option , taken from archlinux..

Quote:
-DBUILD_TESTING=OFF \

the last lines , say this,

Quote:
* Qt5Quick, Qt5 Quick library., <http://www.qt.io/>
Required to run tests for the ECMQMLModules module.
 
Old 07-05-2020, 04:00 PM   #2859
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,515

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
the last lines , say this,
I guess you have issues with your qt5 installation as the qt5 libraries named there are shipped with qt5 in Slackware current.
 
Old 07-05-2020, 04:03 PM   #2860
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,442

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Quote:
Originally Posted by ponce View Post
I guess you have issues with your qt5 installation as the qt5 libraries named there are shipped with qt5 in Slackware current.
I reinstalls all qt5 libs , but error is same ever ...i make entirely pastebin


https://pastebin.com/x542RxdV
 
Old 07-05-2020, 04:08 PM   #2861
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,515

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by USUARIONUEVO View Post
I reinstalls all qt5 libs , but error is same ever ...i make entirely pastebin


https://pastebin.com/x542RxdV
there is no error about qt5 in there (it isn't even cited once)...
have you logged out and logged in again after reinstalling qt5?

Last edited by ponce; 07-05-2020 at 04:10 PM.
 
Old 07-05-2020, 04:19 PM   #2862
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,442

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Quote:
Originally Posted by ponce View Post
there is no error about qt5 in there (it isn't even cited once)...
have you logged out and logged in again after reinstalling qt5?
yep , i reloged , no lucky , only disabling tests ...



Quote:
-- Self-check passed, Using /usr/bin/python2 to generate bindings
CMake Error at /usr/lib64/cmake/Qt5Gui/Qt5Gui_QGtk2ThemePlugin.cmake:4 (_populate_Gui_plugin_properties):
_populate_Gui_plugin_properties Macro invoked with incorrect arguments for
macro named: _populate_Gui_plugin_properties
Call Stack (most recent call first):
/usr/lib64/cmake/Qt5Gui/Qt5GuiConfig.cmake:248 (include)
/usr/lib64/cmake/Qt5Quick/Qt5QuickConfig.cmake:111 (find_package)
tests/CMakeLists.txt:212 (find_package)

I test 14.2 box , and builds without touch nothing , -current fails for me , im not sure if some extra SBo package can produce this issue , i go test "clean-system" , and i try to build.

Last edited by USUARIONUEVO; 07-05-2020 at 04:38 PM.
 
Old 07-05-2020, 04:44 PM   #2863
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,442

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Hi again , in a clean system , extra cmake modules builds fine ...

I continue investigating for curiosity , but can ignore for now.

Thanks and sorry.
 
Old 07-05-2020, 05:33 PM   #2864
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,442

Rep: Reputation: 454Reputation: 454Reputation: 454Reputation: 454Reputation: 454
Sorry for this , i found my culprit

Quote:
qt5-styleplugins
Its strange how an extra module for qt5 can make others scripts fails to build

extra-cmake-modules and wireshark , fails for this qt5 plugin ..

I rebuild qt5-styleplugins , and now all builds fine , i comment cause probably others can pick up this problem.
 
Old 07-06-2020, 10:28 AM   #2865
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,018

Rep: Reputation: 52
MPV and JWM

MPV error: Unable to locate docutils in the SlackBuilds.org tree.

JWM: no /etc/jwm/sytem.jwmrc exists, no way to copy the global file into /home and configure the window manager.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration