LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-16-2020, 05:35 AM   #2716
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,591

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by aherrys View Post
Hi I try to compile calibre with the below error

my slackware is current 64 and it already has the PyQt5-5.13.2 from the installation iso. So I did not install PyQt5-5.13.2 package from the slackbuilds, eventhough it compiled successfully. I noticed that the PyQt5 from the slackbuilds is compiled for python 2.7

While PyQt5 package that comes with the iso current build was compiled with python 3.8


That's why I do not want to replace the package that comes with the iso with the one I compile from slackbuilds for fearing breaking other dependencies.
you probably have installed an older PyQt5, because the one presently in current, PyQt5-5.13.2-x86_64-2 (updated april 25th), contains also the python-2.x modules.

there's no PyQt5 in this repository because everything is already provided by Slackware: if you don't find a package here that is present on SBo usually there should be a good reason, check the git interface linked in the first post to read the relative commit message.

Last edited by ponce; 05-16-2020 at 05:42 AM.
 
Old 05-16-2020, 07:00 AM   #2717
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,790

Rep: Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370Reputation: 1370
NetworkManager-openvpn has been added in -current.
 
Old 05-16-2020, 07:02 AM   #2718
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,591

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by montagdude View Post
NetworkManager-openvpn has been added in -current.
http://cgit.ponce.cc/slackbuilds/com...anager-openvpn ;-)
 
Old 05-16-2020, 08:04 AM   #2719
bakura_666
LQ Newbie
 
Registered: May 2017
Distribution: Slackware64 14.2
Posts: 10

Rep: Reputation: Disabled
Hello,

mgba does not build correctly because in the SlackBuild script, CONTRIBUTING.md file is typed as "ONTRIBUTING.md" and cannot be copy into the tarball. Can you check that? Thanks!
 
Old 05-16-2020, 08:18 AM   #2720
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,591

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bakura_666 View Post
Hello,

mgba does not build correctly because in the SlackBuild script, CONTRIBUTING.md file is typed as "ONTRIBUTING.md" and cannot be copy into the tarball. Can you check that? Thanks!
Hi bakura_666, thanks for the report, but as you can read in the first post of the topic, this is a current-specific one: please report build failures not related to current, like this one, to the respective SlackBuilds maintainers (the ones that should correct the SlackBuild in these cases, their adress are in the *.info files) and (not "or", sorry if I stress it), if you feel like, to the slackbuilds-users mailing list too.

Last edited by ponce; 05-16-2020 at 08:36 AM.
 
Old 05-16-2020, 09:18 AM   #2721
bakura_666
LQ Newbie
 
Registered: May 2017
Distribution: Slackware64 14.2
Posts: 10

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
Hi bakura_666, thanks for the report, but as you can read in the first post of the topic, this is a current-specific one: please report build failures not related to current, like this one, to the respective SlackBuilds maintainers (the ones that should correct the SlackBuild in these cases, their adress are in the *.info files) and (not "or", sorry if I stress it), if you feel like, to the slackbuilds-users mailing list too.
Thanks Ponce, it is my fault, I though the SlackBuild was changed in current (I run slackware64-current by now), but the same typo error is on 14.2 SlackBuild script too, I will report there. Thanks again and excuse me!
 
Old 05-16-2020, 02:10 PM   #2722
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 546

Rep: Reputation: 262Reputation: 262Reputation: 262
Hi,

Building ocp fails on -current:

Code:
ls -I. -DHAVE_CONFIG_H -I.././ timidity-git/utils/strtab.c -o timidity-git/utils/strtab.o -c -DNO_CURSES
gcc -O2 -fPIC -fPIC -Wall -Itimidity-git/interface -Itimidity-git/libarc -Itimidity-git/libunimod -Itimidity-git/timidity -Itimidity-git/utils -I. -DHAVE_CONFIG_H -I.././ timidity-git/utils/timer.c -o timidity-git/utils/timer.o -c -DNO_CURSES
gcc -O2 -fPIC -fPIC -Wall -Itimidity-git/interface -Itimidity-git/libarc -Itimidity-git/libunimod -Itimidity-git/timidity -Itimidity-git/utils -I. -DHAVE_CONFIG_H -I.././ -shared -o playtimidity.so timiditypchan.o timidityplay.o timiditypplay.o timiditypdots.o ocp-output.o timidity-git/interface/wrdt_dumb.o timidity-git/libarc/arc.o timidity-git/libarc/arc_mime.o timidity-git/libarc/arc_lzh.o timidity-git/libarc/arc_tar.o timidity-git/libarc/arc_zip.o timidity-git/libarc/deflate.o timidity-git/libarc/explode.o timidity-git/libarc/inflate.o timidity-git/libarc/unlzh.o timidity-git/libarc/url.o timidity-git/libarc/url_b64decode.o timidity-git/libarc/url_cache.o timidity-git/libarc/url_dir.o timidity-git/libarc/url_file.o timidity-git/libarc/url_hqxdecode.o timidity-git/libarc/url_inflate.o timidity-git/libarc/url_mem.o timidity-git/libarc/url_pipe.o timidity-git/libarc/url_qsdecode.o timidity-git/libarc/url_uudecode.o timidity-git/timidity/aq.o timidity-git/timidity/audio_cnv.o timidity-git/timidity/common.o timidity-git/timidity/effect.o timidity-git/timidity/filter.o timidity-git/timidity/freq.o timidity-git/timidity/instrum.o timidity-git/timidity/loadtab.o timidity-git/timidity/mfi.o timidity-git/timidity/miditrace.o timidity-git/timidity/mix.o timidity-git/timidity/mt19937ar.o timidity-git/timidity/optcode.o timidity-git/timidity/quantity.o timidity-git/timidity/rcp.o timidity-git/timidity/readmidi.o timidity-git/timidity/recache.o timidity-git/timidity/resample.o timidity-git/timidity/reverb.o timidity-git/timidity/sbkconv.o timidity-git/timidity/sffile.o timidity-git/timidity/sfitem.o timidity-git/timidity/smfconv.o timidity-git/timidity/smplfile.o timidity-git/timidity/sndfont.o timidity-git/timidity/tables.o timidity-git/timidity/timidity.o timidity-git/timidity/version.o timidity-git/timidity/wrd_read.o timidity-git/timidity/wrdt.o timidity-git/utils/mblock.o timidity-git/utils/fft4g.o timidity-git/utils/memb.o timidity-git/utils/nkflib.o timidity-git/utils/strtab.o timidity-git/utils/timer.o -lm
/usr/bin/ld: timidity-git/timidity/timidity.o:(.bss+0x140): multiple definition of `got_a_configuration'; timidityplay.o:(.bss+0x8c4): first defined here
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:185: playtimidity.so] Error 1
make[1]: Leaving directory '/tmp/SBo/ocp-0.2.1/playgmi'
make: *** [Makefile:155: dirs] Error 2
Looks like it has TiMidity++ as a dependence. Tried rebuilding it but to no avail.
 
Old 05-16-2020, 04:35 PM   #2723
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,591

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by sombragris View Post
Hi,

Building ocp fails on -current:

Code:
ls -I. -DHAVE_CONFIG_H -I.././ timidity-git/utils/strtab.c -o timidity-git/utils/strtab.o -c -DNO_CURSES
gcc -O2 -fPIC -fPIC -Wall -Itimidity-git/interface -Itimidity-git/libarc -Itimidity-git/libunimod -Itimidity-git/timidity -Itimidity-git/utils -I. -DHAVE_CONFIG_H -I.././ timidity-git/utils/timer.c -o timidity-git/utils/timer.o -c -DNO_CURSES
gcc -O2 -fPIC -fPIC -Wall -Itimidity-git/interface -Itimidity-git/libarc -Itimidity-git/libunimod -Itimidity-git/timidity -Itimidity-git/utils -I. -DHAVE_CONFIG_H -I.././ -shared -o playtimidity.so timiditypchan.o timidityplay.o timiditypplay.o timiditypdots.o ocp-output.o timidity-git/interface/wrdt_dumb.o timidity-git/libarc/arc.o timidity-git/libarc/arc_mime.o timidity-git/libarc/arc_lzh.o timidity-git/libarc/arc_tar.o timidity-git/libarc/arc_zip.o timidity-git/libarc/deflate.o timidity-git/libarc/explode.o timidity-git/libarc/inflate.o timidity-git/libarc/unlzh.o timidity-git/libarc/url.o timidity-git/libarc/url_b64decode.o timidity-git/libarc/url_cache.o timidity-git/libarc/url_dir.o timidity-git/libarc/url_file.o timidity-git/libarc/url_hqxdecode.o timidity-git/libarc/url_inflate.o timidity-git/libarc/url_mem.o timidity-git/libarc/url_pipe.o timidity-git/libarc/url_qsdecode.o timidity-git/libarc/url_uudecode.o timidity-git/timidity/aq.o timidity-git/timidity/audio_cnv.o timidity-git/timidity/common.o timidity-git/timidity/effect.o timidity-git/timidity/filter.o timidity-git/timidity/freq.o timidity-git/timidity/instrum.o timidity-git/timidity/loadtab.o timidity-git/timidity/mfi.o timidity-git/timidity/miditrace.o timidity-git/timidity/mix.o timidity-git/timidity/mt19937ar.o timidity-git/timidity/optcode.o timidity-git/timidity/quantity.o timidity-git/timidity/rcp.o timidity-git/timidity/readmidi.o timidity-git/timidity/recache.o timidity-git/timidity/resample.o timidity-git/timidity/reverb.o timidity-git/timidity/sbkconv.o timidity-git/timidity/sffile.o timidity-git/timidity/sfitem.o timidity-git/timidity/smfconv.o timidity-git/timidity/smplfile.o timidity-git/timidity/sndfont.o timidity-git/timidity/tables.o timidity-git/timidity/timidity.o timidity-git/timidity/version.o timidity-git/timidity/wrd_read.o timidity-git/timidity/wrdt.o timidity-git/utils/mblock.o timidity-git/utils/fft4g.o timidity-git/utils/memb.o timidity-git/utils/nkflib.o timidity-git/utils/strtab.o timidity-git/utils/timer.o -lm
/usr/bin/ld: timidity-git/timidity/timidity.o:(.bss+0x140): multiple definition of `got_a_configuration'; timidityplay.o:(.bss+0x8c4): first defined here
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:185: playtimidity.so] Error 1
make[1]: Leaving directory '/tmp/SBo/ocp-0.2.1/playgmi'
make: *** [Makefile:155: dirs] Error 2
Looks like it has TiMidity++ as a dependence. Tried rebuilding it but to no avail.
it seems to build fine here, with or without TiMidity++...

could it be you forgot to say that you are using gcc-10.x from /testing?
in that case modify the SlackBuild like this
Code:
--- ./ocp.SlackBuild.orig       2020-05-16 23:11:16.254538000 +0200
+++ ./ocp.SlackBuild    2020-05-16 23:31:18.989538000 +0200
@@ -69,7 +69,7 @@
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -fcommon" \
 ./configure \
   --prefix=/usr \
   --libdir=/usr/lib${LIBDIRSUFFIX} \
I started to push some patches to the repository for gcc-10.x but I will stop until it will get out of /testing and into the distribution, so please don't report other building issues in this topic if you have it installed.

Last edited by ponce; 05-16-2020 at 04:39 PM.
 
1 members found this post helpful.
Old 05-16-2020, 08:12 PM   #2724
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 546

Rep: Reputation: 262Reputation: 262Reputation: 262
Quote:
Originally Posted by ponce View Post
it seems to build fine here, with or without TiMidity++...

could it be you forgot to say that you are using gcc-10.x from /testing?
in that case modify the SlackBuild like this
Code:
--- ./ocp.SlackBuild.orig       2020-05-16 23:11:16.254538000 +0200
+++ ./ocp.SlackBuild    2020-05-16 23:31:18.989538000 +0200
@@ -69,7 +69,7 @@
  \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
   -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
 
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -fcommon" \
 ./configure \
   --prefix=/usr \
   --libdir=/usr/lib${LIBDIRSUFFIX} \
I started to push some patches to the repository for gcc-10.x but I will stop until it will get out of /testing and into the distribution, so please don't report other building issues in this topic if you have it installed.
Indeed; since I have PAM enabled I have testing as a priority in slackpkg and of course it picked gcc-10. Thanks for the patch and sorry for the noise.
 
Old 05-17-2020, 05:00 PM   #2725
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 505

Rep: Reputation: 271Reputation: 271Reputation: 271
Could we get an update to glade, pretty please? Putting this here rather than contacting the glade SlackBuild maintainer, because ponce's is ahead of SBo-master already anyway.

Code:
--- glade.info	2020-05-17 17:43:05.317938838 -0400
+++ glade.info.sbopkg	2020-05-17 17:51:25.520919757 -0400
@@ -1,8 +1,8 @@
 PRGNAM="glade"
-VERSION="3.22.1"
+VERSION="3.22.2"
 HOMEPAGE="https://glade.gnome.org"
-DOWNLOAD="https://ftp.gnome.org/pub/GNOME/sources/glade/3.22/glade-3.22.1.tar.xz"
-MD5SUM="226802cf3b06861240524805aa6fe6ff"
+DOWNLOAD="https://ftp.gnome.org/pub/GNOME/sources/glade/3.22/glade-3.22.2.tar.xz"
+MD5SUM="c074fa378c8f1ad80d20133c4ae6f42d"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
 REQUIRES=""
--- glade.SlackBuild	2020-05-17 17:43:05.317938838 -0400
+++ glade.SlackBuild.sbopkg	2020-05-17 17:49:49.940923403 -0400
@@ -23,7 +23,7 @@
 #  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 
 PRGNAM=glade
-VERSION=${VERSION:-3.22.1}
+VERSION=${VERSION:-3.22.2}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}
md5sum verified against sha256sum on GNOME ftp server.
 
Old 05-17-2020, 08:02 PM   #2726
ehartman
Senior Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 1,674

Rep: Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884Reputation: 884
Quote:
Originally Posted by Poprocks View Post
Could we get an update to glade, pretty please? Putting this here rather than contacting the glade SlackBuild maintainer, because ponce's is ahead of SBo-master already anyway.
You do know there seems to be a (maybe experimental) 3.36 version out there too?
See http://ftp.gnome.org/pub/GNOME/sources/glade/3.36/
 
Old 05-17-2020, 09:44 PM   #2727
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 505

Rep: Reputation: 271Reputation: 271Reputation: 271
Quote:
Originally Posted by ehartman View Post
You do know there seems to be a (maybe experimental) 3.36 version out there too?
See http://ftp.gnome.org/pub/GNOME/sources/glade/3.36/
Yes I did see this. I had assumed based on the huge version bump that it was a development version for the forthcoming gtk4, but reading the NEWS file that may not be the case. It's surprisingly difficult to find out this information online, and their website doesn't seem to be actively maintained any longer. I'll look into it.
 
Old 05-18-2020, 02:44 AM   #2728
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 505

Rep: Reputation: 271Reputation: 271Reputation: 271
The upstream maintainer told me 3.36.0 is the current stable version - they just bumped it to match the current GNOME release version number (although glade is not part of the GNOME release cycle).

I had no issues building and running 3.36 on current so I'll submit it as a pull request on GitHub. That's probably a better place to submit anyway since this is technically offtopic for this thread.
 
Old 05-18-2020, 10:45 AM   #2729
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,591

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Poprocks View Post
The upstream maintainer told me 3.36.0 is the current stable version - they just bumped it to match the current GNOME release version number (although glade is not part of the GNOME release cycle).

I had no issues building and running 3.36 on current so I'll submit it as a pull request on GitHub. That's probably a better place to submit anyway since this is technically offtopic for this thread.
remember to check if anything needing glade in the repository (gtksourceview3, ...) keeps building/working fine with the newer version...
 
1 members found this post helpful.
Old 05-19-2020, 03:53 AM   #2730
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 659

Rep: Reputation: 170Reputation: 170
Not so much building, but running: since the pam inclusion of yesterday:
Code:
bash-5.0$ /etc/rc.d/rc.clamav start
Starting clamd daemon:  /usr/sbin/clamd chown: changing ownership of '/var/run/clamav/': Operation not permitted
chmod: changing permissions of '/var/run/clamav/': Operation not permitted
LibClamAV Warning: Detected duplicate databases /var/lib/clamav/main.cvd and /var/lib/clamav/main.cld, please manually remove one of them
One of the first lines of /etc/rc.d/rc.clamav start is a chown...

freshclam works

EDIT: latest clamav-0.102.3
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration