LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-14-2020, 01:57 PM   #2386
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,843

Rep: Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416Reputation: 1416

Quote:
Originally Posted by qunying View Post
SimGear download URL is broken, could not download from
ftp://slackware.uk/sbosrcarch/by-md5...1.2-rc.tar.bz2
The official download at
https://sourceforge.net/projects/fli...1.2-rc.tar.bz2
works.

For compilation, I have to comment out the `cd build` and `cd ..` lines and use the top directory as build directory, otherwise I would get config.h not found error.
Interesting, I just built it on a different non-Slackware machine and had the same problem. I got around it by setting the CPATH environment variable rather than building in the source directory. This makes me think there must be something different about the sourceforge.net and sbosrcarch files.

Edit: but as ponce said, probably not a problem unique to -current.
 
Old 01-14-2020, 04:28 PM   #2387
edps
LQ Newbie
 
Registered: Aug 2019
Posts: 9

Rep: Reputation: 0
Quote:
Originally Posted by ponce View Post
thanks Edinaldo for the libass tip!

regarding removing the dependencies added to Slackware from the *.info files maybe you missed it but unfortunately, as a general policy, I avoid to do it for all the scripts because it would create a gazillion of additional branches that will be very painful to rebase every week.
Ok, thanks for your hard work (and quality too).
 
Old 01-15-2020, 06:50 PM   #2388
qunying
Member
 
Registered: Jun 2002
Distribution: Slackware
Posts: 194

Rep: Reputation: 107Reputation: 107
gnome-vfs could not compile due to incompatibility with OpenSSL 1.1.x.
After using the patch at https://bugs.gentoo.org/592540, it compiles fine.
 
Old 01-16-2020, 12:45 AM   #2389
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,846

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by qunying View Post
gnome-vfs could not compile due to incompatibility with OpenSSL 1.1.x.
After using the patch at https://bugs.gentoo.org/592540, it compiles fine.
I had forced it to use openssl-1.0.x one year and an half ago but this is for sure a better option, thanks a lot!
 
Old 01-16-2020, 10:08 PM   #2390
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 -current
Posts: 923

Rep: Reputation: 628Reputation: 628Reputation: 628Reputation: 628Reputation: 628Reputation: 628
The recent guile 3.0 upgrade breaks gnucash 3.8. Apparently compilation requires guile 2.0 or 2.2. Can 2.x and 3.0 be installed concurrently?

Last edited by drgibbon; 01-18-2020 at 01:35 PM. Reason: version 3.8, not 2.8!
 
1 members found this post helpful.
Old 01-17-2020, 05:03 AM   #2391
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,846

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by drgibbon View Post
The recent guile 3.0 upgrade breaks gnucash 2.8. Apparently compilation requires guile 2.0 or 2.2. Can 2.x and 3.0 be installed concurrently?
can you please check if this works (it should)?

http://ponce.cc/slackware/testing/guile2.2/
 
1 members found this post helpful.
Old 01-17-2020, 09:06 AM   #2392
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current
Posts: 244
Blog Entries: 1

Rep: Reputation: Disabled
Cinelerra CV revisited

The link at https://slackbuilds.org/repository/1...dia/cinelerra/ for Cinelerra CV is "https://cinelerra-cv.org/." It is "https" that times out. When you use "http://cinelerra-cv.org/" as listed in https://github.com/ratopi/CinelerraCV, it is a redirect to https://www.cinelerra-gg.org/. Hence my confusion of CV, GG, and http://heroinewarrior.com/.

When you `git clone git://git.cinelerra-gg.org/goodguy/cinelerra.git cinelerra5`, cd cinelerra5/cinelerra-5.1/blds, you will find cin.SlackBuild. Running that script as root generates /tmp/cin-<date>-x86_64-1_cin.txz ready for installpkg. Any prerequisites that are not found already installed are built with the included source tarballs.
 
2 members found this post helpful.
Old 01-18-2020, 12:33 PM   #2393
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 -current
Posts: 923

Rep: Reputation: 628Reputation: 628Reputation: 628Reputation: 628Reputation: 628Reputation: 628
Quote:
Originally Posted by ponce View Post
can you please check if this works (it should)?

http://ponce.cc/slackware/testing/guile2.2/
gnucash 3.8 compiles with this installed, thanks!
 
Old 01-21-2020, 04:42 PM   #2394
Dan Suson
Member
 
Registered: Aug 2007
Location: Valparaiso, IN
Distribution: Slackware
Posts: 55

Rep: Reputation: 2
librecad2.2.0rc1 doesn't build

I am trying to build librecad2.2.0rc1 under Slackware64-current using Ponce's slackbuild scripts. I have already successfully built and installed qt5 and muParser, which are listed as required packages. When I tried to build librecad, I got the error shown in the attachment. Suggestions?

Dan
Attached Files
File Type: txt librecad_error.txt (31.2 KB, 3 views)
 
Old 01-21-2020, 05:21 PM   #2395
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,846

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Dan Suson View Post
I am trying to build librecad2.2.0rc1 under Slackware64-current using Ponce's slackbuild scripts. I have already successfully built and installed qt5 and muParser, which are listed as required packages. When I tried to build librecad, I got the error shown in the attachment. Suggestions?

Dan
you should apply a patch from fedora

http://cgit.ponce.cc/slackbuilds/commit/?h=librecad

thanks for reporting it!
 
Old 01-23-2020, 06:21 PM   #2396
Skaendo
Senior Member
 
Registered: Dec 2014
Location: West Texas, USA
Distribution: Slackware64-14.2
Posts: 1,335

Rep: Reputation: Disabled
After the latest Slackware64-current updates, and using Ponce's SlackBuilds, I am having problems with gst-plugins-bad and aegisub.

Full logs are here:
aegisub - https://pastebin.com/0MJbX0qt
gst-plugins-bad - https://pastebin.com/X0s78eKK

Edit2: It seems that Ponce's gst-plugins-bad needs to be updated to 1.16.2, but fails the same.

Edit3: I uploaded single threaded logs instead of slackrepo logs.

Last edited by Skaendo; 01-23-2020 at 08:04 PM.
 
Old 01-24-2020, 07:03 AM   #2397
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,846

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Skaendo View Post
After the latest Slackware64-current updates, and using Ponce's SlackBuilds, I am having problems with gst-plugins-bad and aegisub.

Full logs are here:
aegisub - https://pastebin.com/0MJbX0qt
regarding this you better ask the aegisub maintainer: maybe the solution could be to not use the bundled luajit but the SBo one, but trying to do that I found a gentoo patch that requires a git snapshot of aegisub...
https://gitweb.gentoo.org/repo/gento...it-build.patch
https://github.com/Aegisub/Aegisub

Quote:
gst-plugins-bad - https://pastebin.com/X0s78eKK

Edit2: It seems that Ponce's gst-plugins-bad needs to be updated to 1.16.2, but fails the same.
it seems that there are problems in the headers generated by glib-mkenums (a generated line starts with a backslash) and build breaks at the start, but I wasn't able to find a solution yet...
 
1 members found this post helpful.
Old 01-24-2020, 09:32 AM   #2398
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 4,261

Rep: Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494
i will take a look on aegisub
 
1 members found this post helpful.
Old 01-24-2020, 01:38 PM   #2399
Nille_kungen
Member
 
Registered: Jul 2005
Distribution: Slackware64-current
Posts: 556

Rep: Reputation: 190Reputation: 190
I had problems building cryptography.
It needs wheel as dependency on current.
Cryptography also needs version 2.8 to build with python 3.8
https://cryptography.io/en/latest/changelog/#v2-8
 
Old 01-24-2020, 02:20 PM   #2400
unInstance
Member
 
Registered: Jan 2020
Distribution: Slackware/FreeBSD
Posts: 73

Rep: Reputation: Disabled
How to build openresolv:
Open openresolv.SlackBuild and remove
Code:
cp README $PKG/usr/doc/$PRGNAM-$VERSION
How to build neomutt:
Open neomutt.SlackBuild in vim and apply the following command
Code:
:%s/PRGNAM/PKGNAM/g

Last edited by unInstance; 01-24-2020 at 02:25 PM.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration