LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-13-2019, 11:56 AM   #1846
brobr
Member
 
Registered: Oct 2003
Location: uk
Distribution: Slackware
Posts: 552

Rep: Reputation: 148Reputation: 148

Quote:
Originally Posted by brobr View Post
Recent upgrade to Swig-4.0.0 is not without pain...

..

Since the upgrade in Slackware64-current to swig-4 (and gcc-9.1), compilation of ViennaRNA still works but the creation of the python-3 module halts and breaks the process (https://github.com/ViennaRNA/ViennaRNA/issues/54)
Upstream provided a patch that works both for swig-3 and swig-4 (see link above); this is incorporated in the SlackBuild script just submitted to SBo.
 
Old 05-18-2019, 08:56 AM   #1847
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,599

Rep: Reputation: Disabled
Please force clang/clang++ for RetroArch on current, a new feature introduced in 1.7.7 was completely broken during run time by gcc9.

This can be done by adding these two lines somewhere between "set -eu" and "./configure".

Code:
export CC=clang
export CXX=clang++
Relevant RetroArch issue: https://github.com/libretro/RetroArch/issues/8716
 
Old 05-18-2019, 09:31 AM   #1848
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,757

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by orbea View Post
Please force clang/clang++ for RetroArch on current, a new feature introduced in 1.7.7 was completely broken during run time by gcc9.

This can be done by adding these two lines somewhere between "set -eu" and "./configure".

Code:
export CC=clang
export CXX=clang++
Relevant RetroArch issue: https://github.com/libretro/RetroArch/issues/8716
just pushed in a dedicated branch, will go in the main one at the next update.
 
2 members found this post helpful.
Old 05-23-2019, 05:09 AM   #1849
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 119

Rep: Reputation: 83
[SOLVED]

After today's -current upgrades (probably glib2-2.60.3 or maybe perl-5.30.0) I get the error message
Code:
Glib.c: loadable library and perl binaries are mismatched (got handshake key 0xce00080, needed 0xcd00080)
when trying to run applications dependent on various perl packages.
Trying to rebuild perl-glib ends with
Code:
Test Summary Report
-------------------
t/g.t                    (Wstat: 768 Tests: 33 Failed: 3)
  Failed tests:  18, 22, 24
  Non-zero exit status: 3
Files=33, Tests=1189,  5 wallclock secs ( 0.19 usr  0.03 sys +  2.08 cusr  0.23 csys =  2.53 CPU)
Result: FAIL
Failed 1/33 test programs. 3/1189 subtests failed.
make: *** [Makefile:1382: test_dynamic] Error 255
The same error occurs with both the official SBo script and Ponce's buildscript and patch for -current dated 20190518.

EDIT: after a fresh download of Ponce's buildscript including patch, it worked! Don't know why it didn't build the first time. Thanks a lot for the patch!

Last edited by kgha; 05-23-2019 at 05:35 AM.
 
Old 05-23-2019, 05:29 AM   #1850
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,757

Original Poster
Rep: Reputation: Disabled
I've just tried to build its dependencies, perl-extutils-pkgconfig and perl-extutils-depends, and then perl-glib from scratch on a clean system updated at today using this repository and everything went fine.
consider that, as it happens often with perl, with version 5.30 binary compatibility is broken, so you should rebuild every perl module not already included in Slackware that you have on your system (like Pat has done in current with this update).

Last edited by ponce; 05-23-2019 at 05:39 AM.
 
1 members found this post helpful.
Old 05-23-2019, 05:52 AM   #1851
kgha
Member
 
Registered: May 2018
Location: Sweden
Distribution: Slackware 64 -current multilib from AlienBob's LiveSlak MATE
Posts: 119

Rep: Reputation: 83
Thanks Matteo. I know from experience that perl packages can be a nuisance. After succeeding with perl-glib, I got stuck again on perl-pango...
I'll make a try uninstalling all old perl SBo packages and then try rebuilding them in prescribed order.
 
Old 05-23-2019, 11:58 AM   #1852
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 450

Rep: Reputation: 146Reputation: 146
I think this is just to report, the vhba module (needed by cdemu)
doesn't build with 4.19.4x kernel (I didn't try with the new 4.19.45).

I couldn't find anything related searching with Google about it.

It builds OK with the 5.0.x, the kernel I'm running.

Worth to report to the maintainer?
 
Old 05-23-2019, 01:16 PM   #1853
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,757

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Paulo2 View Post
I think this is just to report, the vhba module (needed by cdemu)
doesn't build with 4.19.4x kernel (I didn't try with the new 4.19.45).

I couldn't find anything related searching with Google about it.

It builds OK with the 5.0.x, the kernel I'm running.

Worth to report to the maintainer?
I just pushed a change in this repository that should be enough, disabling -Werror: will go in the main branch at the next update.

thanks for reporting!
 
Old 05-23-2019, 02:55 PM   #1854
Paulo2
Member
 
Registered: Aug 2012
Distribution: Slackware64 -current (started with 13.37(32))
Posts: 450

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by ponce View Post
I just pushed a change in this repository that should be enough, disabling -Werror: will go in the main branch at the next update.

thanks for reporting!
Thanks ponce.

Disabling -Werror in the Makefile?
I edited vhba-module.SlackBuild and it builds OK now with kernel 4.19.45, cdemu works OK now.
Code:
sed -i '8 s/-Werror/ /' Makefile

make KERNELRELEASE=$KERNEL
 
Old Yesterday, 05:34 PM   #1855
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,140

Rep: Reputation: 349Reputation: 349Reputation: 349Reputation: 349
Only for curiosity , i see SBo up qt5 version last week , to 5.9.8 , but you remains under 5.9.6 umbrella.

5.9.8 not build under current ?
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration