LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-24-2019, 04:06 PM   #1741
chris.willing
Member
 
Registered: Jun 2014
Location: Brisbane, Australia
Distribution: Slackware,LFS
Posts: 546

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330

Quote:
Originally Posted by stormtracknole View Post
vlc-3.0.6 from SBo does not compile. Getting this error:
Code:
access/sftp.c: In function ‘Open’:
access/sftp.c:310:14: error: ‘LIBSSH2_HOSTKEY_TYPE_ECDSA_256’ undeclared (first use in this function); did you mean ‘LIBSSH2_HOSTKEY_TYPE_DSS’?
         case LIBSSH2_HOSTKEY_TYPE_ECDSA_256:
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
              LIBSSH2_HOSTKEY_TYPE_DSS
access/sftp.c:310:14: note: each undeclared identifier is reported only once for each function it appears in
access/sftp.c:311:42: error: ‘LIBSSH2_KNOWNHOST_KEY_ECDSA_256’ undeclared (first use in this function); did you mean ‘LIBSSH2_KNOWNHOST_KEY_RSA1’?
             knownhost_fingerprint_algo = LIBSSH2_KNOWNHOST_KEY_ECDSA_256;
                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                          LIBSSH2_KNOWNHOST_KEY_RSA1
access/sftp.c:314:14: error: ‘LIBSSH2_HOSTKEY_TYPE_ECDSA_384’ undeclared (first use in this function); did you mean ‘LIBSSH2_HOSTKEY_TYPE_DSS’?
         case LIBSSH2_HOSTKEY_TYPE_ECDSA_384:
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
              LIBSSH2_HOSTKEY_TYPE_DSS
access/sftp.c:315:42: error: ‘LIBSSH2_KNOWNHOST_KEY_ECDSA_384’ undeclared (first use in this function); did you mean ‘LIBSSH2_KNOWNHOST_KEY_RSA1’?
             knownhost_fingerprint_algo = LIBSSH2_KNOWNHOST_KEY_ECDSA_384;
                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                          LIBSSH2_KNOWNHOST_KEY_RSA1
access/sftp.c:318:14: error: ‘LIBSSH2_HOSTKEY_TYPE_ECDSA_521’ undeclared (first use in this function); did you mean ‘LIBSSH2_HOSTKEY_TYPE_DSS’?
         case LIBSSH2_HOSTKEY_TYPE_ECDSA_521:
              ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
              LIBSSH2_HOSTKEY_TYPE_DSS
access/sftp.c:319:42: error: ‘LIBSSH2_KNOWNHOST_KEY_ECDSA_521’ undeclared (first use in this function); did you mean ‘LIBSSH2_KNOWNHOST_KEY_RSA1’?
             knownhost_fingerprint_algo = LIBSSH2_KNOWNHOST_KEY_ECDSA_521;
                                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                          LIBSSH2_KNOWNHOST_KEY_RSA1
make[4]: *** [Makefile:22925: access/libsftp_plugin_la-sftp.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
Adding:
Code:
--disable-sftp \
to the SlackBuild got it to build.
There's already a patch to fix this in next SBo update. See: https://git.slackbuilds.org/slackbui...1d427cb8bdca80

chris
 
1 members found this post helpful.
Old 03-24-2019, 04:19 PM   #1742
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,120

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by chris.willing View Post
There's already a patch to fix this in next SBo update. See: https://git.slackbuilds.org/slackbui...1d427cb8bdca80

chris
I figured there would be one already. Thanks!!!
 
Old 03-25-2019, 03:33 AM   #1743
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,708

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by stormtracknole View Post
Without the patch, it builds fine. However, start the application and notice that none of the menu options on the top and on the side show up. If that doesn't happen to you, let me know.
with that version menus are blank here too, but I also tested the latest version patched by Chris: it builds fine and menus seems to show.

Last edited by ponce; 03-25-2019 at 03:35 AM.
 
Old 03-25-2019, 11:42 AM   #1744
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,120

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by ponce View Post
with that version menus are blank here too, but I also tested the latest version patched by Chris: it builds fine and menus seems to show.
Well...shoot. I don't know then. I tried it from another machine (even a virtual one) and I still run into the same problem. Did you build one of the extra libraries for numpy3 by any chance? If you are getting it to show, then I wonder what I'm missing on my end.
 
Old 03-25-2019, 11:42 AM   #1745
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,120

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by chris.willing View Post
There's already a patch to fix this in next SBo update. See: https://git.slackbuilds.org/slackbui...1d427cb8bdca80

chris
It seems that the latest vlc doesn't want to play nice with vpx?
 
Old 03-25-2019, 11:49 AM   #1746
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,708

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by stormtracknole View Post
It seems that the latest vlc doesn't want to play nice with vpx?
the vlc script in this repository is patched with an added "--disable-vpx" as 3.0.6 is still not compatible with the new libvpx in current.
Quote:
Originally Posted by stormtracknole View Post
Did you build one of the extra libraries for numpy3 by any chance?
no, I built Blender and all the mandatory dependencies only, no optional ones for any of the scripts.
 
Old 03-25-2019, 12:32 PM   #1747
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,120

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by ponce View Post
the vlc script in this repository is patched with an added "--disable-vpx" as 3.0.6 is still not compatible with the new libvpx in current.

no, I built Blender and all the mandatory dependencies only, no optional ones for any of the scripts.
I noticed that from your repo. Good catch.

I'm building the other package for now (the one that doesn't require the dependencies). Not really sure if building from source would make any difference.
 
Old 03-25-2019, 01:27 PM   #1748
mickski56
LQ Newbie
 
Registered: Mar 2018
Posts: 17

Rep: Reputation: Disabled
On the blender issue. I rebuilt it on 14.2 for python-3.7 with the updated patch from chris, and got the no menus thing. The cause for me was a python directory under /usr/share/blender/2.79 removing this directory and rebuilding solved the issue. I'm not sure where the /usr/share/blender/2.79/python directory came from as it was not removed by upgradepkg. hth
 
1 members found this post helpful.
Old 03-25-2019, 04:58 PM   #1749
chris.willing
Member
 
Registered: Jun 2014
Location: Brisbane, Australia
Distribution: Slackware,LFS
Posts: 546

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Quote:
Originally Posted by mickski56 View Post
On the blender issue. I rebuilt it on 14.2 for python-3.7 with the updated patch from chris, and got the no menus thing. The cause for me was a python directory under /usr/share/blender/2.79 removing this directory and rebuilding solved the issue. I'm not sure where the /usr/share/blender/2.79/python directory came from as it was not removed by upgradepkg. hth
As well as the "missing menus" patch in the updated SlackBuild, I also took the opportunity to no longer include blender's own python installation, which is really just a (partial?) copy of the system python available at build time (we now just use the system python). As you suggest, the extra blender python should have been removed by upragepkg so I'm surprised it was still there - glad you figured out the problem.

chris
 
1 members found this post helpful.
Old 03-25-2019, 06:35 PM   #1750
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,120

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by chris.willing View Post
As well as the "missing menus" patch in the updated SlackBuild, I also took the opportunity to no longer include blender's own python installation, which is really just a (partial?) copy of the system python available at build time (we now just use the system python). As you suggest, the extra blender python should have been removed by upragepkg so I'm surprised it was still there - glad you figured out the problem.

chris
For the life of me, I can't get this going. The build fails when the python patch is enabled. I have include my full log in pastebin to see if anything sticks out. I have tried this on a laptop, a server and a virtual machine with the same result. Here's the link.
 
Old 03-26-2019, 01:21 AM   #1751
chris.willing
Member
 
Registered: Jun 2014
Location: Brisbane, Australia
Distribution: Slackware,LFS
Posts: 546

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
Quote:
Originally Posted by stormtracknole View Post
For the life of me, I can't get this going. The build fails when the python patch is enabled. I have include my full log in pastebin to see if anything sticks out. I have tried this on a laptop, a server and a virtual machine with the same result. Here's the link.
Based on your pastebin, have a look at http://blender.45788.x6.nabble.com/n...-td178338.html where a patch is linked which may fix your problem. I say "may" because the patch title mentions "clang" yet I don't see LLVM mentioned in your configuration. It's probably worth a shot though ...

chris
 
1 members found this post helpful.
Old 03-26-2019, 06:52 AM   #1752
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,120

Rep: Reputation: 158Reputation: 158
Quote:
Originally Posted by chris.willing View Post
Based on your pastebin, have a look at http://blender.45788.x6.nabble.com/n...-td178338.html where a patch is linked which may fix your problem. I say "may" because the patch title mentions "clang" yet I don't see LLVM mentioned in your configuration. It's probably worth a shot though ...

chris
Okay, that didn't fix the error. However, I went back and looked at all the patches Fedora was implementing. I went ahead and loaded all of those (including your python patch) and that finally got it to build correctly and show the menus. Not sure which patch did the trick. This is how my patch section looks:

Code:
patch -p0 < $CWD/buildinfo-$VERSION.diff
patch -p1 < $CWD/use-libopenmj2-for-openjpeg.diff
patch -p1 < $CWD/PyRNA-python3.7.diff
patch -p1 < $CWD/blender-2.79-droid.patch
patch -p1 < $CWD/blender-2.79-thumbnailer.patch
patch -p1 < $CWD/blender-2.79-scripts.patch
patch -p1 < $CWD/blender-2.79-locale.patch
patch -p1 < $CWD/blender-2.79-manpages.patch
patch -p1 < $CWD/blender-2.79-unversioned-system-path.patch
patch -p1 < $CWD/blender-2.79-openvdb3-abi.patch
patch -p1 < $CWD/util_sseb.patch
patch -p1 < $CWD/tree_hpp.patch
I'll go ahead and update the other thread. Thank you and mickski56 so much for looking into this.
 
Old 04-11-2019, 10:55 AM   #1753
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,368

Rep: Reputation: Disabled
@ponce

Last week I added a patch so that dwm-6.2 will build in 14.2. The patch allows it to use the fontconfig in 14.2 by undoing references to LC_COLOR in the latest dwm git commit.

This patch isn't necesary with -current and it should build without it (tested last week).
 
Old 04-11-2019, 11:03 AM   #1754
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,708

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by dive View Post
@ponce

Last week I added a patch so that dwm-6.2 will build in 14.2. The patch allows it to use the fontconfig in 14.2 by undoing references to LC_COLOR in the latest dwm git commit.

This patch isn't necesary with -current and it should build without it (tested last week).
I'll remove it from the repo, thanks for notifying!
 
Old 04-11-2019, 09:55 PM   #1755
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,546

Rep: Reputation: Disabled
It seems perl-net-http no longer builds.

Code:
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Net::HTTP
Writing MYMETA.yml and MYMETA.json
cp lib/Net/HTTP/Methods.pm blib/lib/Net/HTTP/Methods.pm
cp lib/Net/HTTP.pm blib/lib/Net/HTTP.pm
cp lib/Net/HTTPS.pm blib/lib/Net/HTTPS.pm
cp lib/Net/HTTP/NB.pm blib/lib/Net/HTTP/NB.pm
Manifying 3 pod documents
PERL_DL_NONLAZY=1 "/usr/bin/perl5.28.1" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/apache-https.t .. skipped: Live tests disabled; pass --live-tests to Makefile.PL to enable
t/apache.t ........ skipped: Live tests disabled; pass --live-tests to Makefile.PL to enable
t/http-nb.t ....... 
Failed 11/14 subtests 
t/http.t .......... ok

Test Summary Report
-------------------
t/http-nb.t     (Wstat: 13 Tests: 3 Failed: 0)
  Non-zero wait status: 13
  Parse errors: Bad plan.  You planned 14 tests but ran 3.
Files=4, Tests=40,  1 wallclock secs ( 0.03 usr  0.01 sys +  0.13 cusr  0.03 csys =  0.20 CPU)
Result: FAIL
Failed 1/4 test programs. 0/40 subtests failed.
make: *** [Makefile:888: test_dynamic] Error 255
It seems the build script hasn't been touched since 2015 and upstream is now on 6.18 where SBo has 6.09 so I tried the newer version which also failed...

Code:
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Net::HTTP
Writing MYMETA.yml and MYMETA.json
cp lib/Net/HTTP/NB.pm blib/lib/Net/HTTP/NB.pm
cp lib/Net/HTTP/Methods.pm blib/lib/Net/HTTP/Methods.pm
cp lib/Net/HTTPS.pm blib/lib/Net/HTTPS.pm
cp lib/Net/HTTP.pm blib/lib/Net/HTTP.pm
Manifying 4 pod documents
PERL_DL_NONLAZY=1 "/usr/bin/perl5.28.1" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-report-prereqs.t .. # 
# Versions for all modules listed in MYMETA.json (including optional ones):
# 
# === Configure Requires ===
# 
#     Module              Want Have
#     ------------------- ---- ----
#     ExtUtils::MakeMaker  any 7.34
# 
# === Configure Suggests ===
# 
#     Module      Want    Have
#     -------- ------- -------
#     JSON::PP 2.27300 2.97001
# 
# === Build Requires ===
# 
#     Module              Want Have
#     ------------------- ---- ----
#     ExtUtils::MakeMaker  any 7.34
# 
# === Test Requires ===
# 
#     Module              Want     Have
#     ------------------- ---- --------
#     Data::Dumper         any    2.170
#     ExtUtils::MakeMaker  any     7.34
#     File::Spec           any     3.74
#     IO::Select           any     1.39
#     Socket               any    2.027
#     Test::More           any 1.302133
# 
# === Test Recommends ===
# 
#     Module         Want     Have
#     ---------- -------- --------
#     CPAN::Meta 2.120900 2.150010
# 
# === Runtime Requires ===
# 
#     Module                 Want  Have
#     ---------------------- ---- -----
#     Carp                    any  1.50
#     Compress::Raw::Zlib     any 2.076
#     IO::Socket::INET        any  1.39
#     IO::Uncompress::Gunzip  any 2.074
#     URI                     any  1.74
#     base                    any  2.27
#     strict                  any  1.11
#     vars                    any  1.04
#     warnings                any  1.42
# 
# === Runtime Suggests ===
# 
#     Module             Want    Have
#     ----------------- ----- -------
#     IO::Socket          any    1.39
#     IO::Socket::INET6   any missing
#     IO::Socket::IP      any    0.39
#     IO::Socket::SSL   2.012   2.066
#     Symbol              any    1.08
# 
t/00-report-prereqs.t .. ok   
t/http-nb.t ............ Failed 11/14 subtests 
t/http.t ............... ok     
t/live-https.t ......... skipped: Can't connect to www.cpan.org:443
t/live.t ............... skipped: Can't connect to www.neverssl.com

Test Summary Report
-------------------
t/http-nb.t          (Wstat: 13 Tests: 3 Failed: 0)
  Non-zero wait status: 13
  Parse errors: Bad plan.  You planned 14 tests but ran 3.
Files=5, Tests=41,  0 wallclock secs ( 0.03 usr  0.01 sys +  0.39 cusr  0.07 csys =  0.50 CPU)
Result: FAIL
Failed 1/5 test programs. 0/41 subtests failed.
make: *** [Makefile:892: test_dynamic] Error 255
I'm not very familiar with perl so I haven't taken this farther.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration