LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-01-2019, 03:08 PM   #1711
luvr
Member
 
Registered: May 2005
Location: Boom - The Home Town of Tomorrowland, Belgium
Distribution: Slackware, Debian, Xubuntu
Posts: 245
Blog Entries: 1

Rep: Reputation: 90

Quote:
Originally Posted by AlleyTrotter View Post
Why do we need Oracle Java installed to build openjdk java?
I think the process of building openjdk relies on the Java support that used to be built in to the GNU Compiler Collection, gcc, but that support is no longer available.
 
Old 03-01-2019, 04:18 PM   #1712
USUARIONUEVO
Senior Member
 
Registered: Apr 2015
Posts: 1,107

Rep: Reputation: 329Reputation: 329Reputation: 329Reputation: 329
this was added today to current

Quote:
python-ply
we need remove from SBo

Quote:
ply
thanks!
 
Old 03-03-2019, 01:27 PM   #1713
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 450

Rep: Reputation: 268Reputation: 268Reputation: 268
Is qt5 meant to build on -current? I get build failures with 5.9.7 (from official SBo for 14.2), and also with 5.9.6 from ponce's repo.
 
Old 03-03-2019, 01:28 PM   #1714
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,694

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by drgibbon View Post
Is qt5 meant to build on -current? I get build failures with 5.9.7 (from official SBo for 14.2), and also with 5.9.6 from ponce's repo.
the version that's in this repository should build fine, I last built it a few days ago...
 
Old 03-04-2019, 01:17 AM   #1715
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,694

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
Quote:
Originally Posted by drgibbon View Post
Is qt5 meant to build on -current? I get build failures with 5.9.7 (from official SBo for 14.2), and also with 5.9.6 from ponce's repo.
the version that's in this repository should build fine, I last built it a few days ago...
I spoke too soon, seems gcc > 8.2.0 broke it... but I found a fix

https://translate.google.com/transla...i%3Fid%3D35928 (comment #9)

http://git.altlinux.org/gears/q/qt5-...c162159c8905fe

just add this sed before the configure block in the SlackBuild
Code:
# https://bugzilla.altlinux.org/show_bug.cgi?id=35928
sed -i 's|^asm volatile ($|asm (|' qtscript/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp || exit 1
thanks for reporting it!

Last edited by ponce; 03-04-2019 at 01:09 PM.
 
Old 03-05-2019, 03:07 AM   #1716
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,694

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
Quote:
Originally Posted by ponce View Post
Quote:
Originally Posted by drgibbon View Post
Is qt5 meant to build on -current? I get build failures with 5.9.7 (from official SBo for 14.2), and also with 5.9.6 from ponce's repo.
the version that's in this repository should build fine, I last built it a few days ago...
I spoke too soon, seems gcc > 8.2.0 broke it... but I found a fix

https://translate.google.com/transla...i%3Fid%3D35928 (comment #9)

http://git.altlinux.org/gears/q/qt5-...c162159c8905fe

just add this sed before the configure block in the SlackBuild
Code:
# https://bugzilla.altlinux.org/show_bug.cgi?id=35928
sed -i 's|^asm volatile ($|asm (|' qtscript/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp || exit 1
thanks for reporting it!
well, I stand corrected again: after today's current update qt5 builds fine again without the above fix
Code:
Tue Mar  5 00:17:16 UTC 2019
d/gcc-8.3.0-x86_64-2.txz:  Rebuilt.
  Reverted backported asm inline patches that broke "asm volatile".
  Thanks to nobodino.
 
Old 03-06-2019, 02:30 PM   #1717
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 450

Rep: Reputation: 268Reputation: 268Reputation: 268
Ah ok, it was the new gcc. How about xsel?
Code:
if gcc -DHAVE_CONFIG_H -I. -I. -I.     -O2 -fPIC -fno-strict-aliasing -Wall -Werror -g -std=gnu99 -Wdeclaration-after-statement -Wno-unused -MT xsel.o -MD -MP -MF ".deps/xsel.Tpo" -c -o xsel.o xsel.c; \
then mv -f ".deps/xsel.Tpo" ".deps/xsel.Po"; else rm -f ".deps/xsel.Tpo"; exit 1; fi
xsel.c: In function ‘main’:
xsel.c:1986:7: error: ‘strncpy’ specified bound 1024 equals destination size [-Werror=stringop-truncation]
       strncpy (logfile, argv[i], MAXFNAME);
       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[1]: *** [Makefile:266: xsel.o] Error 1
make[1]: Leaving directory '/tmp/SBo/xsel-1.2.0'
make: *** [Makefile:176: all] Error 2
Failures:
  xsel: xsel.SlackBuild return non-zero
 
Old 03-06-2019, 02:45 PM   #1718
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,543

Rep: Reputation: Disabled
Turn off -Werror...
 
Old 03-06-2019, 03:08 PM   #1719
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,694

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by drgibbon View Post
Ah ok, it was the new gcc. How about xsel?
Code:
if gcc -DHAVE_CONFIG_H -I. -I. -I.     -O2 -fPIC -fno-strict-aliasing -Wall -Werror -g -std=gnu99 -Wdeclaration-after-statement -Wno-unused -MT xsel.o -MD -MP -MF ".deps/xsel.Tpo" -c -o xsel.o xsel.c; \
then mv -f ".deps/xsel.Tpo" ".deps/xsel.Po"; else rm -f ".deps/xsel.Tpo"; exit 1; fi
xsel.c: In function ‘main’:
xsel.c:1986:7: error: ‘strncpy’ specified bound 1024 equals destination size [-Werror=stringop-truncation]
       strncpy (logfile, argv[i], MAXFNAME);
       ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cc1: all warnings being treated as errors
make[1]: *** [Makefile:266: xsel.o] Error 1
make[1]: Leaving directory '/tmp/SBo/xsel-1.2.0'
make: *** [Makefile:176: all] Error 2
Failures:
  xsel: xsel.SlackBuild return non-zero
still the new gcc, modify the SlackBuild like this
Code:
--- ./xsel.SlackBuild.orig      2019-03-03 20:33:47.393398000 +0100
+++ ./xsel.SlackBuild   2019-03-06 22:07:06.498398000 +0100
@@ -54,7 +54,7 @@
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  -exec chmod 644 {} \;
 
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -Wno-error=stringop-truncation" \
 CXXFLAGS="$SLKCFLAGS" \
 ./configure \
   --prefix=/usr \
 
Old 03-06-2019, 04:37 PM   #1720
drgibbon
Member
 
Registered: Nov 2014
Distribution: Slackware64 14.2
Posts: 450

Rep: Reputation: 268Reputation: 268Reputation: 268
Got it, thanks!
 
Old 03-07-2019, 11:04 PM   #1721
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 958

Rep: Reputation: 223Reputation: 223Reputation: 223
The gimp-plugin-bimp version 1.18 builds ok on -current but I believe there are more than a few issues with this plugin running with GIMP 2.10 (-current version of GIMP).

I did not test this incompatibility but a simple version bump to BIMP 2.0 works nicely under -current and would be nice if this small version bump appeared in Ponce's repository. Details:
  1. BIMP version 2.0
  2. Bug report that discusses failure of BIMP 1.18 with newer GIMP versions...
 
Old 03-08-2019, 02:02 AM   #1722
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,694

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by andrew.46 View Post
The gimp-plugin-bimp version 1.18 builds ok on -current but I believe there are more than a few issues with this plugin running with GIMP 2.10 (-current version of GIMP).

I did not test this incompatibility but a simple version bump to BIMP 2.0 works nicely under -current and would be nice if this small version bump appeared in Ponce's repository. Details:
  1. BIMP version 2.0
  2. Bug report that discusses failure of BIMP 1.18 with newer GIMP versions...
Thanks, pushed!
 
Old 03-08-2019, 11:59 AM   #1723
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 556

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by willysr View Post
latest version 1.59.x has this issue fixed as well
gojbect-introspection 1.59.x still not on current, or am I missing something? Because I still have this problem.
Code:
ImportError: /usr/lib/gobject-introspection/giscanner/_giscanner.so: wrong ELF class: ELFCLASS32

Last edited by Bindestreck; 03-08-2019 at 01:08 PM.
 
Old 03-08-2019, 03:14 PM   #1724
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,694

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Bindestreck View Post
gojbect-introspection 1.59.x still not on current, or am I missing something? Because I still have this problem.
Code:
ImportError: /usr/lib/gobject-introspection/giscanner/_giscanner.so: wrong ELF class: ELFCLASS32
that looks like a multilib issue.
 
Old 03-08-2019, 03:45 PM   #1725
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 556

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by ponce View Post
that looks like a multilib issue.
It is a bug in gobject-introspection: https://gitlab.gnome.org/GNOME/gobje...ion/issues/220

I temporarily solved it by changing some line in /usr/bin/g-ir-scanner:

Code:
pylibdir = os.path.abspath(os.path.join(filedir, '..', 'lib', 'gobject-introspection'))
to

Code:
pylibdir = os.path.abspath(os.path.join(filedir, '..', '@libdir_relative@', 'gobject-introspection'))
This is however fixed in newer version of gobject-introspection.
 
1 members found this post helpful.
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 05:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 01:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 01:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 07:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration