LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-06-2019, 09:21 AM   #1651
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,610

Original Poster
Rep: Reputation: Disabled

Quote:
Originally Posted by Poprocks View Post
re: simple-scan

Project has relocated to gitlab, and a newer stable version is available. That version does build on my machine. Following patches to .SlackBuild and .info get it to build:

Code:
--- simple-scan.SlackBuild	2019-01-28 14:59:55.975807283 -0500
+++ simple-scan.SlackBuild.sbopkg	2019-02-01 21:40:16.619857650 -0500
@@ -26,7 +26,7 @@
 # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 
 PRGNAM="simple-scan"
-VERSION=${VERSION:-3.25.1}
+VERSION=${VERSION:-3.30.1.1}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}
 
--- simple-scan.info	2019-01-28 14:59:55.975807283 -0500
+++ simple-scan.info.sbopkg	2019-02-01 21:39:55.699858448 -0500
@@ -1,8 +1,8 @@
 PRGNAM="simple-scan"
-VERSION="3.25.1"
+VERSION="3.30.1.1"
 HOMEPAGE="https://launchpad.net/simple-scan"
-DOWNLOAD="https://launchpad.net/simple-scan/3.25/3.25.1/+download/simple-scan-3.25.1.tar.xz"
-MD5SUM="6bff2b9bdfb529e21582f4a65c3f2d27"
+DOWNLOAD="https://gitlab.gnome.org/GNOME/simple-scan/-/archive/3.30.1.1/simple-scan-3.30.1.1.tar.bz2"
+MD5SUM="0f4da95ee93ee2eb5421af16100190c9"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
 REQUIRES="colord packagekit meson libgusb vala"
thanks for this (and sorry for the late reply), I just pushed it!
 
Old 02-08-2019, 12:44 AM   #1652
linuxtinker
Member
 
Registered: Dec 2013
Location: NJ / USA
Distribution: Slackware 64 -Current
Posts: 203

Rep: Reputation: 92
Quote:
Originally Posted by ponce View Post

EDIT: I've tested it and it seems not to build anymore with qt-4.x, it needs qt5 (probably because of a bug upstream): report this to the maintainer.



Sent an email.
Thanks for reply
 
Old 02-09-2019, 12:26 PM   #1653
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 7,910

Rep: Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606
libgksu still not building ...

I am trying to get this installed and googling find this,
source:
https://www.linuxquestions.org/quest...04#post5487904
link within source ponce patched added to slackbuild,
https://git.slackbuilds.org/slackbui...ad20a8c768e6ec

them changes are in the slackbuild, but it is now telling me
Code:
touch scan-build.stamp
*** Rebuilding template files ***
cd . && gtkdoc-mktmpl --module=libgksu
/bin/sh: gtkdoc-mktmpl: command not found
cannot find a slackbuild for that, what is the main package to get this one?

or what to do?
 
Old 02-09-2019, 01:03 PM   #1654
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,930

Rep: Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185
It was caused by changes in gtk-doc (NEWS):
Quote:
GTK-Doc 1.26 (Aug 11 2017)
============

Remove tmpl support (gtkdoc-mktmpl)
Solution: Add this parameter:
Code:
--disable-gtk-doc \

Last edited by willysr; 02-09-2019 at 01:06 PM.
 
2 members found this post helpful.
Old 02-09-2019, 02:47 PM   #1655
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,610

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by willysr View Post
Solution: Add this parameter:
Code:
--disable-gtk-doc \
thanks willysr, pushed!
 
Old 02-09-2019, 03:47 PM   #1656
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 7,910

Rep: Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606
Agree, thanks, willysr, ponce! gksu working now...
 
Old 02-09-2019, 06:49 PM   #1657
BradReed
Member
 
Registered: Apr 2015
Location: Earth
Distribution: Slackware-current
Posts: 68

Rep: Reputation: 26
Issue building sigil 0.9.10

EDIT *** DISREGARD...I missed the hyphen dependency. OOPS

Perhaps this is caused by mixing -alien qt5 with -SBo other dependencies, but I was unable to build the sigil 0.9.10 package from SBo on -current.

I already had qt5-5.11.3-x86_64-1alien and qt5-webkit-5.212.0_alpha2-x86_64-2alien installed.
I successfully built and installed the following dependencies from SBo
python-webencodings-0.5.1-x86_64
html5lib-1.0.1-x86_64
BeautifulSoup4-4.6.1-x86_64
lxml-4.2.5-x86_64

Then tried to build Sigil
Sigil built fine, but then failed to link:

[100%] Building CXX object src/CMakeFiles/sigil.dir/sigil_autogen/mocs_compilation.cpp.o
(much snippage...)
[100%] Linking CXX executable ../bin/sigil
(much snippage...)
/usr/bin/ld: warning: libhyphen.so.0, needed by /usr/lib64/libQt5WebKit.so.5.212.0, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/lib64/libQt5WebKit.so.5.212.0: undefined reference to `hnj_hyphen_hyphenate2'
/usr/bin/ld: /usr/lib64/libQt5WebKit.so.5.212.0: undefined reference to `hnj_hyphen_load'
/usr/bin/ld: /usr/lib64/libQt5WebKit.so.5.212.0: undefined reference to `hnj_hyphen_free'
collect2: error: ld returned 1 exit status
make[2]: *** [src/CMakeFiles/sigil.dir/build.make:3138: bin/sigil] Error 1
make[2]: Leaving directory '/tmp/SBo/Sigil-0.9.10/build'

Sure enough, there is no libhyphen.so.0 or even libhyphen.so on my system.

Short of rebuilding qt5 and qt5-webkit, is there a way around this?

Thanks

Last edited by BradReed; 02-09-2019 at 07:14 PM.
 
Old 02-10-2019, 12:07 AM   #1658
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,930

Rep: Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185Reputation: 1185
try installing hyphen
 
Old 02-12-2019, 11:37 AM   #1659
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 7,910

Rep: Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606
/usr/bin/ld: warning: libhyphen.so.0, needed by /usr/lib64/libQt5WebKit.so, not found (try using -rpath or -rpath-link)

trying to build notepadqq getting error

Code:
/usr/bin/ld: warning: libhyphen.so.0, needed by /usr/lib64/libQt5WebKit.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /usr/lib64/libQt5WebKit.so: undefined reference to `hnj_hyphen_hyphenate2'
/usr/bin/ld: /usr/lib64/libQt5WebKit.so: undefined reference to `hnj_hyphen_load'
/usr/bin/ld: /usr/lib64/libQt5WebKit.so: undefined reference to `hnj_hyphen_free'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:495: ../../out/release/lib/notepadqq-bin] Error 1
make[1]: Leaving directory '/tmp/SBo/notepadqq-1.2.0/src/ui'
make: *** [Makefile:46: sub-src-ui-make_first] Error 2
No find libhyphen.so.0
Code:
userx@slackdvdcurr.org:~
$ sudo find /usr/lib -type f -iname  "libhyphen*"
userx@slackdvdcurr.org:~
$ sudo find /usr/lib64 -type f -iname  "libhyphen*"
But I do have -- /usr/lib64/libQt5WebKit.so
Code:
userx@slackdvdcurr.org:~
$ ls  /usr/lib64/libQt5WebKit.so
/usr/lib64/libQt5WebKit.so
but as stated it has undefined references...

whos got libhyphen.so.0, and , so what now?

edit:
Ha, I just read the ones above this, they got the same where is libhyphen question....

let me try installing that hyphen thing...

it worked but now I get this

Code:
You are using an old version of Qt (5.11.3)
Notepadqq will try to do its best, but some things will 
not work properly.
Install a newer Qt version (≥ 5.3) from the official 
repositories of your distribution.

If it's not available, download Qt (≥ 5.3) 
from http://qt-project.org/
 and install it to "/home/userx/Qt" or to "/opt/Qt".
But is not 5.11.3 > 5.3???

Last edited by BW-userx; 02-12-2019 at 12:03 PM.
 
Old 02-12-2019, 12:06 PM   #1660
montagdude
Senior Member
 
Registered: Apr 2016
Distribution: Slackware
Posts: 1,385

Rep: Reputation: 1036Reputation: 1036Reputation: 1036Reputation: 1036Reputation: 1036Reputation: 1036Reputation: 1036Reputation: 1036
Quote:
Originally Posted by BW-userx View Post
it worked but now I get this

Code:
You are using an old version of Qt (5.11.3)
Notepadqq will try to do its best, but some things will 
not work properly.
Install a newer Qt version (≥ 5.3) from the official 
repositories of your distribution.

If it's not available, download Qt (≥ 5.3) 
from http://qt-project.org/
 and install it to "/home/userx/Qt" or to "/opt/Qt".
But is not 5.11.3 > 5.3???
Looks like a bug in their code that checks for the Qt version. Does Notepadqq actually work properly despite this?

Edit: Actually, looks like it is already fixed upstream: https://github.com/notepadqq/notepad...12b97f6dfee737

Upgrading to the latest version of Notepadqq, if possible, should fix it.

Last edited by montagdude; 02-12-2019 at 12:11 PM.
 
Old 02-12-2019, 12:22 PM   #1661
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,610

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by BW-userx View Post
it worked but now I get this

Code:
You are using an old version of Qt (5.11.3)
Notepadqq will try to do its best, but some things will 
not work properly.
Install a newer Qt version (≥ 5.3) from the official 
repositories of your distribution.

If it's not available, download Qt (≥ 5.3) 
from http://qt-project.org/
 and install it to "/home/userx/Qt" or to "/opt/Qt".
But is not 5.11.3 > 5.3???
please read the first post of the thread: there's no qt5-5.11.3 on SBo, and the scripts are tested with the version of packages that are in the repository.
if you have issues with your custom installation that mixes multiple repositories open a dedicated topic.

Last edited by ponce; 02-12-2019 at 12:24 PM.
 
Old 02-12-2019, 12:40 PM   #1662
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 7,910

Rep: Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606
Quote:
Originally Posted by ponce View Post
please read the first post of the thread: there's no qt5-5.11.3 on SBo, and the scripts are tested with the version of packages that are in the repository.
if you have issues with your custom installation that mixes multiple repositories open a dedicated topic.
it was a slackbuild off your sight and I just added what it told me after I got it to build properly. Just to point it out.... so if I am running 5.11.3 Qt it is because of the dvd build of current by Alien as far as I know... I do not recall installing it, but as stated I just put what it told me in here because that is what it said....


Code:
/var/log/packages/qt5-5.11.3-x86_64-1alien
/var/log/packages/qt5-webkit-5.212.0_alpha2-x86_64-2alien

Last edited by BW-userx; 02-12-2019 at 01:01 PM.
 
Old 02-12-2019, 03:55 PM   #1663
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,705

Rep: Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479
Quote:
Originally Posted by BW-userx View Post
Code:
/var/log/packages/qt5-5.11.3-x86_64-1alien
/var/log/packages/qt5-webkit-5.212.0_alpha2-x86_64-2alien
This is not from ponce, this is from Alien Bob. ponce's SBo repo for -current would have the tag as SBo, and his personal repo will be ponce.
 
1 members found this post helpful.
Old 02-12-2019, 05:16 PM   #1664
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 7,910

Rep: Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606Reputation: 1606
Quote:
Originally Posted by bassmadrigal View Post
This is not from ponce, this is from Alien Bob. ponce's SBo repo for -current would have the tag as SBo, and his personal repo will be ponce.
yeah that obvious as I stated in my typing something something Alien something something, as stated I was just posting what the program told me after I had a successive build is all, relax...

Last edited by BW-userx; 02-12-2019 at 05:19 PM.
 
Old 02-13-2019, 10:00 AM   #1665
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,705

Rep: Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479Reputation: 3479
Quote:
Originally Posted by BW-userx View Post
yeah that obvious as I stated in my typing something something Alien something something, as stated I was just posting what the program told me after I had a successive build is all, relax...
You stated "it was a slackbuild off your sight [sic]", without formally correcting yourself. Maybe it was lost in the way you type your responses, but it certainly wasn't obvious that you realized they were from different repos based on your post.
 
  


Reply

Tags
current, sbo, sbopkg, slackrepo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM
Pls help me take my 1st step! verysoon Fedora - Installation 2 12-12-2005 08:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration