-   Slackware (
-   -   SBo libreoffice 3.6.4 errors (

tuubaaku 01-26-2013 09:40 PM

SBo libreoffice 3.6.4 errors
I'm trying to use Libreoffice - I installed 3.6.4 from When I run swriter, scalc, or sbase, I get the following errors:

/opt/libreoffice3.6/program/../ure-link/lib/ version `GLIBCXX_3.4.11' not found (required by /usr/lib/
Failed to load module: /usr/lib/gio/modules/

If I run the following two commands in libreoffice3.6/ure/lib, these errors don't show up anymore:
bash-4.2# mv
bash-4.2# ln -s /usr/lib/

I guess that's the correct solution? Should that be incorporated into the slackbuild?

Also, when I run sbase, it crashes immediately after creating a new database - no errors on the command line, just a crash. Any hints or suggestions?

willysr 01-26-2013 11:19 PM

Have you installed glib-networking?
That's the package that contains

tuubaaku 01-27-2013 02:55 PM

$ ls /var/log/packages/ | grep glib-networking

$ ls -l /usr/lib/gio/modules/libg*
-rwxr-xr-x 1 root root 1.1K Aug 9 03:11 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 11K Aug 9 03:11 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 1.2K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 16K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 1.2K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 97K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 1.2K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 9.1K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 1.3K Jul 24 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 67K Jul 24 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 1.3K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 20K Jul 19 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 1.2K Jul 24 2012 /usr/lib/gio/modules/*
-rwxr-xr-x 1 root root 169K Jul 24 2012 /usr/lib/gio/modules/*

willysr 01-27-2013 06:18 PM

have you tried to use AlienBOB's package?

D1ver 01-27-2013 06:37 PM

I had the same problem, which was making the GUI in libreoffice look like crap. I found the same solution you did (namely, renaming All the error messages went away and it seems to work fine now..

tuubaaku 01-27-2013 07:21 PM

Yes, I did try alienBob's package - unfortunately I got an error there as well. I can start trying to troubleshoot that if I have to give up on the SBo package.

D1ver - does sbase work for you with the SBo package? And you are on 14.0, right?

D1ver 01-27-2013 07:32 PM

Yep 14.0 64-bit. Installed libreoffice using sbopkg.

Sbase seems to work. I can create a db and enter a few tables without anything crashing. I've never really used this program before so I didn't go much further.

Note I didn't create a symlink in /opt/libreoffice3.6/ure/lib, just renamed

willysr 01-27-2013 07:40 PM

I used alienBOB's package and it worked fine on all of my machines

tuubaaku 01-27-2013 07:55 PM

hmm, I'm on SL 32-bit. Doesn't seem to make a difference whether I create the link to /usr/lib or not - either way sbase just dies with no error when I try to create or open a database.

mlangdn 01-27-2013 08:58 PM

Start it from the command line:


Then when it crashes, you may see exactly what the error is.

tuubaaku 01-27-2013 09:39 PM

Thanks - I've actually been running it from the CLI, and it doesn't show anything when it crashes, unfortunately. It'd be great if there were some option to make it more verbose...

mlangdn 01-27-2013 09:55 PM

See if something here can help you:

tuubaaku 01-28-2013 09:30 PM

I tried alien's package again, and the error happened again. This time I realized that it was pointing to something in my local config directory, though, so I deleted that directory. Then I was able to open lobase, and things are looking OK so far.

Thanks for all the responses. Still not sure what was going on with the SBo package, but it looks like I may be OK with the alien package.

All times are GMT -5. The time now is 06:43 PM.