LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-04-2018, 03:49 AM   #1
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 532

Rep: Reputation: 55
SBo libfilezilla not building on 14.2


I've just in the process of upgrading my system with the latest packages from slackbuilds. I got a problem with compiling libfilezilla-0.15.0, the latest version on SlackBuilds.org

This is the error

Quote:
libtool: compile: g++ -DHAVE_CONFIG_H -I. -I../lib/libfilezilla/private -DBUILDING_LIBFILEZILLA -I./libfilezilla -fvisibility=hidden -O2 -fPIC -Wall -g -std=gnu++14 -MT libfilezilla_la-encryption.lo -MD -MP -MF .deps/libfilezilla_la-encryption.Tpo -c encryption.cpp -fPIC -DPIC -o .libs/libfilezilla_la-encryption.o
encryption.cpp:13:27: fatal error: nettle/memops.h: No such file or directory
compilation terminated.
make[1]: *** [libfilezilla_la-encryption.lo] Error 1
Makefile:604: recipe for target 'libfilezilla_la-encryption.lo' failed

On my Slackware-14.2 system I have two nettle packages namely -

Quote:
nettle-3.2-x86_64-1
nettle-compat32-3.2-x86_64-1compat32
neither of which contain memops.h

On my Slackware-Current system I have two nettle packages namely -

Quote:
nettle-3.4-x86_64-2
nettle-compat32-3.4-x86_64-2compat32
of which only nettle-3.4-x86_64-2 contains memops.h, i.e. it's not available in alienBob's Slackware-Current 32 bit package

I might not be reading the above information correctly, but it looks to me that the most recent libfilezilla requires memops.h which is only available in a recent 64bit package of nettle.

Maybe libfilezilla has got a bit ahead of itself and is now no longer compatible with Slackware-14.2 and Slackware-14.2 should stick with libfilezilla-0.14.0

Any suggestions on how I should proceed?

Alex
 
Old 11-04-2018, 04:06 AM   #2
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2
Posts: 84

Rep: Reputation: 13
Am having the same "problem" here as well...
Having multilib etc as OP

Edit:
Tried to build libfilezilla on another laptop running 14.2, without multilib as well. Same problem...

Last edited by MDKDIO; 11-04-2018 at 04:17 AM.
 
Old 11-04-2018, 04:35 AM   #3
55020
Senior Member
 
Registered: Sep 2009
Location: Yorks. W.R. 167397
Distribution: Slackware
Posts: 1,296
Blog Entries: 4

Rep: Reputation: Disabled
https://lists.slackbuilds.org/piperm...er/022336.html
 
2 members found this post helpful.
Old 11-04-2018, 04:44 AM   #4
MDKDIO
Member
 
Registered: Mar 2004
Location: Sweden
Distribution: Slackware 14.2
Posts: 84

Rep: Reputation: 13
Quote:
Originally Posted by 55020 View Post
Thanks for the link/info

Guess we'll see a fix soon then...
 
Old 11-04-2018, 06:35 AM   #5
aikempshall
Member
 
Registered: Nov 2003
Location: Bristol, Britain
Distribution: Slackware
Posts: 532

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by 55020 View Post
Thanks for the link. As suggested I will stay with filezilla-3.37.4 and libfilezilla-0.14 on my Slackware 14.2 machine.
 
Old 11-05-2018, 08:25 AM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,848

Rep: Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118Reputation: 1118
yeah, i will revert back to the previous version for now.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SBo scripts not building on current (read 1st post, pls) ponce Slackware 1517 Yesterday 08:22 AM
[SOLVED] SBo qbittorrent 3.3.12 cannot complete building BW-userx Slackware 6 04-27-2017 02:21 PM
[SOLVED] Error building gst1-plugins-good 1.4.1 from SBO l0rddarkf0rce Slackware 4 10-06-2014 06:58 PM
[SOLVED] Failure building nvidia-kernel Slackbuild from SBo sysfce2 Slackware 7 07-02-2011 02:10 AM
problems building fontforge from SBo gtludwig Slackware 7 05-12-2010 02:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration