-   Slackware (
-   -   Sat Mar 23 updates: nano segfault error 6 in when writing the file (

burdi01 03-24-2013 12:15 PM

Sat Mar 23 updates: nano segfault error 6 in when writing the file
Current 64-bit: nano segfaults after writing the file:
File Name to Write: /mnt/etc/fstabSegmentation fault
root@riposo:~/works# -D DOS Format M-A Append M-B Backup File
root@riposo:~/works# tail /var/log/messages Prepend
Mar 24 18:00:32 riposo kernel: nano[1181]: segfault at 0 ip 00007f8b1865fee4 sp 00007fff99787e10 error 6 in[7f8b1865c000+1a000]
Mar 24 18:01:36 riposo kernel: nano[1199]: segfault at 0 ip 00007fd413293ee4 sp 00007fff75422370 error 6 in[7fd413290000+1a000]

fskmh 03-24-2013 12:45 PM

deleted post

chrisretusn 03-25-2013 03:24 AM

I have the same problem across two Slackware64-current and one Slackware-current installations. Saving an edited file (^X or ^O) results in the segmentation fault as indicated in the first post. This only happens editing an existing file. Creating a new file and saving it does not result in a segmentation fault.

I have reverted back to nano 2.2.6 which works. (sourced from nano stable)

GazL 03-25-2013 05:44 AM

Confirmed here too on 64-current.

It sounds very much like the symptoms described in this 2 year old open bug,

However, I tried applying the patch provided by the submitter and it still SEGVs so it's not a solution.

burdi01 03-25-2013 07:41 AM

Nano 2.2.6 is too old for my liking ...
Current's nano is 2.3.2.
I tried nano 2.3.1 from Slackware 14.0 : same problem.
The file is saved ok however!
Libmagic is from the file package.
Current's file version is 5.13.
I replaced /usr/lib64/libmagic.{la,so.1.0.0} by those from Slackware 14.0's file 5.11 : problem gone for ^X, ^O displays garbage (but saves the file ok).

Edit: Replacing /usr/lib64/libmagic.{la,so.1.0.0} did not resolve the problem after all. But downgrading the complete file package to 5.11 (as hinted to by allend below) did.

allend 03-25-2013 09:32 AM

Just to confirm that this problem goes away for me if I downgrade to file-5.11-x86_64-1.txz from Slackware64-14.0

[edit] The same problem occurs in 32 bit Slackware where the downgrade also works. [/edit]

chrisretusn 03-26-2013 01:59 AM

Problem solved. The March 25th update reverted file 5.13 to 5.11 and all is well again. Thanks Pat.

allend 03-28-2013 11:17 AM

I have been playing with this on my 64bit Slackware-current (well almost, have yet to upgrade to kernel 3.8.4) and have found that I can use nano 2.3.2 with file-5.14 without the segmentation fault if the file package is built to use the default compiled magic.mgc file.

I needed to comment out the following lines in file.SlackBuild to build file-5.14

#zcat $CWD/file.quiet.diff.gz | patch -p1 -E --verbose || exit 1
#rm -f $PKG/etc/file/magic.mgc
#mkdir -p $PKG/etc/file/magic
#cp -a magic/Magdir/* $PKG/etc/file/magic

Looking at the comments in file.SlackBuild it seems that Slackware has provided flat text files for the magic as an aid to administrators.
Does anybody actually add magic entries? Would Slackware users accept a 2.6M compiled magic file in place of the smaller flat files setup?

willysr 03-28-2013 01:15 PM

2.6M is not that big for nowadays system IMHO :)

All times are GMT -5. The time now is 05:34 PM.