LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-19-2004, 02:41 PM   #1
DexterF
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Rep: Reputation: 0
samba: special character (umlaute) garbled


Two machines, Slackware 9.1, all ready to go, local special characters are ok most of the time, but:
Samba screws up.
With 2.2.8a it was like: touch file called "m" and it turns into "m:200d:200d" on the client.
/me is confused.
Upgraded to 3.0.1.
ls gives "m", and I cheer and joy and frolic.
not for long: as soon as I try to open/read/write/play/delete/rename the file, the system claims it wasn't there at all:
"stat call: no such file or directory" (shoddy translation from german)

umm?
 
Old 01-20-2004, 02:06 AM   #2
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
Is the umlaute character allowed in a file name in older windows versions, this would need unicode.
 
Old 01-20-2004, 06:48 AM   #3
dirstyGuy
Member
 
Registered: Jan 2004
Posts: 67

Rep: Reputation: 15
Read the man mount or smbmount, there is a special section for nfs, must be also one section for samba/smb.

I remember to have read somewhere that the option could solve the character problem, "iocharset=utf8". Below is wut I put into my /etc/fstab.

/dev/hda1 /mnt/nt1 ntfs owner,noexec,nodev,nosuid,noauto,ro,iocharset=utf8 1 8
 
Old 01-20-2004, 08:16 AM   #4
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
the options for fstab you are looking for are:
iocharset=iso8859-1,codepage=cp850
like:
Code:
//<server>/<share> /mnt/<share> smbfs username=<user>,password=<pass>,workgroup=<workgroup>,iocharset=iso8859-1,codepage=cp850,rw,auto 0 0
iocharset is the charset you have on your local machine and codepage is the charset used on the server......it's almost guaranteed CP850 if you mention german umlauts ^^
another thing I've noticed is that this options gets regognized only if you check the option "Use a default NLS" in you kernel config ->
File systems ---> Network File Systems --->
<*> SMB file system support (to mount Windows shares etc.)[*] Use a default NLS
Default Remote NLS Option: "cp850"

regards =)

Last edited by poison; 01-20-2004 at 08:26 AM.
 
Old 01-20-2004, 08:59 AM   #5
DexterF
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
That's just like my setup. Had some settings wrong in Samba, now I've got the old situation again:

I touch a file from client, umlaute are ok on client but not on server.
I touch a file from server, umlaute are ok on server but not on client.

Duh.

(btw, fast and good response here. thanks.)
 
Old 01-20-2004, 09:37 AM   #6
poison
Member
 
Registered: Dec 2003
Location: Layer 7 =D
Distribution: Slackware, LFS, Rock Linux
Posts: 165

Rep: Reputation: 30
is you're SMB server linux or windows ?
if you're touch'ing you're probably running linux ?
well...then you probably can't use 2 different charsets for server<->client...^^

Last edited by poison; 01-20-2004 at 09:47 AM.
 
Old 01-21-2004, 02:43 PM   #7
DexterF
LQ Newbie
 
Registered: Jan 2004
Posts: 4

Original Poster
Rep: Reputation: 0
yes, server is Slackware.
Thing is - *locally* everything is alright, it's only samba shares.
Is there a way to tell which coding is currently used on this and that filesystem if no mount option is given?
 
Old 02-13-2004, 04:49 PM   #8
mathen
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Hello,

simple add

character set = iso8859-1
client code page = cp850

to your server smb.conf


Best Regards,

Mathias
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
block special and character special files s_shenbaga Linux - Newbie 4 06-23-2015 02:16 AM
How do I insert special character with alt? Meriadoc Linux - Newbie 5 05-17-2006 10:42 AM
German umlaute (special chars) in file system steltner Linux - General 5 10-27-2003 02:07 PM
special character boolim Linux - General 1 08-29-2003 09:57 AM
i need help with a special character Hone101 Linux - Newbie 1 05-03-2003 07:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration