LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   samba: special character (umlaute) garbled (https://www.linuxquestions.org/questions/slackware-14/samba-special-character-umlaute-garbled-136433/)

DexterF 01-19-2004 02:41 PM

samba: special character (umlaute) garbled
 
Two machines, Slackware 9.1, all ready to go, local special characters are ok most of the time, but:
Samba screws up.
With 2.2.8a it was like: touch file called "möö" and it turns into "m:200d:200d" on the client.
/me is confused.
Upgraded to 3.0.1.
ls gives "möö", and I cheer and joy and frolic.
not for long: as soon as I try to open/read/write/play/delete/rename the file, the system claims it wasn't there at all:
"stat call: no such file or directory" (shoddy translation from german)

umm?

davidsrsb 01-20-2004 02:06 AM

Is the umlaute character allowed in a file name in older windows versions, this would need unicode.

dirstyGuy 01-20-2004 06:48 AM

Read the man mount or smbmount, there is a special section for nfs, must be also one section for samba/smb.

I remember to have read somewhere that the option could solve the character problem, "iocharset=utf8". Below is wut I put into my /etc/fstab.

/dev/hda1 /mnt/nt1 ntfs owner,noexec,nodev,nosuid,noauto,ro,iocharset=utf8 1 8

poison 01-20-2004 08:16 AM

the options for fstab you are looking for are:
iocharset=iso8859-1,codepage=cp850
like:
Code:

//<server>/<share> /mnt/<share> smbfs username=<user>,password=<pass>,workgroup=<workgroup>,iocharset=iso8859-1,codepage=cp850,rw,auto 0 0
iocharset is the charset you have on your local machine and codepage is the charset used on the server......it's almost guaranteed CP850 if you mention german umlauts ^^
another thing I've noticed is that this options gets regognized only if you check the option "Use a default NLS" in you kernel config ->
File systems ---> Network File Systems --->
<*> SMB file system support (to mount Windows shares etc.)[*] Use a default NLS
Default Remote NLS Option: "cp850"

regards =)

DexterF 01-20-2004 08:59 AM

That's just like my setup. Had some settings wrong in Samba, now I've got the old situation again:

I touch a file from client, umlaute are ok on client but not on server.
I touch a file from server, umlaute are ok on server but not on client.

Duh.

(btw, fast and good response here. thanks.)

poison 01-20-2004 09:37 AM

is you're SMB server linux or windows ?
if you're touch'ing you're probably running linux ?
well...then you probably can't use 2 different charsets for server<->client...^^

DexterF 01-21-2004 02:43 PM

yes, server is Slackware.
Thing is - *locally* everything is alright, it's only samba shares.
Is there a way to tell which coding is currently used on this and that filesystem if no mount option is given?

mathen 02-13-2004 04:49 PM

Hello,

simple add

character set = iso8859-1
client code page = cp850

to your server smb.conf


Best Regards,

Mathias


All times are GMT -5. The time now is 01:30 AM.