-   Slackware (
-   -   Samba share - root can write, no one else can (

Ook 10-29-2012 04:28 PM

Samba share - root can write, no one else can
I'm trying to set up a read/write share for a specific user. This is what my smb.conf entry looks like:

read only = no
path = /home/myuser
guest ok = no
browseable = no
valid users = myuser
security = user

I can mount the share just fine, but only root can write to it. A non-root user, including myuser, cannot write to it. What am I missing?

jv2112 10-30-2012 04:47 AM

writable = yes

Ook 10-31-2012 12:56 PM


Originally Posted by jv2112 (Post 4818005)
writable = yes

To make a long story short, I realized this morning that I could not write to *any* of my shares as non-root user. I eventually was led to this being a problem that could be easily solved by mounting as the non-root user, but then I ran into the only root can do that when trying to run mount. So I added the share to fstab, and then I ran into the rather infamous:

This program is not installed setuid root - "user" CIFS mounts not supported.

So I chmod u+s /sbin/mount.cifs so I can run mount as non-root user.

This works.

Is there a better solution? It's a bit of a pain having to add all of my shares to fstab, there are about a dozen or so that I connect to from time to time.

jv2112 11-01-2012 04:33 AM

You should not have to do that. :scratch: Do the path's in the shares have permissions set for the users you expect ? Are they all part of the same group ?

If the groups don't work for your situation you could always set up by specific user. The links below might be helpfull.

All times are GMT -5. The time now is 07:57 PM.