-   Slackware (
-   -   samba mount broke after upgrade (

spooge 03-07-2013 08:29 PM

samba mount broke after upgrade
since my upgrade to 14 my mount point won't mount.
in my 13.37 fstab i had
Code: /mnt/schmo      smbfs        user=schmo,password=passwd 0 0
and now i get an error

mount: unknown filesystem type 'smbfs'
dolphin and konkeror see the smb; from my server
nothing has change at my server

am i missing somethin?


willysr 03-07-2013 09:27 PM

Have you tried to run

slackpkg install-new
and see if you missed a package during upgrading?
Have a look on CHANGES_AND_HINTS to verify whether the new additions have been installed on your system

ponce 03-07-2013 10:22 PM

smbfs is deprecated, you should use cifs.

here I got this in /etc/fstab

// /media/share cifs user=myuser%mypassword,uid=1000,gid=100 0 0

spooge 03-08-2013 09:35 AM

CIFS, I take it I'll need this on my server(slak 12.x) as well

thanks for the reply

ponce 03-08-2013 09:41 AM

consider that cifs is a kernel module, so with older kernels than the one on slackware-14.0, 3.2.29, it depends on which modules you have available (the two, cifs and smbfs, are mutual exclusive).

spooge 03-08-2013 05:45 PM

thanks ponce,

// /media/share cifs user=myuser%mypassword,uid=1000,gid=100 0 0
this worked.

All times are GMT -5. The time now is 05:09 AM.