-   Slackware (
-   -   SalixOS: I disabled some services so no mouse with gpm plus no keyboard after startx? (

Holering 10-11-2010 12:59 AM

SalixOS: I disabled some services so no mouse with gpm plus no keyboard after startx?
I thought this would be the right place to post since salix is Slackware based.

Ok so I've installed SalixOS LXDE and thought it was the best thing but... After I disabled almost all services except syslog, dbus, and hald while inside lxde desktop. I rebooted and my mouse and keyboard no longer worked. So then I booted my Slackware install and edited /etc/inittab on the salix partition so I could boot into init 3 (I kinda like init 3 more than 4 anyway). Booted back into salix and keyboard seems to work but gpm doesn't... Gpm can't find any mouse so I do an lsmod and there's only about 4 modules loaded? Crap... So I dig around /etc/rc.d folder and I think it's got to do with me disabling the udev services when everything was fine after a fresh install...

I ran the init script for udev but it does nothing... I also ran pkgtool and went to setup, selected services and hit enter but it jumps back to the main menu?! I don't know if that's a glitch or what but it won't even let me pick the services with pkgtool...

So what can I do to change everything back to their default value? I only booted once into my new salix install, changed services, rebooted, and then problems...

I really loved the way everything was working on my first boot. Salix is one of those distro's that really gave me a happy feeling with linux so I'd really hate to stop using it over this one wrong thing I did...

So is there an easy way to change everything back to defaults?

veeall 10-11-2010 02:10 AM

Check that files in /etc/rc.d have executable bit set (set with "chmod +x FILENAME"). I guess disabling services in salix means simply making rc.* files unexecutable. You can use Tab-key autocompletion in bash to make typing easier. Or use mc to manage files and file permissions (F9 activates upper menu).

You can reinstall packages using slapt-get in command line.

gapan 10-11-2010 03:25 AM

You shouldn't have disabled udev. Of course devices won't work after that. As veeall noted, you can reenable it by running:

chmod +x /etc/rc.d/rc.udev
and then reboot.

In salix there are other alternatives to do the same too, you can run:

service start udev
or run

and you can reconfigure all services using the menus.

Holering 10-11-2010 03:56 AM

What's weird is that udev appeared to be starting up on every boot afterward but then again it was probly just an echo hiding what was really going on.

Yeah I thought I shouldn't have disabled that. I tried reinstalling from the livecd using load to ram. After setup partitioned the disk it hung at creating /etc/fstab...

So I'm gonna reinstall it later without load to ram. Then I'm gonna do the same thing I did to screw it up. Then I'm gonna try your solution. LOL

Don't worry I'm just doing it so I know how to fix it and I'm sure what you guys posted will fix it.

Oh and just so you know I'm running on 1gb of ram.

All times are GMT -5. The time now is 03:20 AM.