-   Slackware (
-   -   RT2870 wireless problem Slackware (

Bazzaah 11-05-2010 03:50 PM

RT2870 wireless problem Slackware

I've put this in here rather than networking as I think it's a Slackware issue, rather than a network problem.

I have a problem with Slackware64 current - my wireless connection grinds to a halt after about 5 minutes.

The problem is limited to USB dongles with the RT2870 chipset - a RT73 chipset runs fine. I've tested against Mandriva 32 bit LiveCD with the RT2870 chip and it runs just fine. So, I suspect the problem relates to the RT2870 in Slackware64.

Could someone help me work out how to determine what is wrong please? I've not blacklisted any modules in blacklist.conf so perhaps two drivers are fighting for control (but there can be only one)?

Thanks in advance for any help

Alien Bob 11-05-2010 04:22 PM

Does your card use the rt2800usb driver? If so, perhaps the first part of this older post of mine, also applies to you. Only in your case the staging driver will be the rt2870sta .


Bazzaah 11-05-2010 06:09 PM

Thanks for that - I did that and it seems more stable now, but is slower than it should be (I have a 40meg connection that gives me about 20megs on wireless) - I'll see how it goes over the next 24 hours.

Bazzaah 11-06-2010 04:06 AM

In retrospect, nothing worked so far. I've tried any number of fixes in various forums/wikis.

I'll try compiling the drivers that shipped with the card according to this link;

If that fails, I'll try some powerline adapters. This is starting to feel like a waste of time, all the more when the manufacturer actually provides driver and firmware support.

coralfang 11-13-2010 04:04 PM

Have you tried adding:

blacklist rt2800usb
blacklist rt2x00usb
blacklist rt2800lib
blacklist rt2x00lib

into your

It does the job for my ralink dongle which is:
ID 050d:8053 Belkin Components Ralink RT2870 [F5D8053 N Wireless USB Adapter v1000/v4000]

Took me a while to find that the other rt2*00 modules collide with the rt2870sta one. It might not be the same in your case, but you can always try. :hattip:

Seems to be the kernel itself, i end up having to blacklist those modules on any distro (since linux-2.6.31).

Hope it helps. Good luck!

All times are GMT -5. The time now is 08:02 PM.