-   Slackware (
-   -   rrdtool configure script failure slackware64-13 (

fancylad 03-25-2010 09:08 PM

rrdtool configure script failure slackware64-13
I am having a problem trying to compile rrdtool on slackware64-13. The problem is that the configure script keeps failing when it gets to the third party checks:


configure:30114: WARNING:
* I found a copy of pkgconfig, but there is no pangocairo.pc file around.
You may want to set the PKG_CONFIG_PATH variable to point to its

configure:30147: WARNING:
* I could not find a working copy of pangocairo. Check config.log for hints on why
this is the case. Maybe you need to set LDFLAGS and CPPFLAGS appropriately
so that compiler and the linker can find libpango-1.0 and its header files. If
you have not installed pangocairo, you can get it either from its original home on

You can find also find an archive copy on

The last tested version of pangocairo is 1.17.


I do have pkgconfig installed and the pangocairo.pc file does exist and I've tried setting PKG_CONFIG_PATH to /usr/lib64/pkgconfig/pangocairo.pc; however it just keeps failing at the same place. I do have libpango installed. I have also tried setting CFLAGS and LDFLAGS to include the headers for libpango and as well as the library. Again this does nothing. The weird part is that on my slackware64-current desktop rrdtool compiles no problem. I can even take the compiled slackware pkg from my desktop and run it on the slackware64-13 machine.

One more thing I should add is that my slackware64-13 is multi-lib enabled. I did this by following aliens's instructions:

I also made my slackware64-current machine multi-lib and tried compiling the rrdtool program and it doesn't have the same problems.

Any suggestions?

rfernandez 03-25-2010 09:36 PM

I'd say to point to de directory where pangocairo is, not the file itself.

fancylad 03-25-2010 10:11 PM

i should have been more clear. i tried that too:

export PKG_CONFIG_PATH='/usr/lib64/pkgconfig'

rfernandez 03-25-2010 10:15 PM

Have you also tried to add -lpangocairo to LIBS?

Honestly, if none of this works, I'm out of ideas. =/

fancylad 03-25-2010 10:37 PM

i believe i did. the server is at work so i'll have to check again tomorrow though. thanks.

fancylad 03-26-2010 09:52 AM

i managed to get rrdtool to work. i was missing the glib2 package and for some reason i had to set a bunch of environment variables:

CPPFLAGS=-I/usr/include/cairo -I/usr/include/libpng14 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/pango-1.0 -I/usr/include/cairo

LIBS=-lpangocairo-1.0 -lpango-1.0 -lpng14

not sure why this was necessary but it works. thanks rfernandez for you suggestion.

All times are GMT -5. The time now is 12:17 AM.