-   Slackware (
-   -   rMBP broadcom wireless not working in slack64 14.1 (

captkrill 04-26-2014 09:14 PM

rMBP broadcom wireless not working in slack64 14.1

After some grueling hours of triple booting my rMBP (early-2013; MacBookPro10,1) I finally was able to get clean installs of OS X 10.9.2, Win8.1x64 and Slack64 14.1 to run along side each other. One teensy problem, I have zero internet on slack.

1) Broadcom drivers (according to a lot of forums) generally suck.
2) There is no ethernet jack so I have to move between OS's/computers to download software & sadly, post this, heh
3) Thunderbolt port (thunderbolt to ethernet) doesn't work so I can not do any slack updates

This is what I have gathered so far:

As of kernel 3.2-rc3+ the broadcom driver wl.ko (which includes the broadcom 4331 device) is already included, just needs to load at start up.

I have made the b43xx_blacklist.conf that includes:

blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ssb

When loading into slack I found this line


wl: module license 'unspecified' taints kernel
Wicd/Network Manage (from extra folder on install dvd) is installed and works -assuming- as it should though it can't find any networks.

I found another forum suggesting to # blacklist bcma in place of wl.ko but that did not work either.

Any help would be greatly appreciated...

Bertman123 04-26-2014 10:33 PM

There's a slackbuild for the broadcom-sta driver. Try installing it using sbopkg. If you blacklisted the b43 and ssb modules you should have no problem installing that. I have the 4312 card and use the sta driver and have had no issues.

captkrill 04-26-2014 11:33 PM

rMBP broadcom wireless not working in slack64 14.1
Already tried it. Was my first thought to use the slackbuild. Same results btw.

Bertman123 04-27-2014 06:30 AM

I saw a post in the ubuntu forums saying that they used the b43 drivers. I'm not sure if this would help your situation or not.

captkrill 04-29-2014 11:19 AM

Hmm, well, I managed to get it working - somewhat. Fresh install of 14.1 (again), installed b43, b43 fcutter, and b43 firmware from slackbuilds.

I can finally run

iwconfig wlan0 up
iwlist wlan0 scan

It returns maybe 3 networks; taking it as a good sign. Here is where the "somewhat" comes into play. I cannot see any network in wicd nor can I add a hidden network manually.

Anything I should try?

Here is the dmesg output regarding the wireless device

[    6.086452] b43-phy0: Broadcom 4331 WLAN found (core revision 29)
[    6.087197] b43-phy0: Found PHY: Analog 9, Type 7 (HT), Revision 1
[    6.087827] apple_gmux: gmux device not present
[    6.088357] Broadcom 43xx driver loaded [ Features: PMNLS ]
[    6.094237] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'

Bertman123 04-29-2014 12:15 PM

Did you configure WICD correctly? You may need to go into properties and tell wicd that your wireless is using wlan0.

captkrill 04-29-2014 12:56 PM

I setup wlan0 in wicd properties, never had to do that one before, and now I can see *some* networks, but cant connect to any of them.

Bertman123 04-29-2014 04:02 PM

I prefer network manager over wicd myself as I usually had similar problems with it.

Try setting up network manage to see if you can get it to connect to the networks. That might narrow it down to an issue with wicd then and not some other issue.

ReaperX7 04-29-2014 09:37 PM

Yes, Wicd works but not for everyone. NetworkManager works a bit better in the case of Broadcom hardware usually.

As far as the STA vs B43 driver issue. One is the freeware driver the other is the OEM driver and both equally work. It doesn't matter if it "taints" the kernel. Plenty of OEM drivers taint the kernel because they are proprietary packages, but they are safe to use, so don't let that message fool you.

captkrill 04-30-2014 02:56 PM

Well I wiped my system clean of b43 completely. Reinstalled network manager from Aliens repo, reinstalled b43-fwcutter, broadcom-sta and b43-firmware from slackbuilds.

I am able to connect to a wireless network without it dropping, however it is god awful slow. Getting in the 13-19Kbps down coming from a 75Mbps pipe something definitely is wrong with that one.

Any ideas?


wlan0    IEEE 802.11bg  ESSID:"XXXXXXXX" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 9C:1C:12:18:8D:12 
          Bit Rate=24 Mb/s  Tx-Power=20 dBm 
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=0 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:10  Invalid misc:0  Missed beacon:0

Bertman123 04-30-2014 09:29 PM

with broadcom-sta installed you shouldn't need b43 at all. The sta is the only one I have installed and I also have b43 & ssb blacklisted.

captkrill 05-01-2014 03:36 PM

Alright this is getting more annoying than I care to admit, this is what I have so far.


#Blacklist B43 Drivers
blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ssb
#blacklist wl


bash-4.2# ifconfig
eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::2acf:e9ff:fe1d:cf61  prefixlen 64  scopeid 0x20<link>
        ether 28:cf:e9:1d:cf:61  txqueuelen 1000  (Ethernet)
        RX packets 30430  bytes 12123153 (11.5 MiB)
        RX errors 0  dropped 1692  overruns 0  frame 17781
        TX packets 9598  bytes 1682498 (1.6 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 577  bytes 51220 (50.0 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 577  bytes 51220 (50.0 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

I don't understand why it is showing what should be wlan0 as eth1...?


bash-4.2# iwconfig
eth1      IEEE 802.11abg  ESSID:"XXXXXXXXXXXXX" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:11:95:FA:01:10 
          Bit Rate=54 Mb/s  Tx-Power=200 dBm 
          Retry  long limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=10 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

lo        no wireless extensions.


bash-4.2# vi rc.modules-3.10.17
reading rc.modules-3.10.17
### Wifi Broadcom B43 Driver ###
#Wifi Driver
/sbin/modprobe b43

All of this combined as they are right now I can connect but it either drops to <1Kb/s speeds or tops out at 5Mb/s never gets the full bandwidth of my pipe (75M down / 50M up).

I know this card works fine in Win and OS X and gets the full speeds of the pipe on wireless.

If i #blacklist wl and comment the modprobe b43 module I get no internet at all, the card doesn't even recognize SSIDs previously used/saved.

Also, another great thing that came up, thunderbolt adapter no longer works. In the dmesg i can see that its leased a working IP but KDE Network Manager show it as not connected and nothing I do will force it to connect.doesnt

About ready to scrap the idea of slack on this Mac. Ubuntu had the wireless working almost immediately after install. (I only tried it for S&G's)

Any last thoughts, things to try etc?

Loomx 05-01-2014 09:41 PM


Any last thoughts, things to try etc?
Try running `lsmod' ; I found that despite blacklisting the `ssb' module, it kept being reinstalled.

In my notes I have this command, which I added to /etc/rc.d/rc.local to prevent the ssb module loading:

modprobe -r wl; modprobe -r ohci_hcd ; modprobe -r ssb; modprobe wl; modprobe ohci-hcd
You need to run it as one command, otherwise if you unload the ohci_hcd module you lose the keyboard...

I find the broadcom-sta driver from SBo to be the best one. I'm a bit confused by your rc.modules-3.10.17 file; are you loading the b43 driver too?

Oh, and I have always found the wireless interface to be `eth1' on a Macbook, for some reason.

lukameen 05-02-2014 07:19 AM

Quote: I don't understand why it is showing what should be wlan0 as eth1...?
You might also check the config in /etc/udev/rules.d/70-persistant-net.rules Sometimes they get switched and you have to manually edit the file to switch them back.

captkrill 05-02-2014 09:12 AM


bash-4.2# lsmod|grep ssb
ssb                    52104  1 b43
pcmcia                34628  2 b43,ssb
mmc_core              88717  4 b43,ssb,sdhci,sdhci_pci

This is after adding your line to stop the ssb module from loading.

I did notice at the end of Linux loading (did not show in dmesg) that it said its being used and threw a FATAL ERROR.


bash-4.2# rmmod ssb
rmmod: ERROR: Module ssb is in use by: b43

Also, as for the blacklist mix up, I just realized that too, however if I comment out b43 blacklist WiFi fails entirely.

All times are GMT -5. The time now is 08:29 AM.