-   Slackware (
-   -   Reset permissions (

spaceballs 03-01-2005 04:53 PM

Reset permissions
I must have done something stupid, and I can't quite figure out what it is. The problem is that I cannot su from my user. Fluxbox has problems bringing up a background, and no programs will run. The issue, in this noob's opinion, is that I cannot execute from /usr/bin and /bin. So I tried, as root:
chmod a+rx /bin/* and the same for /usr/bin, and nothing. What am I doing wrong? And is there a way to reset all permissions to the out of the box Slackware defaults?

mdarby 03-01-2005 05:14 PM

try (as root)

chmod -R 777 /bin && chown -R root:root /bin

spaceballs 03-01-2005 05:21 PM

Not yet
chmod -R 777 /bin && chown -R root:root /bin

I tried that and it still says permission denied. Right after a Slackware install, the permissions are right. Is there any way to bring back the default permissions in the same way they are established during a fresh install?

mdarby 03-01-2005 05:29 PM

That that I'm aware of, and I highly doubt it.
Are you running the above code as root?

spaceballs 03-01-2005 05:30 PM

Affirmatron. Should I try it as me?

zeekx4 03-01-2005 05:51 PM

Just a shot in the dark.

There's a rescue mode on the slackware installs. I don't remember the exact method, but it allows you to change the root password, and then should let you change permissions on all the drives without ever actually booting into your system.

Google it, I don't think I found it on this board, but I'm sure that one of the rescue tools can do what you need.

egag 03-01-2005 06:02 PM

there is a way:

Bourne Shell (sh) and sed script for generating a script to recover all of the filesystem permissions listed in the MANIFEST.gz file. Useful for restoring permissions after a botched restore from backup. Be sure to check permissions that are not "out of box"

get it here :


spaceballs 03-02-2005 03:36 PM

The problem was that udev was messed up. Now I have been updating to slackware-current, and I guess that I missed something. How could I have fixed this problem without reinstalling?

cathectic 03-02-2005 03:45 PM


How could I have fixed this problem without reinstalling?
Get hold of the 10.1 udev package then log in as root (if you can't su, log out then log in as root)

removepkg udev-054-i486-1
installpkg <name of old udev package>

and then restart

All times are GMT -5. The time now is 12:12 AM.