LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-13-2021, 08:59 AM   #7636
NonNonBa
Member
 
Registered: Aug 2010
Distribution: Slackware
Posts: 182

Rep: Reputation: Disabled

Are libmypaint and mypaint-brushes really bound to xorg or of a such general use for graphic applications, explaining why they are in x/? The Changelog says they were introduced as GIMP dependencies, therefore they would IMHO be in a better place in l/.
 
1 members found this post helpful.
Old 05-14-2021, 03:32 AM   #7637
franzen
Member
 
Registered: Nov 2012
Distribution: slackware
Posts: 393

Rep: Reputation: 262Reputation: 262Reputation: 262
Quote:
Originally Posted by M0M0 View Post
I'm not sure if someone has requested it so far: texlive 2021 was released in april
Here is the buildscript, waiting for approval: https://www.linuxquestions.org/quest...ml#post6247086
 
1 members found this post helpful.
Old 05-14-2021, 10:36 AM   #7638
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 651

Rep: Reputation: 317Reputation: 317Reputation: 317Reputation: 317
Quote:
Originally Posted by franzen View Post
Here is the buildscript, waiting for approval: https://www.linuxquestions.org/quest...ml#post6247086
Thanks!
Do you have equivalent scripts or packages for the corresponding newer texlive-extra and texlive-fonts ?
 
Old 05-15-2021, 01:53 AM   #7639
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current
Posts: 272
Blog Entries: 1

Rep: Reputation: Disabled
okular-21.04.1-x86_64-1.txz

From yesterday's update, okular cannot open a pdf:
Invalid plugin factory for "/usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so"
That poppler generator is part of the okular package. How can that plugin factory be invalid?
=-==--=-=
okular-git does not generate such errors.

Last edited by hpfeil; 05-15-2021 at 02:53 AM.
 
Old 05-15-2021, 02:54 AM   #7640
marav
Member
 
Registered: Sep 2018
Location: Paris, France
Distribution: Slackware
Posts: 345

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by hpfeil View Post
From yesterday's update, okular cannot open a pdf:
Invalid plugin factory for "/usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so"
That poppler generator is part of the okular package. How can that plugin factory be invalid?
I was able to reproduce by removing the poppler package
Code:
Package: poppler-21.05.0-x86_64-1
        Removing... 
Removing package: poppler-21.05.0-x86_64-1
15step :: ~ » cd Documents 
15step :: ~/Documents » okular 11527.pdf 
org.kde.okular.core: Invalid plugin factory for "/usr/lib64/qt5/plugins/okular/generators
/okularGenerator_poppler.so":"Impossible de charger la bibliothèque 
/usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so*: 
(libpoppler-qt5.so.1: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type)"
You propably need to (re)install poppler

Last edited by marav; 05-15-2021 at 02:58 AM.
 
Old 05-15-2021, 04:52 AM   #7641
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64-current
Posts: 585

Rep: Reputation: 229Reputation: 229Reputation: 229
Quote:
Originally Posted by hpfeil View Post
From yesterday's update, okular cannot open a pdf:
Invalid plugin factory for "/usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so"
That poppler generator is part of the okular package. How can that plugin factory be invalid?
=-==--=-=
okular-git does not generate such errors.
Do you have Eric's latest poppler-compat installed? Latest Okular works fine here.
 
Old 05-15-2021, 05:24 AM   #7642
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,922

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Quote:
Originally Posted by 3rensho View Post
Do you have Eric's latest poppler-compat installed? Latest Okular works fine here.
The poppler-compat package should not be needed as okular is a stock Slackware package and is built with the stock poppler 21.05.0

Okular work fine here with or without the poppler-compat package.

I think @marav nailed it with his post here
 
Old 05-15-2021, 09:09 AM   #7643
3rensho
Member
 
Registered: Mar 2008
Location: Switzerland
Distribution: Slackware64-current
Posts: 585

Rep: Reputation: 229Reputation: 229Reputation: 229
Quote:
Originally Posted by chrisretusn View Post
The poppler-compat package should not be needed as okular is a stock Slackware package and is built with the stock poppler 21.05.0

Okular work fine here with or without the poppler-compat package.
Correct, I hadn't thought that thru. Thanks for pointing that out.
 
Old 05-15-2021, 10:04 AM   #7644
opty
Member
 
Registered: Mar 2021
Posts: 44

Rep: Reputation: Disabled
Quote:
Originally Posted by marav View Post
Code:
15step :: ~/Documents » okular 11527.pdf 
org.kde.okular.core: Invalid plugin factory for "/usr/lib64/qt5/plugins/okular/generators
/okularGenerator_poppler.so":"Impossible de charger la bibliothèque 
/usr/lib64/qt5/plugins/okular/generators/okularGenerator_poppler.so*: 
(libpoppler-qt5.so.1: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type)"
Please consider using LANG=C next time.
 
3 members found this post helpful.
Old 05-15-2021, 10:06 AM   #7645
marav
Member
 
Registered: Sep 2018
Location: Paris, France
Distribution: Slackware
Posts: 345

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by opty View Post
Please consider using LANG=C next time.
Apart from the fact that it's irrelevant
You configure your system as you wish
Let me do the same, thanks

Last edited by marav; 05-15-2021 at 10:16 AM.
 
Old 05-15-2021, 10:16 AM   #7646
opty
Member
 
Registered: Mar 2021
Posts: 44

Rep: Reputation: Disabled
Quote:
Originally Posted by marav View Post
You configure your system as you wish
Let me do the same, thanks
Just temporarily for the sake of report so nobody has to use a translator.

Even only LC_MESSAGES=C should do.
 
3 members found this post helpful.
Old 05-15-2021, 10:24 AM   #7647
marav
Member
 
Registered: Sep 2018
Location: Paris, France
Distribution: Slackware
Posts: 345

Rep: Reputation: 198Reputation: 198
Quote:
Originally Posted by opty View Post
Just temporarily for the sake of report so nobody has to use a translator.

Even only LC_MESSAGES=C should do.
The rules on this forum is to speak in English, not to reconfigure your system
Well, I don't think so

Last edited by marav; 05-15-2021 at 10:30 AM.
 
1 members found this post helpful.
Old 05-15-2021, 11:53 AM   #7648
opty
Member
 
Registered: Mar 2021
Posts: 44

Rep: Reputation: Disabled
Quote:
Originally Posted by marav View Post
The rules on this forum is to speak in English, not to reconfigure your system
Well, I don't think so
You don't have to reconfigure your system:

Code:
15step :: ~/Documents » LC_MESSAGES=C okular 11527.pdf
Anyway, use whatever system messages' locale you want but don't wonder why you might get no help.
 
4 members found this post helpful.
Old 05-15-2021, 12:41 PM   #7649
hpfeil
Member
 
Registered: Nov 2010
Location: Tucson, Arizona US
Distribution: Slackware Current
Posts: 272
Blog Entries: 1

Rep: Reputation: Disabled
`ldd okularGenerator_poppler.so`:libpoppler.so.110 => not found

With /usr/lib64/libpoppler.so.109 installed, I obviously missed a l/poppler update. I'll go away now and soak my head in a pail of cold water....

Last edited by hpfeil; 05-15-2021 at 12:53 PM. Reason: added ldd results
 
Old 05-15-2021, 01:14 PM   #7650
ljb643
Member
 
Registered: Nov 2003
Posts: 494

Rep: Reputation: Disabled
Mousepad error after latest update

After the May 12 update to mousepad-0.5.5, it runs but produces this warning:

Code:
(mousepad:29323): Mousepad-WARNING **: 14:05:31.737: Failed to open plugin directory '/usr/lib64/mousepad/plugins': Error opening directory “/usr/lib64/mousepad/plugins”: No such file or directory
Creating an empty directory with that name stops the warning, but I think something is supposed to go in there from the 0.5.5 release.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Requests for -current (20151216) rworkman Slackware 3441 12-28-2017 03:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration