Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 11-20-2011, 09:20 AM   #1
Registered: Apr 2010
Distribution: Slackware32-13.37
Posts: 58

Rep: Reputation: 16
Requested 'gio-2.0 >= 2.25.9' but version of GIO is 2.22.5

I am trying to install google chrome under Slackware 13.1(32bit); to do that somehow I need to install GConf first, during which the following error occurs. Any advice would be appreciated...

configure: error: Package requirements (glib-2.0 > 2.14.0 gio-2.0 >= 2.25.9 gthread-2.0 gmodule-2.0 >= 2.7.0 gobject-2.0 >= 2.7.0 ORBit-2.0 >= 2.4.0) were not met:

Requested 'gio-2.0 >= 2.25.9' but version of GIO is 2.22.5

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEPENDENT_CFLAGS
and DEPENDENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
So, if a upgrade is needed, which package should I install? I did not find any package named Gio. Or if, as suggested in the error message, some change in the environment variable should be made, what is that?

Last edited by seflyer; 11-20-2011 at 09:23 AM.
Old 11-20-2011, 11:11 AM   #2
Registered: Jul 2007
Location: Belgium
Distribution: slackware64 13.1, slackware 13.1
Posts: 369

Rep: Reputation: 49
janhe@computer:~$ pkg-config --list-all | grep gio
gio-2.0                     GIO - glib I/O library
gio-unix-2.0                GIO unix specific APIs - unix specific headers for glib I/O library
This was executed on Slackware 13.37

It looks like the version of glib2 in slackware 13.1 is too old for your chrome release. (Or the other way around, you try to install a version of chrome that is too recent.)

AFAIK, you cannot simply upgrade glib, you will need to upgrade your Slackware. 13.37 has glib2-2.28.6
1 members found this post helpful.
Old 11-20-2011, 08:25 PM   #3
Registered: Apr 2010
Distribution: Slackware32-13.37
Posts: 58

Original Poster
Rep: Reputation: 16
Thanks janhe, if it is so I guess I would first give the latest Firefox a try...

Turns out that an older GConf(2.28, instead of the latest version 2.32) would fix the problem.
Latest GConf requires the latest glib.

Last edited by seflyer; 11-28-2011 at 10:49 PM.
Old 11-28-2011, 10:51 PM   #4
Registered: Apr 2010
Distribution: Slackware32-13.37
Posts: 58

Original Poster
Rep: Reputation: 16
I found this only after I upgraded slackware to 13.37 at home. But at least I can get along well with 13.1 at the lab now.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
GLib-GIO-CRITICAL faizlo Linux - Software 2 11-29-2010 10:55 PM
ImportError: could not import gio Glenn D. Linux - Software 0 02-16-2010 04:10 AM
[SOLVED] abiword-2.8.1: Make error "gsf/gsf-input-gio.h: No such file or directory" aes canis Slackware 9 12-01-2009 01:58 PM
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 02:54 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:29 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration