-   Slackware (
-   -   Request to jwm users to try a little test (

jimv 05-22-2013 06:03 PM

Request to jwm users to try a little test

I'm using Slackware 14.0 (w/kernel 3.8.13) and jwm as my window manager. I've noticed an odd behavior that I believe is caused by jwm. When I open a jpg image with Imagemagick's "display" program. I am ONLY able to use the menus ONCE. That is: if I edit the image (say adjust the the gamma) I click enhance -> gamma and everything is OK. BUT, if I try to select another menu item like file -> save, nothing happens.

I have seen this on multiple computers with very different processors and graphics chip sets BUT ONLY when using jwm. Icewm and twm work fine. I've tried both the latest stable and development versions of jwm.

I would like to ask a jwm user to open an image with "display" and try to do "2" things to it.... like my "gamma" and "save" example above.

Thank you...


Edit 1: Did I mention the "display" is part of the standard Slackware install? I would really appreciate if some one could help me out here ... just as a sanity check for me if nothing else.

lacadaisical 05-24-2013 04:01 PM

Hi jim

I can replicate the same error by installing JWM r733 into a vanilla SLW-14.0.
You are not alone...

I suggest a mail to (JWM creator).

I use JWM exclusively myself - it does everything I need in a WM in ~320k. However I don't use imagemagick in my own system but I may try it later for comparison.

tuxbg 05-25-2013 04:51 AM

Same problem here.

jimv 05-25-2013 01:18 PM

Thanks lacadaisical and tuxbg....

I like jwm for it's small size and functionality too. I will email joewing today. I do use imagemagick so will have to switch to icewm until this is sorted out.


jimv 05-26-2013 05:15 PM

I just received a response from He sorted things out and JWM development version 762 has the fix.

Joe wrote: "JWM was not reparenting windows that were unmapped, which isn't usually a problem, but apparently ImageMagick reuses those windows in its menus."

Anyway, I've marked this thread as solved.

Thank you for helping test...


All times are GMT -5. The time now is 09:49 AM.