-   Slackware (
-   -   Replacing Mandrake with Slack on a Panasonic Toughbook (

erraticassassin 07-03-2004 03:22 PM

Replacing Mandrake with Slack on a Panasonic Toughbook
I've just bought myself an old Panasonic Toughbook laptop: 233MHz processor, 5gb hard drive, 160Mb ram. At the moment I'm running Mandrake 9.2, using Fluxbox for the window manager and Rox-Filer as a file manager. Booting is quite slow and some programs take a while to start, but it is pretty useable, even with something like (And it's a Toughbook. Magnesium alloy casing. Dude, I have an armoured laptop. How cool is that?)

I'd like to replace Mandrake with Slack 9.1, but when I tried to install it I got an error message saying LILO couldn't be installed to the MBR. I would use a boot floppy, but I don't have a floppy drive on the laptop - all I have is a DVD-ROM. When I tried to boot I got a string of 99s, so I reinstalled Mandrake for the time being.

Given that the Mandrake bootloader is installed and works fine, presumably I could alter its config file, install Slack using the existing Mandrake partitions, and point the bootloader at the fresh Slack install... couldn't I? It would be a bit of an ugly hack, I know, but I just want to use the laptop for word processing - I don't really want to spend ages fine-tuning it and getting it juuust right...

If anyone has any suggestions or comments, that would be groovy... I've collated a few forum threads that might be useful and printed them off, but it would be nice for someone to confirm I'm at least looking in the right area.

* NB - I've previously posted this as a comment on the "Slackware Package????" thread, so don't worry if you're having a little deja vu. *

keefaz 07-03-2004 06:22 PM

I think mandrake bootloader can be fine, backup its config file somewhere and note its path, later after slackware install, just restore bootloader config in the proper path, take care to skip lilo install of course.

sio 07-03-2004 07:11 PM

Reinstall slack on your system. You can try to install Lilo again to the mbr, if it fails dont worry about it. After the install is done leave the install cd in the drive and reboot.

It'll want to boot from the cd again. You want to do this :D

I forget how it goes but it basically tells you what to type on screen. Assuming that the hardrive is hda ( dunno anything about laptops ) youd type something to the effect of

bare.i mount root=/dev/hda1 noinitrd ro

This will mount your linux system. Your lilo.conf should already be setup in /etc/lilo.conf from the slack setup.

After bootup, login as root with whatever password you setup during setup and type

$ lilo -A /dev/hda # will activate the partition you set as bootable if it needs to be
$ lilo # will make sure you dont have errors in your lilo.conf
$ lilo -M /dev/hda -mbr # will update your master boot record and actually work!

During setup in my experience doing the easy install of lilo has worked for me 1 out of 10 times if that hard drive had something else on the mbr. At first id fix it by booting up with a win disk and fdisk /mbr but then i found the above works just fine. Also the expert install of lilo ( dunno why ) seems to work a whole lot better for me to. Only failed maybe 1 out of 8 times for me thus far ( in which i did the above )

erraticassassin 07-04-2004 04:34 AM

Much obliged, dudes. I've printed your responses - once I've finished trawling the forums, I'll have a bash at reinstalling Slack. Then all I have to do is load my fave programs, configure it for printing, and I'll be away! Stardom beckons.

Thanks again...

sio 07-04-2004 08:37 AM

O yeah &

[spoken in old dell commercial]
Dude.. You got a Toughbook :D

erraticassassin 07-04-2004 01:49 PM

Yeah. I call it The Beast. It's, like, Laptopzilla. :D

Strangely enough, when I reinstalled Slack, it installed LILO to the MBR without so much as a whimper. Computers, eh?

Meh. *shrugs* At least it works now. I've got my favourite core applications running, but there's still plenty left to tinker with...

All times are GMT -5. The time now is 07:12 AM.